<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blogcritics.org/xmlrpc.php" />
<title>Interview: Rikki Rockett, Drummer for Poison | Blogcritics</title>
<meta property="og:title" content="Interview: Rikki Rockett, Drummer for Poison - Blogcritics"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Last month in California, Poison launched a new tour, Nothin’ But a Good Time 2018. The title is not"/>
<meta property="og:url" content="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/"/>
<meta property="og:site_name" content="Blogcritics"/>
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2018/06/Poison_Featured-600x330.jpg" />

<!-- This site is optimized with the Yoast SEO plugin v7.5.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Interview: Rikki Rockett, Drummer for Poison | Blogcritics" />
<meta property="og:description" content="Currently on Poison&#039;s new tour, Rikki Rockett shared stories about his motorcycle vlog and why the album &#039;Open Up and Say... Ahh!&#039; was so crucial to success." />
<meta property="og:url" content="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/" />
<meta property="og:site_name" content="Blogcritics" />
<meta property="article:publisher" content="https://www.facebook.com/blogcritics/" />
<meta property="article:tag" content="drummer" />
<meta property="article:tag" content="Open Up and Say...Ahh" />
<meta property="article:tag" content="Poison" />
<meta property="article:tag" content="Rikki Rockett" />
<meta property="article:tag" content="Rockett Vlog" />
<meta property="article:section" content="Music" />
<meta property="article:published_time" content="2018-06-07T00:01:25-04:00" />
<meta property="article:modified_time" content="2018-06-07T00:08:00-04:00" />
<meta property="og:updated_time" content="2018-06-07T00:08:00-04:00" />
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2018/06/Poison_Featured.jpg" />
<meta property="og:image:secure_url" content="https://blogcritics.org/wp-content/uploads/2018/06/Poison_Featured.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="348" />
<meta property="og:image:alt" content="Photo of the rock band Poison" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Currently on Poison&#039;s new tour, Rikki Rockett shared stories about his motorcycle vlog and why the album &#039;Open Up and Say... Ahh!&#039; was so crucial to success." />
<meta name="twitter:title" content="Interview: Rikki Rockett, Drummer for Poison | Blogcritics" />
<meta name="twitter:site" content="@blogcritics" />
<meta name="twitter:image" content="https://blogcritics.org/wp-content/uploads/2018/06/Poison_Featured.jpg" />
<meta name="twitter:creator" content="@PCuad24" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Feed" href="https://blogcritics.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Comments Feed" href="https://blogcritics.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Interview: Rikki Rockett, Drummer for Poison Comments Feed" href="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blogcritics.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://blogcritics.org/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-slick-style-css'  href='https://blogcritics.org/wp-content/plugins/wp-trending-post-slider-and-widget/assets/css/slick.css' type='text/css' media='all' />
<link rel='stylesheet' id='wtpsw-public-style-css'  href='https://blogcritics.org/wp-content/plugins/wp-trending-post-slider-and-widget/assets/css/wtpsw-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://blogcritics.org/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://blogcritics.org/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tieViewsCacheL10n = {"admin_ajax_url":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","post_id":"5487642"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/postviews-cache.js'></script>
<link rel='https://api.w.org/' href='https://blogcritics.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogcritics.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blogcritics.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://blogcritics.org/?p=5487642' />
<link rel="alternate" type="application/json+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Finterview-rikki-rockett-drummer-for-poison%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Finterview-rikki-rockett-drummer-for-poison%2F&#038;format=xml" />
<meta name="framework" content="Alkivia Framework 0.8" />
<link rel="shortcut icon" href="http://blogcritics.org/wp-content/uploads/2017/09/favicon.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://blogcritics.org/wp-content/uploads/2017/09/apple-touch-icon.png" />

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '480525602401175'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=480525602401175&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->

<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #7f0000;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#7f0000;
}

::-webkit-scrollbar-thumb{
	background-color:#7f0000 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #7f0000;
}

.search-block:after {
	border-right-color:#7f0000;
}

body.rtl .search-block:after {
	border-left-color:#7f0000;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #7f0000;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #7f0000;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #7f0000;
	border-color: #7f0000;
}

#order_review,
#order_review_heading {
	border-color: #7f0000;
}


a {
	color: #7f0000;
}
		
a:hover {
	color: #806060;
}
		
.top-nav ul li a:hover, .top-nav ul li:hover > a, .top-nav ul :hover > a , .top-nav ul li.current-menu-item a {
	color: #7f0000;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/blogcritics.org\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>
<!-- BEGIN GADWP v5.3.3 Universal Analytics - https://exactmetrics.com/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-1811558-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
</head>
<body id="top" class="post-template-default single single-post postid-5487642 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://blogcritics.org/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Thursday , June 7 2018</span>
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-5264769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264769"><a href="/contact/">Contact Us</a></li>
<li id="menu-item-5264771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264771"><a href="/write-for-blogcritics/">Writer Sign Up</a></li>
<li id="menu-item-5264773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264773"><a href="/about/">About</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://blogcritics.org/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="Blogcritics" href="https://blogcritics.org/">
					<img src="http://blogcritics.org/wp-content/uploads/2017/10/blogcritics-logo190px.jpg" alt="Blogcritics"  /><strong>Blogcritics The critical lens on today&#039;s culture &amp; entertainment</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan e3lan-top">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=247310&width=728&height=90"></script> 				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-5264473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264473"><a href="/">Home</a></li>
<li id="menu-item-5367196" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5367196"><a href="https://blogcritics.org/category/editor-picks/">Editor Picks</a></li>
<li id="menu-item-5264475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264475"><a href="https://blogcritics.org/category/tv/">TV</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5265485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265485"><a href="https://blogcritics.org/category/tv/tv-reviews-recaps/">Reviews &#038; Recaps</a></li>
	<li id="menu-item-5265515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265515"><a href="https://blogcritics.org/category/tv/interviews-tv/">Interviews</a></li>
	<li id="menu-item-5274805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5274805"><a href="https://blogcritics.org/category/film/columns-film/">Weekly TV Coverage</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5267599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267599"><a href="https://blogcritics.org/category/tv/tv-columns/gleekonomics/">Gleekonomics</a></li>
		<li id="menu-item-5267603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267603"><a href="https://blogcritics.org/category/tv/tv-columns/jeroming-the-tv-landscape/">Jeroming the TV Landscape</a></li>
		<li id="menu-item-5340221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5340221"><a href="https://blogcritics.org/category/tv/tv-columns/the-gallifreyian-groupie/">The Gallifreyan Groupie</a></li>
		<li id="menu-item-5267607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267607"><a href="https://blogcritics.org/category/tv/tv-columns/once-upon-a-time/">Once Upon a Time&#8230;There Was a Place Called Storybrooke</a></li>
		<li id="menu-item-5295573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5295573"><a href="https://blogcritics.org/category/tv/tv-columns/lets-talk-tv-with-barbara-barnett/">Let&#8217;s Talk TV with Barbara Barnett</a></li>
		<li id="menu-item-5267597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267597"><a href="https://blogcritics.org/category/tv/tv-columns/supernatural/">Supernatural Musings</a></li>
		<li id="menu-item-5267601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267601"><a href="https://blogcritics.org/category/tv/tv-columns/idol-wired/">Idol Wired</a></li>
		<li id="menu-item-5267609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267609"><a href="https://blogcritics.org/category/tv/tv-columns/sci-fi-primetime/">Sci-Fi Primetime</a></li>
		<li id="menu-item-5267605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267605"><a href="https://blogcritics.org/category/tv/tv-columns/mad-men-confidential/">Mad Men Confidential</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-5264553" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264553"><a href="https://blogcritics.org/category/music/">Music</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264585"><a href="https://blogcritics.org/category/music/reviews-music/">Reviews music</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5277445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277445"><a href="https://blogcritics.org/category/music/reviews-music/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-5264589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264589"><a href="https://blogcritics.org/category/music/reviews-music/concert-reviews/">Concert Reviews</a></li>
		<li id="menu-item-5277447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277447"><a href="https://blogcritics.org/category/music/reviews-music/music-dvd-blu-ray-reviews/">Music DVD &#038; Blu-ray Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-5264577" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5264577"><a href="https://blogcritics.org/category/music/interviews-music/">Interviews music</a></li>
</ul>
</li>
<li id="menu-item-5264599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264599"><a href="https://blogcritics.org/category/books/">Books</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264625"><a href="https://blogcritics.org/category/books/reviews-books/">Book Reviews</a></li>
	<li id="menu-item-5265519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265519"><a href="https://blogcritics.org/category/books/book-interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-5264731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264731"><a href="https://blogcritics.org/category/gaming/">Gaming</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264745"><a href="https://blogcritics.org/category/gaming/gaming-reviews/">Gaming Reviews</a></li>
	<li id="menu-item-5264743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264743"><a href="https://blogcritics.org/category/gaming/previews/">Previews</a></li>
	<li id="menu-item-5264741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264741"><a href="https://blogcritics.org/category/gaming/conferences/">Conferences</a></li>
</ul>
</li>
<li id="menu-item-5264641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264641"><a href="https://blogcritics.org/category/culture/">Culture and Society</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264647"><a href="https://blogcritics.org/category/culture/arts/">Arts</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5275059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275059"><a href="https://blogcritics.org/category/culture/arts/cabaret/">Cabaret</a></li>
		<li id="menu-item-5275061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275061"><a href="https://blogcritics.org/category/culture/arts/dance/">Dance</a></li>
		<li id="menu-item-5275063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275063"><a href="https://blogcritics.org/category/culture/arts/opera-arts/">Opera</a></li>
		<li id="menu-item-5275067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275067"><a href="https://blogcritics.org/category/culture/arts/theater/">Theater</a></li>
	</ul>
</li>
	<li id="menu-item-5292699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5292699"><a href="https://blogcritics.org/category/culture/culture-columns/">Culture Columns</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5292701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292701"><a href="https://blogcritics.org/category/culture/culture-columns/ending-world-hunger/">Ending World Hunger</a></li>
		<li id="menu-item-5443149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5443149"><a href="https://blogcritics.org/category/culture/culture-columns/language-matters/">Language Matters</a></li>
		<li id="menu-item-5292703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292703"><a href="https://blogcritics.org/category/culture/culture-columns/hometown-heroes-culture-columns/">Hometown Heroes</a></li>
	</ul>
</li>
	<li id="menu-item-5264643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264643"><a href="https://blogcritics.org/category/culture/politics/">Politics</a></li>
	<li id="menu-item-5264659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264659"><a href="https://blogcritics.org/category/culture/travel/">Travel</a></li>
	<li id="menu-item-5264661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264661"><a href="https://blogcritics.org/category/culture/scitech/">Science and Technology</a></li>
	<li id="menu-item-5264645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264645"><a href="https://blogcritics.org/category/culture/sports/">Sports</a></li>
	<li id="menu-item-5264663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264663"><a href="https://blogcritics.org/category/culture/spirituality/">Spirituality</a></li>
	<li id="menu-item-5264657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264657"><a href="https://blogcritics.org/category/culture/tips-and-advice/">Tips and Advice</a></li>
	<li id="menu-item-5439149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5439149"><a href="https://blogcritics.org/category/culture/personalfinance/">Personal Finance</a></li>
	<li id="menu-item-5264655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264655"><a href="https://blogcritics.org/category/culture/health-and-fitness/">Health and Fitness</a></li>
	<li id="menu-item-5264653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264653"><a href="https://blogcritics.org/category/culture/food-and-drink/">Food and Drink</a></li>
</ul>
</li>
<li id="menu-item-5264679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264679"><a href="https://blogcritics.org/category/film/">Film</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264711"><a href="https://blogcritics.org/category/film/reviews-film/">Reviews film</a></li>
	<li id="menu-item-5264685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264685"><a href="https://blogcritics.org/category/film/interviews-film/">Interviews film</a></li>
</ul>
</li>
<li id="menu-item-5406273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5406273"><a href="https://blogcritics.org/category/flash-fiction-2/">Flash Fiction</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://blogcritics.org">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://blogcritics.org/category/editor-picks/">Editor Picks</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://blogcritics.org/category/editor-picks/music-picks/">Editor Pick: Music</a></span> <span class="delimiter">/</span> <span class="current">Interview: Rikki Rockett, Drummer for Poison</span></div>
		

		
		<article class="post-listing post-5487642 post type-post status-publish format-standard has-post-thumbnail  category-music-picks category-editor-picks category-interviews-music category-music category-music-genres category-rock tag-drummer tag-open-up-and-say-ahh tag-poison tag-rikki-rockett tag-rockett-vlog" id="the-post">
			
			<div class="single-post-thumb">
			<img width="600" height="330" src="https://blogcritics.org/wp-content/uploads/2018/06/Poison_Featured-600x330.jpg" class="attachment-slider size-slider wp-post-image" alt="Photo of the rock band Poison" />		</div>
	
		<div class="single-post-caption">Original Poison Band members Rikki Rockett, Bobby Dall, Bret Michaels, and CC DeVille (Credit: Mark Weiss)</div> 


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Interview: Rikki Rockett, Drummer for Poison</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://blogcritics.org/author/pcuad24/" title="">Pat Cuadros </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>8 hours ago</span>	
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/#respond"><span class="dsq-postid" data-dsqidentifier="5487642 https://blogcritics.org/?p=5487642">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>17 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					<div class="share-post">
	<span class="share-text">Share</span>
	
		<script>
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 	'fbjssdk' );
		load('https://apis.google.com/js/plusone.js', 		'gplus1js');
		load('//platform.twitter.com/widgets.js', 			'tweetjs' );
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
	<ul class="normal-social">	
			<li>
			<div class="fb-like" data-href="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
		</li>
		
			<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/" data-text="Interview: Rikki Rockett, Drummer for Poison" data-via="" data-lang="en">tweet</a></li>
				<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/"></div></li>
				<li><su:badge layout="2" location="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/"></su:badge>
			<script type="text/javascript">
				(function() {
					var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true;
					li.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//platform.stumbleupon.com/1/widgets.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s);
				})();
			</script>
		</li>
				<li><script src="https://platform.linkedin.com/in.js" type="text/javascript"></script><script type="IN/Share" data-url="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/" data-counter="right"></script></li>
				<li style="width:80px;"><script type="text/javascript" src="https://assets.pinterest.com/js/pinit.js"></script><a href="http://pinterest.com/pin/create/button/?url=https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/&amp;media=https://blogcritics.org/wp-content/uploads/2018/06/Poison_Featured-600x330.jpg" class="pin-it-button" count-layout="horizontal"><img border="0" src="https://assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->
						<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-review-hungry-march-band-running-through-with-the-sadness/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2018/06/Hungry-March-Band2-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Hungry March Band" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-review-hungry-march-band-running-through-with-the-sadness/" rel="bookmark">Music Review: Hungry March Band – ‘Running Through with the Sadness’</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>14 hours ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-review-suki-rae-cant-stop-now-disappoints/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2018/06/Suki-Rae-2-1-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Suki Rae" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-review-suki-rae-cant-stop-now-disappoints/" rel="bookmark">Music Review: Suki Rae – ‘Can’t Stop Now’ Disappoints</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>16 hours ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/movie-review-leigh-whannells-computer-powered-upgrade/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2018/06/maxresdefault-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/movie-review-leigh-whannells-computer-powered-upgrade/" rel="bookmark">Movie Review: Leigh Whannell&#8217;s Computer-Powered &#8216;Upgrade&#8217;</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>1 day ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
					<p>Last month in California, Poison launched a new tour, <a href="http://www.poisonofficial.com/">Nothin’ But a Good Time 2018</a>. The title is not only an apt reference to one of Poison&#8217;s most iconic tracks, but a promise about what fans will get from the experience. The legendary and high energy rock band is touring with special guests Cheap Trick and Pop Evil. Poison drummer Rikki Rockett called me this week for a quick chat about drumming, motorcycle vlogging, and a very important anniversary.</p>
<p><strong>In music, who were a couple of your early inspirations?</strong></p>
<p>If I start from the very beginning, of course, it was my sister&#8217;s Beatles records, my mom&#8217;s Elvis records, and my dad&#8217;s Santana records. That was influential to me to make it that I wanted to keep exploring music more. I would say those three things were critical.</p>
<p><strong>Do you play other instruments?</strong></p>
<p>I can play guitar well enough to get by, to write a song, and get an idea across, but I certainly wouldn&#8217;t be able join a band doing that. (laughs) I guess I could play bass enough to get by.</p>
<p><strong>When did you realize you wanted to be a drummer?</strong></p>
<p>When I tried trumpet and I went, &#8220;No, this isn&#8217;t working.&#8221; Every time I&#8217;d go to see a live band of any kind, it was always the drummer I focused on. I was always just blown away with that instrument. I knew that&#8217;s what I wanted to do.</p><div class='code-block code-block-1' style='margin: 8px auto 8px 0; text-align: left; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="8538825723"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<p><strong>Was there a particular aspect that drew you in? </strong></p>
<p>It was so loud! This instrument was producing all this volume. I felt like the guys were casually hitting the drums. You know what I mean? Today, people are trying to beat the shit out of their drums. In those days, seeing those old guys doing standards &#8230; the sounds they were producing from cylinders! I don&#8217;t know what was going through my little 10-year-old head back then, but it was something like that. It&#8217;s physical and I&#8217;ve always been a little more physical.</p>
<p><strong>Since we&#8217;re talking about physicality, do you have a workout routine?</strong></p>
<p>I&#8217;m a black belt in Brazilian Jiu-Jitsu so that fight game is such a chess match. I do think drums are 50 percent mental and 50 percent is physical. I tend to choose things in life that are sort of like that.</p>
<p><strong>Do you have a favorite tour stop?</strong></p>
<p>I don&#8217;t have a particularly favorite stop like in terms of the audience. I really love our fans everywhere. There are certain places I like to go, like one of my favorite camera shops in Chicago for example. Things like that become a favorite. The fans aren&#8217;t better somewhere than in the other places.</p>
<p><strong>I read you bought your first Harley in the late 1980s. Do you still have that bike?</strong></p>
<p>No, I do not have that bike anymore. It got stolen, believe it or not. I have seven motorcycles right now, everything ranging from my British bikes up to an Indian that I have out on the road with me right now. Motorcycling is a big part of my life. I have a vlog called <a href="https://www.youtube.com/user/rikkirockett/">&#8220;Rockett Vlog</a>&#8221; that is pretty much motorcycle-centric. Most of the things that I do in the vlog have to do with either traveling on the motorcycle or installing something on a motorcycle. Not always, sometimes I go astray in my studio or something like that. I&#8217;m a YouTuber.</p>
<p>I just did one [vlog] in Texarkana. It&#8217;s where there was a series of murders in 1946 that spawned urban legends. I dedicated that vlog to that and I went visiting the spot where it first happened. If people like true crime, that one is pretty fun. Motorcycles and true crime? Then they&#8217;re really going to love that one.</p>
<p><strong>It&#8217;s been 30 years since the release of <em>Open Up and Say&#8230; Ahh!</em>. How do you feel about making the album and reaching this milestone?</strong></p>
<p>I think that album is pivotal because they say that it takes your whole life to write your first record and two months to write your second. That&#8217;s why people flop on their second record. Everybody was looking for that sophomore flop out of us at that time. They were like, &#8220;Oh, Poison&#8217;s done well but they won&#8217;t be able to repeat that again.&#8221;</p>
<p>That album was even bigger than the first record. It was monumental in that respect. That was our first real record, not like &#8230;<i>Cat Dragged In</i> wasn&#8217;t a real record, but it was so rushed that it was almost like a glorified demo. There&#8217;s a certain magic to it because of that. It was raw and needed to happen now. I feel like the second one was where we really got to examine the songs and take our time instead of what we had to settle for.</p>
<p><strong>What would you like to see in the future for Poison?</strong></p>
<p>I hope we continue to play. I&#8217;d love for us to do some more material. I don&#8217;t have an announcement about that right now, but I&#8217;d love for that to happen. I&#8217;m just happy to go and continue to do this for a living.</p>
<p><strong>Is there anything else you&#8217;d like to share?</strong></p>
<p>I&#8217;d love to spread love to our fans everywhere. I know people sort of say that off the cuff, but at this point of 32 years, we haven&#8217;t put anything out really in a while. It&#8217;s clearly the fans that are the reason we&#8217;re still here. And it always is. Any band that doesn&#8217;t embrace their fans all the way are really missing the point.</p>
<p><iframe width="618" height="348" src="https://www.youtube.com/embed/3Hdu4_ha66Q?feature=oembed" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe></p>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://blogcritics.org/tag/drummer/" rel="tag">drummer</a> <a href="https://blogcritics.org/tag/open-up-and-say-ahh/" rel="tag">Open Up and Say...Ahh</a> <a href="https://blogcritics.org/tag/poison/" rel="tag">Poison</a> <a href="https://blogcritics.org/tag/rikki-rockett/" rel="tag">Rikki Rockett</a> <a href="https://blogcritics.org/tag/rockett-vlog/" rel="tag">Rockett Vlog</a></p>

		<div class="e3lan e3lan-post">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=247310&width=728&height=90"></script> 				</div>
				<section id="author-box">
			<div class="block-head">
				<h3>About Pat Cuadros </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/3dd9df766c0d632afd736e22c2ee9281?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/3dd9df766c0d632afd736e22c2ee9281?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' />	</div><!-- #author-avatar -->
			<div class="author-description">
						Pat Cuadros is a young professional aspiring toward a career in media. In addition to film and television reviews, she focuses primarily on events in Washington, D.C. Highlights in Pat's blogging adventures include meeting Peter Capaldi and Stan Lee, as well as interviews with Kiefer Sutherland and Robert Carlyle. In 2017, she made her debut as an Awesome Con moderator, managing a Q&amp;A for voice actors Sean Schemmel and Christopher Sabat. Pat earned a B.A. in Art History on a full scholarship at the University of Virginia.		</div><!-- #author-description -->
			<div class="author-social flat-social">
												<a class="social-twitter" target="_blank" href="http://twitter.com/PCuad24"><i class="fa fa-twitter"></i><span> @PCuad24</span></a>
												<a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/patcuadros"><i class="fa fa-linkedin"></i></a>
									<a class="social-flickr" target="_blank" href="https://www.flickr.com/photos/135366261@N07/"><i class="fa fa-flickr"></i></a>
																		<a class="social-instagram" target="_blank" href="https://instagram.com/patcuadros/"><i class="fa fa-instagram"></i></a>
					</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

		
		
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<h2 class="post-title"><a href="https://blogcritics.org/book-review-silent-creed-a-ryder-creed-novel-by-alex-kava/" rel="bookmark">Book Review: &#8216;Silent Creed,&#8217; A Ryder Creed Novel by Alex Kava</a></h2>
			<p> With 'Silent Creed' Alex Kava takes us into hidden agendas and possible terror circles as she moves the pawns in the game of life as she sees it. </p>
		</div>
			</section>
			
			
	
		
		
<div id="disqus_thread"></div>

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="ads300_250-widget-2" class="widget e3lan e3lan300_250-widget"><div class="widget-top"><h4> Advertisement</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div  class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar Widget Top -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="9541788348"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
				</div>
	</div></div><!-- .widget /--><div id="wtpsw-post-list-widget-2" class="widget wtpsw_post_list_widget"><h3 class="widget-title">Trending</h3>

<div class="wtpsw-post-items">
    <ul>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/art-review-georgia-okeeffe-visions-of-hawaii-at-new-york-botanical-garden/" title="Art Review: &#8216;Georgia O&#8217;Keeffe: Visions of Hawai&#8217;i&#8217; at New York Botanical Garden">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2018/05/IMG_2667-1-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="NYBG, Georgia O&#039;Keeffe: Visions of Hawai&#039;i, Hawai&#039;i, Georgia O&#039;Keeffe" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/art-review-georgia-okeeffe-visions-of-hawaii-at-new-york-botanical-garden/" title="Art Review: &#8216;Georgia O&#8217;Keeffe: Visions of Hawai&#8217;i&#8217; at New York Botanical Garden">Art Review: &#8216;Georgia O&#8217;Keeffe: Visions of Hawai&#8217;i&#8217; at New York Botanical Garden</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        'Georgia O'Keeffe's Visions of Hawai'i' currently at the NYBG until 28 October will delight you...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/music-review-wulijimuren-sun-of-utc8-will-blow-you-away/" title="Music Review: Wulijimuren – ‘Sun of UTC+8’ Will Blow You Away">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2018/05/Wulijimuren2-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Wulijimuren" srcset="https://blogcritics.org/wp-content/uploads/2018/05/Wulijimuren2-150x150.jpg 150w, https://blogcritics.org/wp-content/uploads/2018/05/Wulijimuren2-330x330.jpg 330w, https://blogcritics.org/wp-content/uploads/2018/05/Wulijimuren2.jpg 600w" sizes="(max-width: 100px) 100vw, 100px" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/music-review-wulijimuren-sun-of-utc8-will-blow-you-away/" title="Music Review: Wulijimuren – ‘Sun of UTC+8’ Will Blow You Away">Music Review: Wulijimuren – ‘Sun of UTC+8’ Will Blow You Away</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        Wulijumuren’s virtuosity on his axe goes beyond prodigious, entering the realm of genius.                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/forget-the-pen-twitter-is-now-mightier-than-the-sword/" title="Forget the Pen – Twitter is Now Mightier Than the Sword">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2018/06/twit1-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/forget-the-pen-twitter-is-now-mightier-than-the-sword/" title="Forget the Pen – Twitter is Now Mightier Than the Sword">Forget the Pen – Twitter is Now Mightier Than the Sword</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        A case of the little Twitter Bird that doth mock the hand that feeds it.                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/movie-review-solo-a-star-wars-story/" title="Movie Review: &#8216;Solo: A Star Wars Story&#8217;">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2018/05/solo_600-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/movie-review-solo-a-star-wars-story/" title="Movie Review: &#8216;Solo: A Star Wars Story&#8217;">Movie Review: &#8216;Solo: A Star Wars Story&#8217;</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        The second installment in the Star Wars anthology series is an enjoyable (3 stars out...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/music-review-sleepy-zuhoski-better-haze/" title="Music Review: Sleepy Zuhoski – ‘Better Haze’">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2018/05/Sleepy-Zuhoski-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Sleepy Zuhoski" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/music-review-sleepy-zuhoski-better-haze/" title="Music Review: Sleepy Zuhoski – ‘Better Haze’">Music Review: Sleepy Zuhoski – ‘Better Haze’</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        'Better Haze' is nuanced, tantalizing, and refreshing.                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
    </ul>
</div><!-- end .wtpsw-post-items --></div></div><!-- .widget /--><div id="categort-posts-widget-2" class="widget categort-posts"><div class="widget-top"><h4>SXSW Coverage		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/interview-wyldest-talks-sxsw-brexit-and-its-upcoming-debut-album/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2018/04/121A4394-EDIT-crop-600px-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Wyldest at SXSW 2018 (Photo: Tan The Man)" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/interview-wyldest-talks-sxsw-brexit-and-its-upcoming-debut-album/">Interview: Wyldest Talks SXSW, Brexit, and Its Upcoming Debut Album</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>April 13, 2018</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/sxsw-film-favorite-first-reformed-ethan-hawke-amanda-seyfried/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2018/03/IMG_2084-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Ethan Hawke, Amanda Seyfried, First Reformed, SXSW FF" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/sxsw-film-favorite-first-reformed-ethan-hawke-amanda-seyfried/">SXSW Film Favorite: &#8216;First Reformed,&#8217; Ethan Hawke, Amanda Seyfried</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>April 3, 2018</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/sxsw-review-blindspotting-starring-daveed-diggs-rafael-casal/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2018/03/IMG_2060-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Daveed Diggs, Rafael Casal, Blindspotting, SXSW Film Festival" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/sxsw-review-blindspotting-starring-daveed-diggs-rafael-casal/">SXSW Review: &#8216;Blindspotting&#8217; Starring Daveed Diggs, Rafael Casal</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>April 3, 2018</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/sxsw-interview-jason-outenreath-immigration-documentary-they-live-here-now/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2018/03/TheyLiveHere-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="&#039;They Live Here, Now&#039;: Refugee Teo sits thoughtfully before lights out at the Austin-based refugee house, Casa Marianella. Photo: Jason Outenreath" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/sxsw-interview-jason-outenreath-immigration-documentary-they-live-here-now/">SXSW 2018 Exclusive Interview: Filmmaker Jason Outenreath on His Immigration Documentary &#8216;They Live Here, Now&#8217;</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>April 2, 2018</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/sxsw-world-premiere-film-weed-the-people-abby-epstein-ricki-lake/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2018/03/IMG_2069-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Weed the People, Abby Epstein, Ricki Lake, SXSW FF screening &amp; Q and A" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/sxsw-world-premiere-film-weed-the-people-abby-epstein-ricki-lake/">SXSW Film World Premiere: &#8216;Weed the People&#8217; Abby Epstein, Ricki Lake</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>March 29, 2018</span>		</li>
						</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /-->		<div id="recent-posts-2" class="widget widget_recent_entries">		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<ul>
											<li>
					<a href="https://blogcritics.org/book-review-the-word-is-murder-by-anthony-horowitz/">Book Review: &#8216;The Word Is Murder&#8217; by Anthony Horowitz</a>
									</li>
											<li>
					<a href="https://blogcritics.org/interview-rikki-rockett-drummer-for-poison/">Interview: Rikki Rockett, Drummer for Poison</a>
									</li>
											<li>
					<a href="https://blogcritics.org/dvd-review-jackass-complete-movie-and-tv-collection/">DVD Review: Jackass: Complete Movie and TV Collection</a>
									</li>
											<li>
					<a href="https://blogcritics.org/music-review-hungry-march-band-running-through-with-the-sadness/">Music Review: Hungry March Band – ‘Running Through with the Sadness’</a>
									</li>
											<li>
					<a href="https://blogcritics.org/music-review-suki-rae-cant-stop-now-disappoints/">Music Review: Suki Rae – ‘Can’t Stop Now’ Disappoints</a>
									</li>
					</ul>
		</div></div><!-- .widget /--><div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-top"><h4>Recent Comments</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://autisticagainstantivaxxers.wordpress.com/2017/04/07/submissions/' rel='external nofollow' class='url'>Containing =/= Is.</a></span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11815">Los Angeles Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://disqus.com/home/discussion/channel-sci/lets_debate_everything_science/' rel='external nofollow' class='url'>Kianna Prodzinski</a></span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11814">Los Angeles Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://autisticagainstantivaxxers.wordpress.com/2017/04/07/submissions/' rel='external nofollow' class='url'>Containing =/= Is.</a></span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11813">Los Angeles Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link">Stacey</span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11812">Los Angeles Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link">Brian</span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11811">Los Angeles Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li></ul></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->
<div class="e3lan e3lan-bottom">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=323844&width=728&height=90"></script> 				</div>
<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-2c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="facebook-widget-2" class="footer-widget facebook-widget"><div class="footer-widget-top"><h4>Find us on Facebook		</h4></div>
						<div class="footer-widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/pg/Blogcritics-132856246726018&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="latest_tweets_widget-2" class="footer-widget twitter-widget"><div class="footer-widget-top"><h4>			<a href="http://twitter.com/@Blogcritics">Follow Us</a>
		</h4></div>
						<div class="footer-widget-container">
<div class="twitter-widget-content" >
<ul class="twitter_update_list">
<li class="twitter-item">
	<i class="fa fa-twitter"></i><a href="http://twitter.com/DigiAbstinence" class="twitter-user">@DigiAbstinence</a> <a href="http://twitter.com/STurkle" class="twitter-user">@STurkle</a> It's definitely a problem for teens. <a href="https://t.co/NctgDvTjeG" class="twitter-link">https://t.co/NctgDvTjeG</a><small class="twitter-timestamp"><abbr title="2018/06/06 15:24:34">20 hours ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i><a href="http://twitter.com/megmeekermd" class="twitter-user">@megmeekermd</a> It's definitely a problem. <a href="https://t.co/NctgDvTjeG" class="twitter-link">https://t.co/NctgDvTjeG</a><small class="twitter-timestamp"><abbr title="2018/06/06 15:22:23">20 hours ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i><a href="http://twitter.com/Cleo_patrra" class="twitter-user">@Cleo_patrra</a> We have to agree. <a href="https://t.co/NctgDvTjeG" class="twitter-link">https://t.co/NctgDvTjeG</a><small class="twitter-timestamp"><abbr title="2018/06/06 15:21:13">20 hours ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i><a href="http://twitter.com/ghostblindlemon" class="twitter-user">@ghostblindlemon</a> <a href="http://twitter.com/SleepyZuhoski" class="twitter-user">@SleepyZuhoski</a> And the new Sleepy Zuhoski albums is great - <a href="https://t.co/9cVisMjgdK" class="twitter-link">https://t.co/9cVisMjgdK</a><small class="twitter-timestamp"><abbr title="2018/06/06 15:13:20">21 hours ago</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i><a href="http://twitter.com/moondogspub" class="twitter-user">@moondogspub</a> <a href="http://twitter.com/BandTogetherPGH" class="twitter-user">@BandTogetherPGH</a> <a href="http://twitter.com/Aut2knowpgh" class="twitter-user">@Aut2knowpgh</a> <a href="http://twitter.com/tascru" class="twitter-user">@tascru</a> And the new Tas Cru album is great! <a href="https://t.co/PRtWnp3Grh" class="twitter-link">https://t.co/PRtWnp3Grh</a><small class="twitter-timestamp"><abbr title="2018/06/06 15:09:08">21 hours ago</abbr></small></li>
</ul> </div>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>  | Web Admin <a href="mailto:michael.carrasquillo@blogcritics.org">Michael Carrasquillo</a>		</div>
				
		<div class="alignleft">
			© Copyright 2018, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div id="reading-position-indicator"></div><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blogcritics.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"blogcritics"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.16"},"disqusIdentifier":"5487642 https:\/\/blogcritics.org\/?p=5487642","disqusShortname":"blogcritics","disqusTitle":"Interview: Rikki Rockett, Drummer for Poison","disqusUrl":"https:\/\/blogcritics.org\/interview-rikki-rockett-drummer-for-poison\/","postId":"5487642"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/search.js'></script>
</body>
</html>