<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blogcritics.org/xmlrpc.php" />
<meta property="og:title" content="Videogame Review: &#8216;Soulstice&#8217; - Blogcritics"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content=""Lute," I whisper in my head as words are not necessary, "Do you see the devastation before us?" "Ye"/>
<meta property="og:url" content="https://blogcritics.org/videogame-review-soulstice/"/>
<meta property="og:site_name" content="Blogcritics"/>
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart.png" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.6.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Videogame Review: &#039;Soulstice&#039; | Blogcritics</title>
	<meta name="description" content="Soulstice has some repetitious gameplay but is well worth checking out for its beauty, character dynamics and compelling world." />
	<link rel="canonical" href="https://blogcritics.org/videogame-review-soulstice/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Videogame Review: &#039;Soulstice&#039; | Blogcritics" />
	<meta property="og:description" content="Soulstice has some repetitious gameplay but is well worth checking out for its beauty, character dynamics and compelling world." />
	<meta property="og:url" content="https://blogcritics.org/videogame-review-soulstice/" />
	<meta property="og:site_name" content="Blogcritics" />
	<meta property="article:publisher" content="https://www.facebook.com/blogcritics/" />
	<meta property="article:published_time" content="2022-09-20T12:58:48+00:00" />
	<meta property="article:modified_time" content="2022-09-20T12:58:50+00:00" />
	<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart.png" />
	<meta property="og:image:width" content="1365" />
	<meta property="og:image:height" content="768" />
	<meta property="og:image:type" content="image/png" />
	<meta name="author" content="Michael Prince" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@blogcritics" />
	<meta name="twitter:site" content="@blogcritics" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Michael Prince" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="6 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://blogcritics.org/videogame-review-soulstice/#article","isPartOf":{"@id":"https://blogcritics.org/videogame-review-soulstice/"},"author":{"name":"Michael Prince","@id":"https://blogcritics.org/#/schema/person/e2c6e21dd2ab5180ce0ebe70a24888ff"},"headline":"Videogame Review: &#8216;Soulstice&#8217;","datePublished":"2022-09-20T12:58:48+00:00","dateModified":"2022-09-20T12:58:50+00:00","mainEntityOfPage":{"@id":"https://blogcritics.org/videogame-review-soulstice/"},"wordCount":951,"commentCount":0,"publisher":{"@id":"https://blogcritics.org/#organization"},"image":{"@id":"https://blogcritics.org/videogame-review-soulstice/#primaryimage"},"thumbnailUrl":"https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart.png","keywords":["action videogame","pc game","ps5","soulstice","soulstice release","soulstice review","videogame review"],"articleSection":["Editor Pick: Gaming","Gaming","Gaming Reviews","Top Stories"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://blogcritics.org/videogame-review-soulstice/#respond"]}]},{"@type":"WebPage","@id":"https://blogcritics.org/videogame-review-soulstice/","url":"https://blogcritics.org/videogame-review-soulstice/","name":"Videogame Review: 'Soulstice' | Blogcritics","isPartOf":{"@id":"https://blogcritics.org/#website"},"primaryImageOfPage":{"@id":"https://blogcritics.org/videogame-review-soulstice/#primaryimage"},"image":{"@id":"https://blogcritics.org/videogame-review-soulstice/#primaryimage"},"thumbnailUrl":"https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart.png","datePublished":"2022-09-20T12:58:48+00:00","dateModified":"2022-09-20T12:58:50+00:00","description":"Soulstice has some repetitious gameplay but is well worth checking out for its beauty, character dynamics and compelling world.","breadcrumb":{"@id":"https://blogcritics.org/videogame-review-soulstice/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blogcritics.org/videogame-review-soulstice/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blogcritics.org/videogame-review-soulstice/#primaryimage","url":"https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart.png","contentUrl":"https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart.png","width":1365,"height":768},{"@type":"BreadcrumbList","@id":"https://blogcritics.org/videogame-review-soulstice/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blogcritics.org/"},{"@type":"ListItem","position":2,"name":"Videogame Review: &#8216;Soulstice&#8217;"}]},{"@type":"WebSite","@id":"https://blogcritics.org/#website","url":"https://blogcritics.org/","name":"Blogcritics","description":"The critical lens on today&#039;s culture &amp; entertainment","publisher":{"@id":"https://blogcritics.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blogcritics.org/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://blogcritics.org/#organization","name":"Blogcritics","url":"https://blogcritics.org/","sameAs":["https://www.linkedin.com/company/227939/","https://www.facebook.com/blogcritics/","https://twitter.com/blogcritics"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blogcritics.org/#/schema/logo/image/","url":"https://blogcritics.org/wp-content/uploads/2017/09/blogcritics-logo-wplogin320_65.png","contentUrl":"https://blogcritics.org/wp-content/uploads/2017/09/blogcritics-logo-wplogin320_65.png","width":320,"height":65,"caption":"Blogcritics"},"image":{"@id":"https://blogcritics.org/#/schema/logo/image/"}},{"@type":"Person","@id":"https://blogcritics.org/#/schema/person/e2c6e21dd2ab5180ce0ebe70a24888ff","name":"Michael Prince","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://blogcritics.org/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=96&d=mm&r=g","caption":"Michael Prince"},"description":"A longtime video game fan starting from simple games on the Atari 2600 to newer titles on a bleeding edge PC I play everything I can get my hands on.","sameAs":["http://www.seriousgamer.ca/"],"url":"https://blogcritics.org/author/michael-prince/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//pagead2.googlesyndication.com' />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Feed" href="https://blogcritics.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Comments Feed" href="https://blogcritics.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Videogame Review: &#8216;Soulstice&#8217; Comments Feed" href="https://blogcritics.org/videogame-review-soulstice/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blogcritics.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://blogcritics.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='tie-style-css'  href='https://blogcritics.org/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://blogcritics.org/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>

<!-- Google Analytics snippet added by Site Kit -->
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-231291915-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["blogcritics.org"]} );
gtag("js", new Date());
gtag("set", "developer_id.dZTNiMT", true);
gtag("config", "UA-231291915-1", {"anonymize_ip":true});
gtag("config", "G-L3JJLBP0J4");
</script>

<!-- End Google Analytics snippet added by Site Kit -->
<link rel="https://api.w.org/" href="https://blogcritics.org/wp-json/" /><link rel="alternate" type="application/json" href="https://blogcritics.org/wp-json/wp/v2/posts/5520089" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogcritics.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blogcritics.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://blogcritics.org/?p=5520089' />
<link rel="alternate" type="application/json+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fvideogame-review-soulstice%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fvideogame-review-soulstice%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.83.0" /><link rel="shortcut icon" href="https://blogcritics.org/wp-content/uploads/2017/09/favicon.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://blogcritics.org/wp-content/uploads/2017/09/apple-touch-icon.png" />

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=G-L3JJLBP0J4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'G-L3JJLBP0J4');
</script>

<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #7f0000;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#7f0000;
}

::-webkit-scrollbar-thumb{
	background-color:#7f0000 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #7f0000;
}

.search-block:after {
	border-right-color:#7f0000;
}

body.rtl .search-block:after {
	border-left-color:#7f0000;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #7f0000;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #7f0000;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #7f0000;
	border-color: #7f0000;
}

#order_review,
#order_review_heading {
	border-color: #7f0000;
}


a {
	color: #7f0000;
}
		
a:hover {
	color: #806060;
}
		
.top-nav ul li a:hover, .top-nav ul li:hover > a, .top-nav ul :hover > a , .top-nav ul li.current-menu-item a {
	color: #7f0000;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/blogcritics.org\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		
<!-- Google AdSense snippet added by Site Kit -->
<meta name="google-adsense-platform-account" content="ca-host-pub-2644536267352236">
<meta name="google-adsense-platform-domain" content="sitekit.withgoogle.com">
<!-- End Google AdSense snippet added by Site Kit -->
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>
<!-- Google AdSense snippet added by Site Kit -->
<script async="async" src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3219627867632523" crossorigin="anonymous" type="text/javascript"></script>

<!-- End Google AdSense snippet added by Site Kit -->

<!-- Google Tag Manager snippet added by Site Kit -->
<script type="text/javascript">
			( function( w, d, s, l, i ) {
				w[l] = w[l] || [];
				w[l].push( {'gtm.start': new Date().getTime(), event: 'gtm.js'} );
				var f = d.getElementsByTagName( s )[0],
					j = d.createElement( s ), dl = l != 'dataLayer' ? '&l=' + l : '';
				j.async = true;
				j.src = 'https://www.googletagmanager.com/gtm.js?id=' + i + dl;
				f.parentNode.insertBefore( j, f );
			} )( window, document, 'script', 'dataLayer', 'GTM-5N22LXN' );
			
</script>

<!-- End Google Tag Manager snippet added by Site Kit -->
</head>
<body id="top" class="post-template-default single single-post postid-5520089 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://blogcritics.org/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Tuesday , September 20 2022</span>
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-5264769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264769"><a href="/contact/">Contact Us</a></li>
<li id="menu-item-5264771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264771"><a href="/write-for-blogcritics/">Writer Sign Up</a></li>
<li id="menu-item-5264773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264773"><a href="/about/">About</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://blogcritics.org/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="Blogcritics" href="https://blogcritics.org/">
					<img src="https://blogcritics.org/wp-content/uploads/2017/10/blogcritics-logo190px.jpg" alt="Blogcritics"  /><strong>Blogcritics The critical lens on today&#039;s culture &amp; entertainment</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan e3lan-top">			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Logo Header Banner -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="3121633733"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-5264473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264473"><a href="/">Home</a></li>
<li id="menu-item-5367196" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-5367196"><a href="https://blogcritics.org/editor-picks/">Editor Picks</a></li>
<li id="menu-item-5264475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264475"><a href="https://blogcritics.org/tv/">TV</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5265485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265485"><a href="https://blogcritics.org/tv/tv-reviews-recaps/">Reviews &#038; Recaps</a></li>
	<li id="menu-item-5265515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265515"><a href="https://blogcritics.org/tv/interviews-tv/">Interviews</a></li>
	<li id="menu-item-5274805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5274805"><a href="https://blogcritics.org/film/columns-film/">Weekly TV Coverage</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5267599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267599"><a href="https://blogcritics.org/tv/tv-columns/gleekonomics/">Gleekonomics</a></li>
		<li id="menu-item-5267603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267603"><a href="https://blogcritics.org/tv/tv-columns/jeroming-the-tv-landscape/">Jeroming the TV Landscape</a></li>
		<li id="menu-item-5340221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5340221"><a href="https://blogcritics.org/tv/tv-columns/the-gallifreyian-groupie/">The Gallifreyan Groupie</a></li>
		<li id="menu-item-5267607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267607"><a href="https://blogcritics.org/tv/tv-columns/once-upon-a-time/">Once Upon a Time&#8230;There Was a Place Called Storybrooke</a></li>
		<li id="menu-item-5295573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5295573"><a href="https://blogcritics.org/tv/tv-columns/lets-talk-tv-with-barbara-barnett/">Let&#8217;s Talk TV with Barbara Barnett</a></li>
		<li id="menu-item-5267597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267597"><a href="https://blogcritics.org/tv/tv-columns/supernatural/">Supernatural Musings</a></li>
		<li id="menu-item-5267601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267601"><a href="https://blogcritics.org/tv/tv-columns/idol-wired/">Idol Wired</a></li>
		<li id="menu-item-5267609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267609"><a href="https://blogcritics.org/tv/tv-columns/sci-fi-primetime/">Sci-Fi Primetime</a></li>
		<li id="menu-item-5267605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267605"><a href="https://blogcritics.org/tv/tv-columns/mad-men-confidential/">Mad Men Confidential</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-5264553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264553"><a href="https://blogcritics.org/music/">Music</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264585"><a href="https://blogcritics.org/music/reviews-music/">Reviews music</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5277445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277445"><a href="https://blogcritics.org/music/reviews-music/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-5264589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264589"><a href="https://blogcritics.org/music/reviews-music/concert-reviews/">Concert Reviews</a></li>
		<li id="menu-item-5277447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277447"><a href="https://blogcritics.org/music/reviews-music/music-dvd-blu-ray-reviews/">Music DVD &#038; Blu-ray Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-5264577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264577"><a href="https://blogcritics.org/music/interviews-music/">Interviews music</a></li>
</ul>
</li>
<li id="menu-item-5264599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264599"><a href="https://blogcritics.org/books/">Books</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264625"><a href="https://blogcritics.org/books/reviews-books/">Book Reviews</a></li>
	<li id="menu-item-5265519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265519"><a href="https://blogcritics.org/books/book-interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-5264731" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264731"><a href="https://blogcritics.org/gaming/">Gaming</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264745" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5264745"><a href="https://blogcritics.org/gaming/gaming-reviews/">Gaming Reviews</a></li>
	<li id="menu-item-5264743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264743"><a href="https://blogcritics.org/gaming/previews/">Previews</a></li>
	<li id="menu-item-5264741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264741"><a href="https://blogcritics.org/gaming/conferences/">Conferences</a></li>
</ul>
</li>
<li id="menu-item-5264641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264641"><a href="https://blogcritics.org/culture/">Culture and Society</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264647"><a href="https://blogcritics.org/culture/arts/">Arts</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5275059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275059"><a href="https://blogcritics.org/culture/arts/cabaret/">Cabaret</a></li>
		<li id="menu-item-5275061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275061"><a href="https://blogcritics.org/culture/arts/dance/">Dance</a></li>
		<li id="menu-item-5275063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275063"><a href="https://blogcritics.org/culture/arts/opera-arts/">Opera</a></li>
		<li id="menu-item-5275067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275067"><a href="https://blogcritics.org/culture/arts/theater/">Theater</a></li>
	</ul>
</li>
	<li id="menu-item-5292699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5292699"><a href="https://blogcritics.org/culture/culture-columns/">Culture Columns</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5292701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292701"><a href="https://blogcritics.org/culture/culture-columns/ending-world-hunger/">Ending World Hunger</a></li>
		<li id="menu-item-5443149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5443149"><a href="https://blogcritics.org/culture/culture-columns/language-matters/">Language Matters</a></li>
		<li id="menu-item-5292703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292703"><a href="https://blogcritics.org/culture/culture-columns/hometown-heroes-culture-columns/">Hometown Heroes</a></li>
	</ul>
</li>
	<li id="menu-item-5264643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264643"><a href="https://blogcritics.org/culture/politics/">Politics</a></li>
	<li id="menu-item-5264659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264659"><a href="https://blogcritics.org/culture/travel/">Travel</a></li>
	<li id="menu-item-5264661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264661"><a href="https://blogcritics.org/culture/scitech/">Science and Technology</a></li>
	<li id="menu-item-5264645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264645"><a href="https://blogcritics.org/culture/sports/">Sports</a></li>
	<li id="menu-item-5264663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264663"><a href="https://blogcritics.org/culture/spirituality/">Spirituality</a></li>
	<li id="menu-item-5264657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264657"><a href="https://blogcritics.org/culture/tips-and-advice/">Tips and Advice</a></li>
	<li id="menu-item-5439149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5439149"><a href="https://blogcritics.org/culture/personalfinance/">Personal Finance</a></li>
	<li id="menu-item-5264655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264655"><a href="https://blogcritics.org/culture/health-and-fitness/">Health and Fitness</a></li>
	<li id="menu-item-5264653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264653"><a href="https://blogcritics.org/culture/food-and-drink/">Food and Drink</a></li>
</ul>
</li>
<li id="menu-item-5264679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264679"><a href="https://blogcritics.org/film/">Film</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264711"><a href="https://blogcritics.org/film/reviews-film/">Reviews film</a></li>
	<li id="menu-item-5264685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264685"><a href="https://blogcritics.org/film/interviews-film/">Interviews film</a></li>
</ul>
</li>
<li id="menu-item-5406273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5406273"><a href="https://blogcritics.org/flash-fiction-2/">Flash Fiction</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<nav id="crumbs"><a href="https://blogcritics.org/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><span class="delimiter">/</span><a href="https://blogcritics.org/editor-picks/">Editor Picks</a><span class="delimiter">/</span><a href="https://blogcritics.org/editor-picks/gaming-picks/">Editor Pick: Gaming</a><span class="delimiter">/</span><span class="current">Videogame Review: &#8216;Soulstice&#8217;</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/blogcritics.org\/"}},{"@type":"ListItem","position":2,"item":{"name":"Editor Picks","@id":"https:\/\/blogcritics.org\/editor-picks\/"}},{"@type":"ListItem","position":3,"item":{"name":"Editor Pick: Gaming","@id":"https:\/\/blogcritics.org\/editor-picks\/gaming-picks\/"}}]}</script>
		

		<div class="e3lan e3lan-post">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=582133&width=320&height=50"></script> 				</div>
		<article class="post-listing post-5520089 post type-post status-publish format-standard has-post-thumbnail  category-gaming-picks category-gaming category-gaming-reviews category-top-stories tag-action-videogame tag-pc-game tag-ps5 tag-soulstice tag-soulstice-release tag-soulstice-review tag-videogame-review" id="the-post">
			
			<div class="single-post-thumb">
			<img width="660" height="330" src="https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart-660x330.png" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart-660x330.png 660w, https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart-1050x525.png 1050w" sizes="(max-width: 660px) 100vw, 660px" />		</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Videogame Review: &#8216;Soulstice&#8217;</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://blogcritics.org/author/michael-prince/" title="">Michael Prince </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>8 hours ago</span>	
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://blogcritics.org/videogame-review-soulstice/#respond"><span class="dsq-postid" data-dsqidentifier="5520089 https://blogcritics.org/?p=5520089">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>7 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					<div class="share-post">
	<span class="share-text">Share</span>

		<ul class="flat-social">
			<li><a href="https://www.facebook.com/sharer.php?u=https://blogcritics.org/videogame-review-soulstice/" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
				<li><a href="https://twitter.com/intent/tweet?text=Videogame+Review%3A+%E2%80%98Soulstice%E2%80%99&url=https://blogcritics.org/videogame-review-soulstice/" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
					<li><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://blogcritics.org/videogame-review-soulstice/&amp;title=Videogame+Review%3A+%E2%80%98Soulstice%E2%80%99" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li>
				<li><a href="https://pinterest.com/pin/create/button/?url=https://blogcritics.org/videogame-review-soulstice/&amp;description=Videogame+Review%3A+%E2%80%98Soulstice%E2%80%99&amp;media=https://blogcritics.org/wp-content/uploads/2022/09/Soulstice_Keyart-660x330.png" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->

					
					
<p><em>&#8220;Lute,&#8221; I whisper in my head as words are not necessary, &#8220;Do you see the devastation before us?&#8221; &#8220;Yes Sister&#8221; she replies, slowly forming from the ether around me.</em></p>



<p><em>I revel in her touch, I can feel it lightly, like a breath from the summer breeze. The only pleasure in my cursed state is when my sister is with me like this. Shaking myself I turn my head to see her face glowing with blue light staring at me with love, and worry.</em></p>



<p><em>&#8220;Do you feel the pull, Briar?&#8221; she asks, the worry on her face echoed in her tremulous voice. It was no use lying to her, we are joined and she would know. &#8220;Yes&#8221; I say stoically &#8220;but it is not strong enough to consume us&#8230;yet.&#8221;</em></p>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-05fn0yyq-1024x576.png" alt="" class="wp-image-5520093" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-05fn0yyq-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-05fn0yyq-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-05fn0yyq-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-05fn0yyq.png 1365w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p><em>&#8220;Then we must move on&#8221; Lute says in her most optimistic tone, which can always make me smile, if just for a moment. &#8220;An observer should be near, and I can sense a — no wait, two other Chimeras up ahead.&#8221; Lute paused. &#8220;They are conflicted but alive.</em>&#8220;</p>



<p><em>&#8220;Then we have no time to waste&#8221; I say aloud with a resigned tone. &#8220;Observers are cowards and blowhards, but they can be handy.&#8221; With a whisper which I knew Lute would hear I added &#8220;We will need all the help we can get.</em>&#8220;</p>



<p><em>She wisely said nothing knowing I had to settle myself on this path. Checking that my weapons were ready to be drawn at a moment&#8217;s notice I stared up at the shattered sky, filled with the all-consuming tear, and said with finality &#8220;Nothing will stand in our way, I will destroy all in our path and redeem our fate, I promise this Lute.&#8221;</em></p>



<p><em><a href="https://soulsticegame.com/" target="_blank" rel="noreferrer noopener">Soulstice </a></em>is an action adventure game from <a href="https://www.reply.com/reply-game-studios/en/" target="_blank" rel="noreferrer noopener">Reply Game Studios</a> that features two soul-bound sisters (Briar and Lute) who have been reborn Chimeras, living weapons serving the mysterious Order of the Ashen Blade.</p>



<p>Little is explained about how and why these two became Chimeras; when the game starts, they just are in this state. I actually found that refreshing as there was simply a need to accept these conjoined characters as they explore and battle their way through the fallen city of Ilden.</p>



<figure class="wp-container-2 wp-block-gallery-1 wp-block-gallery has-nested-images columns-default is-cropped">
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" data-id="5520094"  src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-49_AM-tjzvhgnh-1024x576.png" alt="" class="wp-image-5520094" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-49_AM-tjzvhgnh-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-49_AM-tjzvhgnh-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-49_AM-tjzvhgnh-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-49_AM-tjzvhgnh.png 1365w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" data-id="5520095"  src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-52oynbcb-1024x576.png" alt="" class="wp-image-5520095" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-52oynbcb-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-52oynbcb-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-52oynbcb-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-52oynbcb-1536x864.png 1536w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-52oynbcb.png 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
</figure>



<p>In an opening cutscene we learn that the Kingdom of Keidas was shaped by three entities who have since waned in the world leaving the path open for an evil entity to take over the Kingdom. The Chimeras are elite soldiers who use their supernatural joining with their Shades to develop incredible powers.</p>



<p>Briar and Lute each have their roles and in <em>Soulstice</em>, both are controlled at the same time. Briar is the main controllable character and gets an expanding roster of weapons and attack to leverage but I found Lute&#8217;s skill arc to be much more interesting.</p>



<p>Lute is a mix of defensive/offensive and puzzle solving as she assists Briar through the battles. Her ability to deflect or block attacks with timed button presses is literally the key to surviving the game.</p>



<p>She also generates auto attacks depending on the Unity she builds with Briar and can generate two types of fields around them that help against enemies and the puzzles in the world of <em>Soulstice</em>. Evocation or Banishment Fields will help to damage corresponding enemies and barriers that are found along the game&#8217;s dangerous path.</p>



<figure class="wp-container-4 wp-block-gallery-3 wp-block-gallery has-nested-images columns-default is-cropped">
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" data-id="5520097"  src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-wjngounq-1024x576.png" alt="" class="wp-image-5520097" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-wjngounq-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-wjngounq-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-wjngounq-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-wjngounq-1536x864.png 1536w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-wjngounq.png 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" data-id="5520098"  src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-47_AM-5bnsswm2-1024x576.png" alt="" class="wp-image-5520098" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-47_AM-5bnsswm2-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-47_AM-5bnsswm2-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-47_AM-5bnsswm2-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-47_AM-5bnsswm2-1536x864.png 1536w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-47_AM-5bnsswm2.png 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
</figure>



<p>While Lute has the more dynamic skills and powers, Briar is the main powerhouse and she uses her growing repertoire of weapons, combos and skills to destroy all enemies in her path. Weapons ranging from massive swords to whips and gauntlet strikes are switchable at will to enable many varied combos.</p>



<p>While I did enjoy the depth of skills, weapons and tactics that can be employed, the game itself can become a bit monotonous in steady combat as the patterns remain the same. Attack, combo, leap, dodge, deflect as Lute, rinse and repeat. The changing weapons change these attacks and enable different combos, but the feeling of repetition still sinks in.</p>



<p>New enemies do appear quite often but generally they just add new wrinkles to combat like needing a field active, armor that needs to get destroyed or an anchor that needs to be removed so they can be harmed. The combat is fast-paced, can be fun at moments, but suffers from a sameness despite the new skills, weapons and combos discovered along the way.</p>



<figure class="wp-container-6 wp-block-gallery-5 wp-block-gallery has-nested-images columns-default is-cropped">
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" data-id="5520100"  src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-soxkb1gu-1024x576.png" alt="" class="wp-image-5520100" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-soxkb1gu-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-soxkb1gu-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-soxkb1gu-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-48_AM-soxkb1gu.png 1365w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="576" data-id="5520101"  src="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-hufggdvm-1024x576.png" alt="" class="wp-image-5520101" srcset="https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-hufggdvm-1024x576.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-hufggdvm-330x186.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-hufggdvm-768x432.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-hufggdvm-1536x864.png 1536w, https://blogcritics.org/wp-content/uploads/2022/09/9-19-2022_8-47-46_AM-hufggdvm.png 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>
</figure>



<p>The same, thankfully, need not be said of the atmosphere, the dialog between the sisters and the general moodiness of the game. I found myself many times stopping and admiring the scale and effectiveness of the visuals as well as the interactions between Briar and Lute and the few characters they meet.</p>



<p>The real strength in <em>Soulstice</em> is the amazing ecosystem and world Reply Game Studios has made. Each scene is dripping in details and pathways with hidden secrets and ways to proceed through the game.</p>



<p>While the <em>DMC</em>-style combat has been what is first noticed about the game, there is a true dark beauty in the world of <em>Soulstice </em>and the relationship between Briar and Lute. The big reason I kept coming back to the game was their dynamic and the world they were navigating.</p>



<p><em>Soulstice</em> is not a perfect game, its combat could have used some tweaking to be more dynamic and the skill pool is a little stretched with all the weapons, but the game is redeemed by its beauty, character dynamics and atmosphere. Ultimately as a result this is a game well worth checking out. It&#8217;s available on <a href="https://store.playstation.com/en-us/concept/10003036" target="_blank" rel="noreferrer noopener">PlayStation 5</a>, <a href="https://www.xbox.com/en-us/games/store/soulstice/9n9plfh8sw3f?ref=dtf.ru" target="_blank" rel="noreferrer noopener">Xbox Series X|S</a> and <a href="https://store.steampowered.com/app/1602080/Soulstice/" target="_blank" rel="noreferrer noopener">PC via Steam</a>.</p>



<figure class="wp-block-image size-large is-resized"><img loading="lazy" src="https://blogcritics.org/wp-content/uploads/2022/09/4-star-1024x272.png" alt="" class="wp-image-5520090" width="241" height="64" srcset="https://blogcritics.org/wp-content/uploads/2022/09/4-star-1024x272.png 1024w, https://blogcritics.org/wp-content/uploads/2022/09/4-star-330x88.png 330w, https://blogcritics.org/wp-content/uploads/2022/09/4-star-768x204.png 768w, https://blogcritics.org/wp-content/uploads/2022/09/4-star-1536x408.png 1536w, https://blogcritics.org/wp-content/uploads/2022/09/4-star-2048x543.png 2048w" sizes="(max-width: 241px) 100vw, 241px" /></figure>



<p>We were given an Xbox Series X code by the publisher to play through <em>Soulstice</em> for this review.</p>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json" class="tie-schema-graph">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://blogcritics.org/tag/action-videogame/" rel="tag">action videogame</a> <a href="https://blogcritics.org/tag/pc-game/" rel="tag">pc game</a> <a href="https://blogcritics.org/tag/ps5/" rel="tag">ps5</a> <a href="https://blogcritics.org/tag/soulstice/" rel="tag">soulstice</a> <a href="https://blogcritics.org/tag/soulstice-release/" rel="tag">soulstice release</a> <a href="https://blogcritics.org/tag/soulstice-review/" rel="tag">soulstice review</a> <a href="https://blogcritics.org/tag/videogame-review/" rel="tag">videogame review</a></p>

		<div class="e3lan e3lan-post">			<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Above Article Banner -->
<ins class="adsbygoogle"
     style="display:inline-block;width:468px;height:60px"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="4623660935"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div>
				<section id="author-box">
			<div class="block-head">
				<h3>About Michael Prince </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' loading='lazy'/>	</div><!-- #author-avatar -->
			<div class="author-description">
						A longtime video game fan starting from simple games on the Atari 2600 to newer titles on a bleeding edge PC I play everything I can get my hands on.		</div><!-- #author-description -->
			<div class="author-social flat-social">
						<a class="social-site" target="_blank" href="http://www.seriousgamer.ca/"><i class="fa fa-home"></i></a>
																													</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/fantastic-fest-horror-sci-fi-just-plain-weird-live-september-22/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2022/09/FFfeatured-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Fantastic Fest" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/fantastic-fest-horror-sci-fi-just-plain-weird-live-september-22/" rel="bookmark">Fantastic Fest: Horror, Sci-Fi and Just Plain Weird Goes Live September 22</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>48 seconds ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-reviews-johnston-i-draw-slow-carpenter-commonheart/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2022/09/Freedy-Johnston-Back-on-the-Road-to-You-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Freedy Johnston-Back on the Road to You" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-reviews-johnston-i-draw-slow-carpenter-commonheart/" rel="bookmark">￼Music Reviews: Freedy Johnston, I Draw Slow, Jimmy Carpenter, and the Commonheart</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>8 hours ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-reviews-kinks-mccutcheon-collective-soul-kolassa-lisik/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2022/09/cover-muswell-hillbillies-slash-everybodys-in-show-biz-everybodys-a-star-deluxe-box-set-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="The Kinks--Muswell Hillbillies - Everybody&#039;s Show-biz, Everybody&#039;s a Star" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-reviews-kinks-mccutcheon-collective-soul-kolassa-lisik/" rel="bookmark">Music Reviews: The Kinks’ ‘Muswell Hillbillies/Everybody’s in Show-biz – Everybody’s a Star’ plus John McCutcheon, Collective Soul, Mick Kolassa, and Brian Lisik</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>1 week ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://blogcritics.org/videogame-review-young-souls/">
					<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2022/03/youngsouls-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://blogcritics.org/videogame-review-young-souls/" rel="bookmark">Videogame Review: &#8216;Young Souls&#8217;</a></h2>
			<p>Generally when a game features smart-mouthed teens fighting against the world, I roll my eyes, but Young Souls from developer 1P2P Studios made me a believer</p>
		</div>
			</section>
			
			
	
		
		
<div id="disqus_thread"></div>

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">

		<div id="recent-posts-2" class="widget widget_recent_entries">
		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">
		<ul>
											<li>
					<a href="https://blogcritics.org/fantastic-fest-horror-sci-fi-just-plain-weird-live-september-22/">Fantastic Fest: Horror, Sci-Fi and Just Plain Weird Goes Live September 22</a>
									</li>
											<li>
					<a href="https://blogcritics.org/concert-review-nyc-momenta-festival-vii-horn-fifths-music-of-brahms-bacewicz-and-mogi/">Concert Review (NYC): Momenta Festival VII – &#8216;Horn Fifths,&#8217; Music of Brahms, Bacewicz and Mogi</a>
									</li>
											<li>
					<a href="https://blogcritics.org/music-reviews-johnston-i-draw-slow-carpenter-commonheart/">￼Music Reviews: Freedy Johnston, I Draw Slow, Jimmy Carpenter, and the Commonheart</a>
									</li>
											<li>
					<a href="https://blogcritics.org/videogame-review-soulstice/" aria-current="page">Videogame Review: &#8216;Soulstice&#8217;</a>
									</li>
											<li>
					<a href="https://blogcritics.org/jun-markl-taiwan-philharmonic/">Exclusive Interview: Maestro Jun Märkl on Taiwan Philharmonic&#8217;s 2022-23 Season</a>
									</li>
					</ul>

		</div></div><!-- .widget /--><div id="categort-posts-widget-2" class="widget categort-posts"><div class="widget-top"><h4>Film Picks		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/fantastic-fest-horror-sci-fi-just-plain-weird-live-september-22/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2022/09/FFfeatured-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Fantastic Fest" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/fantastic-fest-horror-sci-fi-just-plain-weird-live-september-22/">Fantastic Fest: Horror, Sci-Fi and Just Plain Weird Goes Live September 22</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>48 seconds ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/blu-ray-review-paradise-highway-starring-juliette-binoche-and-morgan-freeman/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2022/09/PARADISE-HIGHWAY_-BD-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/blu-ray-review-paradise-highway-starring-juliette-binoche-and-morgan-freeman/">Blu-ray Review: &#8216;Paradise Highway&#8217; Starring Juliette Binoche and Morgan Freeman</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>1 week ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/the-last-movie-stars-a-homage-to-paul-newman-and-joanne-woodward/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2022/09/16210_905752719455629_5932965533552752508_n-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/the-last-movie-stars-a-homage-to-paul-newman-and-joanne-woodward/">The Last Movie Stars: A Homage to Paul Newman and Joanne Woodward</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>1 week ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/anthem-film-review-grid-down-power-up-narrated-by-dennis-quaid/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2022/07/GD-Featured-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/anthem-film-review-grid-down-power-up-narrated-by-dennis-quaid/">Anthem Film Review: ‘Grid Down, Power Up’ Narrated by Dennis Quaid</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>August 5, 2022</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/anthem-film-review-tackling-woke-melons-were-doing-good/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2022/07/featured-1-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Anthem" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/anthem-film-review-tackling-woke-melons-were-doing-good/">Anthem Film Review: Tackling Woke: ‘Melons’ and ‘We’re Doing Good’</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>August 4, 2022</span>		</li>
						</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-top"><h4>Recent Comments</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11925">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://toliveandwriteinla.com/' rel='external nofollow ugc' class='url'>Leo Sopicki</a></span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11924">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11923">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/greta-thunberg-started-out-all-alone-but-shes-not-alone-anymore/#comment-11917">Greta the Great – Greta Thunberg Leads the Way on Climate Change</a></li><li class="recentcomments"><span class="comment-author-link">Dr Joseph S Maresca</span> on <a href="https://blogcritics.org/greta-thunberg-started-out-all-alone-but-shes-not-alone-anymore/#comment-11916">Greta the Great – Greta Thunberg Leads the Way on Climate Change</a></li></ul></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-2c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="facebook-widget-2" class="footer-widget facebook-widget"><div class="footer-widget-top"><h4>Find us on Facebook		</h4></div>
						<div class="footer-widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/pg/Blogcritics-132856246726018&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="latest_tweets_widget-2" class="footer-widget twitter-widget"><div class="footer-widget-top"><h4>			<a href="https://twitter.com/@Blogcritics">Follow Us</a>
		</h4></div>
						<div class="footer-widget-container">
<div class="twitter-widget-content" >
<ul class="twitter_update_list">
<li class="twitter-item">
	<i class="fa fa-twitter"></i>RT <a href="https://twitter.com/B_Barnett" class="twitter-user">@B_Barnett</a>: I am so angry this morning as I hear story after story from home and <a href="https://twitter.com/#search?q=dear" class="twitter-link">#dear</a> friends about the gladness and joy turned to terr…<small class="twitter-timestamp"><abbr title="2022/07/05 18:50:24">2022/07/05</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>PAX East 2022 Day One: Michael Prince visits the  Dolmen, The Last Oricru and Rusted Moss booths at <a href="https://twitter.com/#search?q=PAXEast2022" class="twitter-link">#PAXEast2022</a> Re… <a href="https://t.co/GkgIz1iaY5" class="twitter-link">https://t.co/GkgIz1iaY5</a><small class="twitter-timestamp"><abbr title="2022/05/04 14:28:00">2022/05/04</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Trivia Game Review: ‘MLB Baseball Trivia Challenge’ from MasterPieces gives <a href="https://twitter.com/#search?q=baseball" class="twitter-link">#baseball</a> enthusiasts the one thing the… <a href="https://t.co/tMweaigByL" class="twitter-link">https://t.co/tMweaigByL</a><small class="twitter-timestamp"><abbr title="2022/05/03 23:35:00">2022/05/03</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Out own Michael Prince covers <a href="https://twitter.com/#search?q=PAXEast2022" class="twitter-link">#PAXEast2022</a> from the inside out. Here's his intro. (Further installments on the way!… <a href="https://t.co/hUqH8tcRps" class="twitter-link">https://t.co/hUqH8tcRps</a><small class="twitter-timestamp"><abbr title="2022/05/03 14:18:00">2022/05/03</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Theater Review: Masks Can't Mask Love in 'André &amp; Dorine' – masked actors tell a story of dementia in a brilliantly… <a href="https://t.co/SZSZv1sDlU" class="twitter-link">https://t.co/SZSZv1sDlU</a><small class="twitter-timestamp"><abbr title="2022/05/02 23:12:59">2022/05/02</abbr></small></li>
</ul> </div>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="https://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>  | Web Admin <a href="/cdn-cgi/l/email-protection#0865616b60696d64266b697a7a697b797d61646467486a64676f6b7a617c616b7b26677a6f">Michael Carrasquillo</a>		</div>
				
		<div class="alignleft">
			© Copyright 2022, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div id="reading-position-indicator"></div>		<meta http-equiv="imagetoolbar" content="no"><!-- disable image toolbar (if any) -->
		<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
			/*<![CDATA[*/
			document.oncontextmenu = function() {
				return false;
			};
			document.onselectstart = function() {
				if (event.srcElement.type != "text" && event.srcElement.type != "textarea" && event.srcElement.type != "password") {
					return false;
				}
				else {
					return true;
				}
			};
			if (window.sidebar) {
				document.onmousedown = function(e) {
					var obj = e.target;
					if (obj.tagName.toUpperCase() == 'SELECT'
							|| obj.tagName.toUpperCase() == "INPUT"
							|| obj.tagName.toUpperCase() == "TEXTAREA"
							|| obj.tagName.toUpperCase() == "PASSWORD") {
						return true;
					}
					else {
						return false;
					}
				};
			}
			document.ondragstart = function() {
				return false;
			};
			/*]]>*/
		</script>
				<!-- Google Tag Manager (noscript) snippet added by Site Kit -->
		<noscript>
			<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5N22LXN" height="0" width="0" style="display:none;visibility:hidden"></iframe>
		</noscript>
		<!-- End Google Tag Manager (noscript) snippet added by Site Kit -->
		<style>.wp-container-2 {display: flex;gap: 0.5em;flex-wrap: wrap;align-items: center;}.wp-container-2 > * { margin: 0; }</style>
<style>.wp-container-4 {display: flex;gap: 0.5em;flex-wrap: wrap;align-items: center;}.wp-container-4 > * { margin: 0; }</style>
<style>.wp-container-6 {display: flex;gap: 0.5em;flex-wrap: wrap;align-items: center;}.wp-container-6 > * { margin: 0; }</style>
<style> .wp-block-gallery-1{ --wp--style--unstable-gallery-gap: var( --wp--style--gallery-gap-default, var( --gallery-block--gutter-size, var( --wp--style--block-gap, 0.5em ) ) ); gap: var( --wp--style--gallery-gap-default, var( --gallery-block--gutter-size, var( --wp--style--block-gap, 0.5em ) ) )}</style><style> .wp-block-gallery-3{ --wp--style--unstable-gallery-gap: var( --wp--style--gallery-gap-default, var( --gallery-block--gutter-size, var( --wp--style--block-gap, 0.5em ) ) ); gap: var( --wp--style--gallery-gap-default, var( --gallery-block--gutter-size, var( --wp--style--block-gap, 0.5em ) ) )}</style><style> .wp-block-gallery-5{ --wp--style--unstable-gallery-gap: var( --wp--style--gallery-gap-default, var( --gallery-block--gutter-size, var( --wp--style--block-gap, 0.5em ) ) ); gap: var( --wp--style--gallery-gap-default, var( --gallery-block--gutter-size, var( --wp--style--block-gap, 0.5em ) ) )}</style><script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"blogcritics"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"5520089 https:\/\/blogcritics.org\/?p=5520089","disqusShortname":"blogcritics","disqusTitle":"Videogame Review: \u2018Soulstice\u2019","disqusUrl":"https:\/\/blogcritics.org\/videogame-review-soulstice\/","postId":"5520089"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script>
<script type='text/javascript' id='tie-scripts-js-extra'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"","lightbox_gallery":"","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/tie-scripts.js' id='tie-scripts-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/ilightbox.packed.js' id='tie-ilightbox-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/search.js' id='tie-search-js'></script>

        <script>(function(){var js = "window['__CF$cv$params']={r:'74e5c0d20c779c28',m:'zKiyBSbzwR.F785ciEtaUVkzHodWtkpBL8VDpa9oIkM-1663794265-0-Afit7zgmHmNKPKxKDeRjRG5kq+hlSeNeDMzbv1V3mtcoUzVHuEasyMC87t5E/jdaPCoAmDzoQuzCINRsEyrk2dG46VMPI1MvuTLJuYTaskawCieV8x+GF99bSlcbrHVnM1t0trF+coKo4GgCH5Yc2+8=',s:[0xffb58bc0ab,0xb5571b8b43],u:'/cdn-cgi/challenge-platform/h/b'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/b/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script></body>
</html>