<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blogcritics.org/xmlrpc.php" />
<meta property="og:title" content="Music Review: &#8216;Feminine Care&#8217; Lexagon - Blogcritics"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Feminine Care, by Bay Area multimedia artist Lexagon (AKA Alexa Burrell) on Ratskin Records, is a co"/>
<meta property="og:url" content="https://blogcritics.org/music-review-feminine-care-lexagon/"/>
<meta property="og:site_name" content="Blogcritics"/>
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014280365.jpg" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO Premium plugin v16.1 (Yoast SEO v16.6.1) - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Music Review: &#039;Feminine Care&#039; Lexagon | Blogcritics</title>
	<meta name="description" content="&#039;Feminine Care&#039; from Lexagon is a visceral and intelligent response to the indignities women face daily and a great musical experience." />
	<link rel="canonical" href="https://blogcritics.org/music-review-feminine-care-lexagon/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Music Review: &#039;Feminine Care&#039; Lexagon | Blogcritics" />
	<meta property="og:description" content="&#039;Feminine Care&#039; from Lexagon is a visceral and intelligent response to the indignities women face daily and a great musical experience." />
	<meta property="og:url" content="https://blogcritics.org/music-review-feminine-care-lexagon/" />
	<meta property="og:site_name" content="Blogcritics" />
	<meta property="article:publisher" content="https://www.facebook.com/blogcritics/" />
	<meta property="article:published_time" content="2021-09-07T11:32:00+00:00" />
	<meta property="article:modified_time" content="2021-09-07T11:32:02+00:00" />
	<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014280365.jpg" />
	<meta property="og:image:width" content="750" />
	<meta property="og:image:height" content="449" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@blogcritics" />
	<meta name="twitter:site" content="@blogcritics" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Richard Marcus" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="2 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://blogcritics.org/#organization","name":"Blogcritics","url":"https://blogcritics.org/","sameAs":["https://www.facebook.com/blogcritics/","https://www.linkedin.com/company/227939/","https://twitter.com/blogcritics"],"logo":{"@type":"ImageObject","@id":"https://blogcritics.org/#logo","inLanguage":"en-US","url":"https://blogcritics.org/wp-content/uploads/2017/09/blogcritics-logo-wplogin320_65.png","contentUrl":"https://blogcritics.org/wp-content/uploads/2017/09/blogcritics-logo-wplogin320_65.png","width":320,"height":65,"caption":"Blogcritics"},"image":{"@id":"https://blogcritics.org/#logo"}},{"@type":"WebSite","@id":"https://blogcritics.org/#website","url":"https://blogcritics.org/","name":"Blogcritics","description":"The critical lens on today&#039;s culture &amp; entertainment","publisher":{"@id":"https://blogcritics.org/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://blogcritics.org/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#primaryimage","inLanguage":"en-US","url":"https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014280365.jpg","contentUrl":"https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014280365.jpg","width":750,"height":449,"caption":"Cover Feminine Care Lexagon"},{"@type":"WebPage","@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#webpage","url":"https://blogcritics.org/music-review-feminine-care-lexagon/","name":"Music Review: 'Feminine Care' Lexagon | Blogcritics","isPartOf":{"@id":"https://blogcritics.org/#website"},"primaryImageOfPage":{"@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#primaryimage"},"datePublished":"2021-09-07T11:32:00+00:00","dateModified":"2021-09-07T11:32:02+00:00","description":"'Feminine Care' from Lexagon is a visceral and intelligent response to the indignities women face daily and a great musical experience.","breadcrumb":{"@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://blogcritics.org/music-review-feminine-care-lexagon/"]}]},{"@type":"BreadcrumbList","@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://blogcritics.org/"},{"@type":"ListItem","position":2,"name":"Music Review: &#8216;Feminine Care&#8217; Lexagon"}]},{"@type":"Article","@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#article","isPartOf":{"@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#webpage"},"author":{"@id":"https://blogcritics.org/#/schema/person/86482f5f1b56663b6a066180877f3621"},"headline":"Music Review: &#8216;Feminine Care&#8217; Lexagon","datePublished":"2021-09-07T11:32:00+00:00","dateModified":"2021-09-07T11:32:02+00:00","mainEntityOfPage":{"@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#webpage"},"wordCount":419,"commentCount":0,"publisher":{"@id":"https://blogcritics.org/#organization"},"image":{"@id":"https://blogcritics.org/music-review-feminine-care-lexagon/#primaryimage"},"thumbnailUrl":"https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014280365.jpg","keywords":["avant-garde music","electronic music","Feminine Care","Lexagon","Music Review"],"articleSection":["Album Reviews","Ambient","Avant-garde","Music","Music Genres","Reviews music"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://blogcritics.org/music-review-feminine-care-lexagon/#respond"]}]},{"@type":"Person","@id":"https://blogcritics.org/#/schema/person/86482f5f1b56663b6a066180877f3621","name":"Richard Marcus","image":{"@type":"ImageObject","@id":"https://blogcritics.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/58e1c29772aaca69afaf8ccd1d707cf0?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/58e1c29772aaca69afaf8ccd1d707cf0?s=96&d=mm&r=g","caption":"Richard Marcus"},"description":"Richard Marcus is the author of two books commissioned by Ulysses Press, \"What Will Happen In Eragon IV?\" (2009) and \"The Unofficial Heroes Of Olympus Companion\". Aside from Blogcritics his work has appeared around the world in publications like the German edition of Rolling Stone Magazine and the multilingual web site Qantara.de. He has been writing for Blogcritics.org since 2005 and has published around 1900 articles at the site.","sameAs":["http://www.richardrbmarcus.com"],"url":"https://blogcritics.org/author/richard-marcus/"}]}</script>
	<!-- / Yoast SEO Premium plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Feed" href="https://blogcritics.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Comments Feed" href="https://blogcritics.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Music Review: &#8216;Feminine Care&#8217; Lexagon Comments Feed" href="https://blogcritics.org/music-review-feminine-care-lexagon/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blogcritics.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://blogcritics.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='tptn-style-left-thumbs-css'  href='https://blogcritics.org/wp-content/plugins/top-10/css/left-thumbs.min.css' type='text/css' media='all' />
<style id='tptn-style-left-thumbs-inline-css' type='text/css'>

			.tptn_related a {
			  width: 250px;
			  height: 250px;
			  text-decoration: none;
			}
			.tptn_related img {
			  max-width: 250px;
			  margin: auto;
			}
			.tptn_related .tptn_title {
			  width: 100%;
			}
			

			.tptn_posts_widget3 img.tptn_thumb {
				width: 110px !important;
				height: 75px !important;
			}
			
</style>
<link rel='stylesheet' id='tie-style-css'  href='https://blogcritics.org/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://blogcritics.org/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='tie-postviews-cache-js-extra'>
/* <![CDATA[ */
var tieViewsCacheL10n = {"admin_ajax_url":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","post_id":"5505789"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/postviews-cache.js' id='tie-postviews-cache-js'></script>
<link rel="https://api.w.org/" href="https://blogcritics.org/wp-json/" /><link rel="alternate" type="application/json" href="https://blogcritics.org/wp-json/wp/v2/posts/5505789" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogcritics.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blogcritics.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://blogcritics.org/?p=5505789' />
<link rel="alternate" type="application/json+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fmusic-review-feminine-care-lexagon%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fmusic-review-feminine-care-lexagon%2F&#038;format=xml" />
<style type="text/css">0</style><link rel="shortcut icon" href="https://blogcritics.org/wp-content/uploads/2017/09/favicon.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://blogcritics.org/wp-content/uploads/2017/09/apple-touch-icon.png" />



<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #7f0000;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#7f0000;
}

::-webkit-scrollbar-thumb{
	background-color:#7f0000 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #7f0000;
}

.search-block:after {
	border-right-color:#7f0000;
}

body.rtl .search-block:after {
	border-left-color:#7f0000;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #7f0000;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #7f0000;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #7f0000;
	border-color: #7f0000;
}

#order_review,
#order_review_heading {
	border-color: #7f0000;
}


a {
	color: #7f0000;
}
		
a:hover {
	color: #806060;
}
		
.top-nav ul li a:hover, .top-nav ul li:hover > a, .top-nav ul :hover > a , .top-nav ul li.current-menu-item a {
	color: #7f0000;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/blogcritics.org\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		<script async src='/cdn-cgi/challenge-platform/h/g/scripts/invisible.js'></script></head>
<body id="top" class="post-template-default single single-post postid-5505789 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://blogcritics.org/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Tuesday , September 7 2021</span>
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-5264769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264769"><a href="/contact/">Contact Us</a></li>
<li id="menu-item-5264771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264771"><a href="/write-for-blogcritics/">Writer Sign Up</a></li>
<li id="menu-item-5264773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264773"><a href="/about/">About</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://blogcritics.org/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="Blogcritics" href="https://blogcritics.org/">
					<img src="https://blogcritics.org/wp-content/uploads/2017/10/blogcritics-logo190px.jpg" alt="Blogcritics" /><strong>Blogcritics The critical lens on today&#039;s culture &amp; entertainment</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan e3lan-top">			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Logo Header Banner -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="3121633733"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-5264473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264473"><a href="/">Home</a></li>
<li id="menu-item-5367196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5367196"><a href="https://blogcritics.org/editor-picks/">Editor Picks</a></li>
<li id="menu-item-5264475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264475"><a href="https://blogcritics.org/tv/">TV</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5265485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265485"><a href="https://blogcritics.org/tv/tv-reviews-recaps/">Reviews &#038; Recaps</a></li>
	<li id="menu-item-5265515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265515"><a href="https://blogcritics.org/tv/interviews-tv/">Interviews</a></li>
	<li id="menu-item-5274805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5274805"><a href="https://blogcritics.org/film/columns-film/">Weekly TV Coverage</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5267599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267599"><a href="https://blogcritics.org/tv/tv-columns/gleekonomics/">Gleekonomics</a></li>
		<li id="menu-item-5267603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267603"><a href="https://blogcritics.org/tv/tv-columns/jeroming-the-tv-landscape/">Jeroming the TV Landscape</a></li>
		<li id="menu-item-5340221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5340221"><a href="https://blogcritics.org/tv/tv-columns/the-gallifreyian-groupie/">The Gallifreyan Groupie</a></li>
		<li id="menu-item-5267607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267607"><a href="https://blogcritics.org/tv/tv-columns/once-upon-a-time/">Once Upon a Time&#8230;There Was a Place Called Storybrooke</a></li>
		<li id="menu-item-5295573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5295573"><a href="https://blogcritics.org/tv/tv-columns/lets-talk-tv-with-barbara-barnett/">Let&#8217;s Talk TV with Barbara Barnett</a></li>
		<li id="menu-item-5267597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267597"><a href="https://blogcritics.org/tv/tv-columns/supernatural/">Supernatural Musings</a></li>
		<li id="menu-item-5267601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267601"><a href="https://blogcritics.org/tv/tv-columns/idol-wired/">Idol Wired</a></li>
		<li id="menu-item-5267609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267609"><a href="https://blogcritics.org/tv/tv-columns/sci-fi-primetime/">Sci-Fi Primetime</a></li>
		<li id="menu-item-5267605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267605"><a href="https://blogcritics.org/tv/tv-columns/mad-men-confidential/">Mad Men Confidential</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-5264553" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264553"><a href="https://blogcritics.org/music/">Music</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264585" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264585"><a href="https://blogcritics.org/music/reviews-music/">Reviews music</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5277445" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5277445"><a href="https://blogcritics.org/music/reviews-music/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-5264589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264589"><a href="https://blogcritics.org/music/reviews-music/concert-reviews/">Concert Reviews</a></li>
		<li id="menu-item-5277447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277447"><a href="https://blogcritics.org/music/reviews-music/music-dvd-blu-ray-reviews/">Music DVD &#038; Blu-ray Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-5264577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264577"><a href="https://blogcritics.org/music/interviews-music/">Interviews music</a></li>
</ul>
</li>
<li id="menu-item-5264599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264599"><a href="https://blogcritics.org/books/">Books</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264625"><a href="https://blogcritics.org/books/reviews-books/">Book Reviews</a></li>
	<li id="menu-item-5265519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265519"><a href="https://blogcritics.org/books/book-interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-5264731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264731"><a href="https://blogcritics.org/gaming/">Gaming</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264745"><a href="https://blogcritics.org/gaming/gaming-reviews/">Gaming Reviews</a></li>
	<li id="menu-item-5264743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264743"><a href="https://blogcritics.org/gaming/previews/">Previews</a></li>
	<li id="menu-item-5264741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264741"><a href="https://blogcritics.org/gaming/conferences/">Conferences</a></li>
</ul>
</li>
<li id="menu-item-5264641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264641"><a href="https://blogcritics.org/culture/">Culture and Society</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264647"><a href="https://blogcritics.org/culture/arts/">Arts</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5275059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275059"><a href="https://blogcritics.org/culture/arts/cabaret/">Cabaret</a></li>
		<li id="menu-item-5275061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275061"><a href="https://blogcritics.org/culture/arts/dance/">Dance</a></li>
		<li id="menu-item-5275063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275063"><a href="https://blogcritics.org/culture/arts/opera-arts/">Opera</a></li>
		<li id="menu-item-5275067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275067"><a href="https://blogcritics.org/culture/arts/theater/">Theater</a></li>
	</ul>
</li>
	<li id="menu-item-5292699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5292699"><a href="https://blogcritics.org/culture/culture-columns/">Culture Columns</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5292701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292701"><a href="https://blogcritics.org/culture/culture-columns/ending-world-hunger/">Ending World Hunger</a></li>
		<li id="menu-item-5443149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5443149"><a href="https://blogcritics.org/culture/culture-columns/language-matters/">Language Matters</a></li>
		<li id="menu-item-5292703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292703"><a href="https://blogcritics.org/culture/culture-columns/hometown-heroes-culture-columns/">Hometown Heroes</a></li>
	</ul>
</li>
	<li id="menu-item-5264643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264643"><a href="https://blogcritics.org/culture/politics/">Politics</a></li>
	<li id="menu-item-5264659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264659"><a href="https://blogcritics.org/culture/travel/">Travel</a></li>
	<li id="menu-item-5264661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264661"><a href="https://blogcritics.org/culture/scitech/">Science and Technology</a></li>
	<li id="menu-item-5264645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264645"><a href="https://blogcritics.org/culture/sports/">Sports</a></li>
	<li id="menu-item-5264663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264663"><a href="https://blogcritics.org/culture/spirituality/">Spirituality</a></li>
	<li id="menu-item-5264657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264657"><a href="https://blogcritics.org/culture/tips-and-advice/">Tips and Advice</a></li>
	<li id="menu-item-5439149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5439149"><a href="https://blogcritics.org/culture/personalfinance/">Personal Finance</a></li>
	<li id="menu-item-5264655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264655"><a href="https://blogcritics.org/culture/health-and-fitness/">Health and Fitness</a></li>
	<li id="menu-item-5264653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264653"><a href="https://blogcritics.org/culture/food-and-drink/">Food and Drink</a></li>
</ul>
</li>
<li id="menu-item-5264679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264679"><a href="https://blogcritics.org/film/">Film</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264711"><a href="https://blogcritics.org/film/reviews-film/">Reviews film</a></li>
	<li id="menu-item-5264685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264685"><a href="https://blogcritics.org/film/interviews-film/">Interviews film</a></li>
</ul>
</li>
<li id="menu-item-5406273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5406273"><a href="https://blogcritics.org/flash-fiction-2/">Flash Fiction</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<nav id="crumbs"><a href="https://blogcritics.org/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><span class="delimiter">/</span><a href="https://blogcritics.org/music/">Music</a><span class="delimiter">/</span><a href="https://blogcritics.org/music/reviews-music/">Reviews music</a><span class="delimiter">/</span><a href="https://blogcritics.org/music/reviews-music/album-reviews/">Album Reviews</a><span class="delimiter">/</span><span class="current">Music Review: &#8216;Feminine Care&#8217; Lexagon</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/blogcritics.org\/"}},{"@type":"ListItem","position":2,"item":{"name":"Music","@id":"https:\/\/blogcritics.org\/music\/"}},{"@type":"ListItem","position":3,"item":{"name":"Reviews music","@id":"https:\/\/blogcritics.org\/music\/reviews-music\/"}},{"@type":"ListItem","position":4,"item":{"name":"Album Reviews","@id":"https:\/\/blogcritics.org\/music\/reviews-music\/album-reviews\/"}}]}</script>
		

		<div class="e3lan e3lan-post">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=582133&width=320&height=50"></script> 				</div>
		<article class="post-listing post-5505789 post type-post status-publish format-standard has-post-thumbnail  category-album-reviews category-ambient category-avant-garde category-music category-music-genres category-reviews-music tag-avant-garde-music tag-electronic-music tag-feminine-care tag-lexagon tag-music-review" id="the-post">
			
			<div class="single-post-thumb">
			<img width="660" height="330" src="https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014246133-660x330.jpg" class="attachment-slider size-slider wp-post-image" alt="Cover Feminine Care Lexagon" loading="lazy" srcset="https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014246133-660x330.jpg 660w, https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014246133-1050x525.jpg 1050w" sizes="(max-width: 660px) 100vw, 660px" />		</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Music Review: &#8216;Feminine Care&#8217; Lexagon</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://blogcritics.org/author/richard-marcus/" title="">Richard Marcus </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>13 hours ago</span>	
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://blogcritics.org/music-review-feminine-care-lexagon/#respond"><span class="dsq-postid" data-dsqidentifier="5505789 https://blogcritics.org/?p=5505789">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>14 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					<div class="share-post">
	<span class="share-text">Share</span>

		<ul class="flat-social">
			<li><a href="https://www.facebook.com/sharer.php?u=https://blogcritics.org/music-review-feminine-care-lexagon/" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
				<li><a href="https://twitter.com/intent/tweet?text=Music+Review%3A+%E2%80%98Feminine+Care%E2%80%99+Lexagon&url=https://blogcritics.org/music-review-feminine-care-lexagon/" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
					<li><a href="https://www.linkedin.com/shareArticle?mini=true&amp;url=https://blogcritics.org/music-review-feminine-care-lexagon/&amp;title=Music+Review%3A+%E2%80%98Feminine+Care%E2%80%99+Lexagon" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li>
				<li><a href="https://pinterest.com/pin/create/button/?url=https://blogcritics.org/music-review-feminine-care-lexagon/&amp;description=Music+Review%3A+%E2%80%98Feminine+Care%E2%80%99+Lexagon&amp;media=https://blogcritics.org/wp-content/uploads/2021/09/Cover-Feminine-Care-Lexagon-e1631014246133-660x330.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->

					
					
<p><em><a href="https://ratskinrecords.bandcamp.com/album/feminine-care">Feminine Care</a>,</em> by Bay Area multimedia artist <a href="https://alexachristineburrell.com">Lexagon</a> (AKA Alexa Burrell) on <a href="https://ratskin.org">Ratskin Records</a>, is a complex and subtle musical examination of what it meant to be a woman of colour living during the time of the Trump presidency. However, anyone expecting strident political statements will be sorely disappointed, as these songs are more an emotional response than anything else.</p>



<p>Lexagon has created an eclectic mixture of electronic music and field recordings as the background for her vocalizations. For she presents her lyrics not just as singing or spoken word but a wonderful mixture of both. At times she sounds like she&#8217;s chanting, creating a spell that brings us deeper into the experience of her music.</p>



<p>While each song features a variety of created and found sounds the undercurrent that runs through all thirteen tracks on the album is Lexagon&#8217;s voice. At times reminiscent of the great blues and torch singers of the past with her wonderful resonance and ability to evoke emotional responses she simultaneously communicates complex ideas and thoughts.</p>



<p>Amazingly enough Lexagon is able to do this without any preaching and lecturing. Maybe that&#8217;s part of the spell she weaves with her music and voice. She creates an hypnotic atmosphere that eases us into a state where we allow her to communicate with us on an almost subliminal level.</p>



<p>Even those times, maybe especially, when her voice is almost lost amidst the wash of music we end up hearing the lyrics with as much clarity as any other piece. Part of this is because Lexagon&#8217;s voice is so intriguing we will put the effort into listening to her no matter what the circumstances, but this is also part of the magic she creates.&nbsp;</p>



<p>From the first moment you start playing <em>Feminine Care</em> you&#8217;re drawn into Lexagon&#8217;s alternate reality; one which explores how women are, and always have been, treated as something different. From the title of the album, the name some drugstores still use to designate aisles used for products relating to menstrual cycles, to its content she ensures you understand everything from social/economic realities impacting women to the constant fear they have to deal with simply walking down the street at night.</p>



<p>This is the world we&#8217;ve created and <em>Feminine Care</em> from Lexagon is a visceral and intelligent response to the indignities women, specifically women of colour, face daily. Considering what&#8217;s just happened in Texas this is not only and incredibly moving album, but a timely one as well.</p>
<div class="tptn_counter" id="tptn_counter_5505789">(Visited 13 times, 13 visits today)</div>					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json" class="tie-schema-graph">{"@context":"http:\/\/schema.org","@type":"BlogPosting","dateCreated":"2021-09-07T07:32:00-04:00","datePublished":"2021-09-07T07:32:00-04:00","dateModified":"2021-09-07T07:32:02-04:00","headline":"Music Review: &#8216;Feminine Care&#8217; Lexagon","name":"Music Review: &#8216;Feminine Care&#8217; Lexagon","keywords":"avant-garde music,electronic music,Feminine Care,Lexagon,Music Review","url":"https:\/\/blogcritics.org\/music-review-feminine-care-lexagon\/","description":"Feminine Care, by Bay Area multimedia artist Lexagon (AKA Alexa Burrell) on Ratskin Records, is a complex and subtle musical examination of what it meant to be a woman of colour living during the time","copyrightYear":"2021","publisher":{"@id":"#Publisher","@type":"Organization","name":"Blogcritics","logo":{"@type":"ImageObject","url":"http:\/\/blogcritics.org\/wp-content\/uploads\/2017\/10\/blogcritics-logo190px.jpg"},"sameAs":["https:\/\/www.facebook.com\/Blogcritics-132856246726018\/","http:\/\/twitter.com\/blogcritics"]},"sourceOrganization":{"@id":"#Publisher"},"copyrightHolder":{"@id":"#Publisher"},"mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/blogcritics.org\/music-review-feminine-care-lexagon\/","breadcrumb":{"@id":"#crumbs"}},"author":{"@type":"Person","name":"Richard Marcus","url":"https:\/\/blogcritics.org\/author\/richard-marcus\/"},"articleSection":"Album Reviews,Ambient,Avant-garde,Music,Music Genres,Reviews music","articleBody":"\nFeminine Care, by Bay Area multimedia artist Lexagon (AKA Alexa Burrell) on Ratskin Records, is a complex and subtle musical examination of what it meant to be a woman of colour living during the time of the Trump presidency. However, anyone expecting strident political statements will be sorely disappointed, as these songs are more an emotional response than anything else.\n\n\n\nLexagon has created an eclectic mixture of electronic music and field recordings as the background for her vocalizations. For she presents her lyrics not just as singing or spoken word but a wonderful mixture of both. At times she sounds like she's chanting, creating a spell that brings us deeper into the experience of her music.\n\n\n\nWhile each song features a variety of created and found sounds the undercurrent that runs through all thirteen tracks on the album is Lexagon's voice. At times reminiscent of the great blues and torch singers of the past with her wonderful resonance and ability to evoke emotional responses she simultaneously communicates complex ideas and thoughts.\n\n\n\nAmazingly enough Lexagon is able to do this without any preaching and lecturing. Maybe that's part of the spell she weaves with her music and voice. She creates an hypnotic atmosphere that eases us into a state where we allow her to communicate with us on an almost subliminal level.\n\n\n\nEven those times, maybe especially, when her voice is almost lost amidst the wash of music we end up hearing the lyrics with as much clarity as any other piece. Part of this is because Lexagon's voice is so intriguing we will put the effort into listening to her no matter what the circumstances, but this is also part of the magic she creates.&nbsp;\n\n\n\nFrom the first moment you start playing Feminine Care you're drawn into Lexagon's alternate reality; one which explores how women are, and always have been, treated as something different. From the title of the album, the name some drugstores still use to designate aisles used for products relating to menstrual cycles, to its content she ensures you understand everything from social\/economic realities impacting women to the constant fear they have to deal with simply walking down the street at night.\n\n\n\nThis is the world we've created and Feminine Care from Lexagon is a visceral and intelligent response to the indignities women, specifically women of colour, face daily. Considering what's just happened in Texas this is not only and incredibly moving album, but a timely one as well.\n","image":{"@type":"ImageObject","url":"https:\/\/blogcritics.org\/wp-content\/uploads\/2021\/09\/Cover-Feminine-Care-Lexagon-e1631014280365.jpg","width":750,"height":449}}</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://blogcritics.org/tag/avant-garde-music/" rel="tag">avant-garde music</a> <a href="https://blogcritics.org/tag/electronic-music/" rel="tag">electronic music</a> <a href="https://blogcritics.org/tag/feminine-care/" rel="tag">Feminine Care</a> <a href="https://blogcritics.org/tag/lexagon/" rel="tag">Lexagon</a> <a href="https://blogcritics.org/tag/music-review/" rel="tag">Music Review</a></p>

		<div class="e3lan e3lan-post">			<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Above Article Banner -->
<ins class="adsbygoogle"
     style="display:inline-block;width:468px;height:60px"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="4623660935"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div>
				<section id="author-box">
			<div class="block-head">
				<h3>About Richard Marcus </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/58e1c29772aaca69afaf8ccd1d707cf0?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/58e1c29772aaca69afaf8ccd1d707cf0?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' loading='lazy'/>	</div><!-- #author-avatar -->
			<div class="author-description">
						Richard Marcus is the author of two books commissioned by Ulysses Press, "What Will Happen In Eragon IV?" (2009) and "The Unofficial Heroes Of Olympus Companion". Aside from Blogcritics his work has appeared around the world in publications like the German edition of Rolling Stone Magazine and the multilingual web site Qantara.de. He has been writing for Blogcritics.org since 2005 and has published around 1900 articles at the site.		</div><!-- #author-description -->
			<div class="author-social flat-social">
						<a class="social-site" target="_blank" href="http://www.richardrbmarcus.com"><i class="fa fa-home"></i></a>
																													</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/exclusive-interview-eleanor-mccain-on-i-can-see-hope-from-here-a-celebration-of-canadian-music/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2021/09/Eleanor-McCain_Newfoundland_Credit-V.-Tony-Hauser-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Eleanor McCain I Can See Hope from Here" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/exclusive-interview-eleanor-mccain-on-i-can-see-hope-from-here-a-celebration-of-canadian-music/" rel="bookmark">Exclusive Interview: Eleanor McCain on &#8216;I Can See Hope from Here&#8217; &#8211; a Celebration of Canadian Music</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>6 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-reviews-jimmie-vaughan-suzie-ungerleider-connie-smith-karen-jonas-matt-jaffe-ward-hayden/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2021/09/Vaughan-Story-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-reviews-jimmie-vaughan-suzie-ungerleider-connie-smith-karen-jonas-matt-jaffe-ward-hayden/" rel="bookmark">Music Reviews: ‘The Jimmie Vaughan Story’ plus Suzie Ungerleider, Connie Smith, Karen Jonas, Matt Jaffe, and Ward Hayden</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>6 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-reviews-girl-from-the-north-country-explorer-tapes-oregon-ferrell-bostick/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2021/08/Girl-From-the-North-Country-310x165.jpeg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" loading="lazy" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-reviews-girl-from-the-north-country-explorer-tapes-oregon-ferrell-bostick/" rel="bookmark">Music Reviews: ‘Girl from the North Country’ Soundtrack, plus Explorer Tapes, Oregon, Sierra Ferrell, and Ben Bostick</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>2 weeks ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://blogcritics.org/music-review-willie-nile-the-day-the-earth-stood-still/">
					<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2021/08/Willie_Nile_Earth_Stood_Still_Cover_Art-Title-e1629804777619-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="The Day The Earth Stood Still" loading="lazy" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://blogcritics.org/music-review-willie-nile-the-day-the-earth-stood-still/" rel="bookmark">Music Review: Willie Nile: &#8216;The Day The Earth Stood Still&#8217;</a></h2>
			<p>'The Day The Earth Stood Still' from Willie Nile is a great album of timely and intelligent music from a heartfelt and aware songwriter.</p>
		</div>
			</section>
			
			
	
		
		
<div id="disqus_thread"></div>

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="widget_tptn_pop-3" class="widget tptn_posts_list_widget"><div class="widget-top"><h4>Trending</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div class="tptn_posts  tptn_posts_widget tptn_posts_widget3"><ul><li><a href="https://blogcritics.org/exclusive-interview-eleanor-mccain-on-i-can-see-hope-from-here-a-celebration-of-canadian-music/"    target="_blank"  class="tptn_link"><img  width="110" height="75"  src="https://blogcritics.org/wp-content/uploads/2021/09/Eleanor-McCain_Newfoundland_Credit-V.-Tony-Hauser-110x75.jpg" class="tptn_thumb tptn_featured" alt="Exclusive Interview: Eleanor McCain on &#039;I Can See Hope from Here&#039; - a Celebration of Canadian Music" title="Exclusive Interview: Eleanor McCain on &#039;I Can See Hope from Here&#039; - a Celebration of Canadian Music" /></a><span class="tptn_after_thumb"><a href="https://blogcritics.org/exclusive-interview-eleanor-mccain-on-i-can-see-hope-from-here-a-celebration-of-canadian-music/"    target="_blank"  class="tptn_link"><span class="tptn_title">Exclusive Interview: Eleanor McCain on &#8216;I Can&hellip;</span></a><span class="tptn_excerpt"> The Canadian singer tells us about her album 'I Can See Hope&hellip;</span></span></li><li><a href="https://blogcritics.org/theatre-interview-john-r-wilkinson-director-of-mugabe-my-dad-me/"    target="_blank"  class="tptn_link"><img  width="110" height="75"  src="https://blogcritics.org/wp-content/uploads/2021/08/Wilkinson_Featured-110x75.jpg" class="tptn_thumb tptn_featured" alt="Theatre Interview: John R. Wilkinson, Director of &#039;Mugabe, My Dad &amp; Me&#039;" title="Theatre Interview: John R. Wilkinson, Director of &#039;Mugabe, My Dad &amp; Me&#039;" /></a><span class="tptn_after_thumb"><a href="https://blogcritics.org/theatre-interview-john-r-wilkinson-director-of-mugabe-my-dad-me/"    target="_blank"  class="tptn_link"><span class="tptn_title">Theatre Interview: John R. Wilkinson, Director of&hellip;</span></a><span class="tptn_excerpt"> Wilkinson shares his approach to directing and the rehearsal process for this&hellip;</span></span></li><li><a href="https://blogcritics.org/music-reviews-jimmie-vaughan-suzie-ungerleider-connie-smith-karen-jonas-matt-jaffe-ward-hayden/"    target="_blank"  class="tptn_link"><img  width="110" height="75"  src="https://blogcritics.org/wp-content/uploads/2021/09/Vaughan-Story-110x75.jpg" class="tptn_thumb tptn_featured" alt="Music Reviews: ‘The Jimmie Vaughan Story’ plus Suzie Ungerleider, Connie Smith, Karen Jonas, Matt Jaffe, and Ward Hayden" title="Music Reviews: ‘The Jimmie Vaughan Story’ plus Suzie Ungerleider, Connie Smith, Karen Jonas, Matt Jaffe, and Ward Hayden" /></a><span class="tptn_after_thumb"><a href="https://blogcritics.org/music-reviews-jimmie-vaughan-suzie-ungerleider-connie-smith-karen-jonas-matt-jaffe-ward-hayden/"    target="_blank"  class="tptn_link"><span class="tptn_title">Music Reviews: ‘The Jimmie Vaughan Story’ plus Suzie&hellip;</span></a><span class="tptn_excerpt"> A star-studded box set surveys highlights from Jimmie Vaughan's long career. Also,&hellip;</span></span></li><li><a href="https://blogcritics.org/greenwichdocklands-international-festival-interview-jeanefer-jean-charles-choreographer-black-victorians/"    target="_blank"  class="tptn_link"><img  width="110" height="75"  src="https://blogcritics.org/wp-content/uploads/2021/08/BlackVictorians_Featured-110x75.jpg" class="tptn_thumb tptn_featured" alt="Greenwich+Docklands International Festival Interview: Jeanefer Jean-Charles, Choreographer and Artistic Director of &#039;Black Victorians&#039;" title="Greenwich+Docklands International Festival Interview: Jeanefer Jean-Charles, Choreographer and Artistic Director of &#039;Black Victorians&#039;" /></a><span class="tptn_after_thumb"><a href="https://blogcritics.org/greenwichdocklands-international-festival-interview-jeanefer-jean-charles-choreographer-black-victorians/"    target="_blank"  class="tptn_link"><span class="tptn_title">Greenwich+Docklands International Festival&hellip;</span></a><span class="tptn_excerpt"> Jeanefer Jean-Charles provides an in-depth look at the research and rehearsal processes&hellip;</span></span></li><li><a href="https://blogcritics.org/party-game-review-anchorman-improper-teleprompter-barry-jason/"    target="_blank"  class="tptn_link"><img  width="110" height="75"  src="https://blogcritics.org/wp-content/uploads/2021/08/Anchorman-The-Game-110x75.png" class="tptn_thumb tptn_featured" alt="Party Game Review: &#039;Anchorman: Improper Teleprompter&#039; from Barry &amp; Jason" title="Party Game Review: &#039;Anchorman: Improper Teleprompter&#039; from Barry &amp; Jason" /></a><span class="tptn_after_thumb"><a href="https://blogcritics.org/party-game-review-anchorman-improper-teleprompter-barry-jason/"    target="_blank"  class="tptn_link"><span class="tptn_title">Party Game Review: &#8216;Anchorman: Improper&hellip;</span></a><span class="tptn_excerpt"> 'Anchorman: The Legend of Ron Burgundy: The Game: Improper Teleprompter' from Barry&hellip;</span></span></li></ul><div class="tptn_clear"></div></div></div></div><!-- .widget /-->
		<div id="recent-posts-2" class="widget widget_recent_entries">
		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">
		<ul>
											<li>
					<a href="https://blogcritics.org/music-review-feminine-care-lexagon/" aria-current="page">Music Review: &#8216;Feminine Care&#8217; Lexagon</a>
									</li>
											<li>
					<a href="https://blogcritics.org/theatre-interview-john-r-wilkinson-director-of-mugabe-my-dad-me/">Theatre Interview: John R. Wilkinson, Director of &#8216;Mugabe, My Dad &#038; Me&#8217;</a>
									</li>
											<li>
					<a href="https://blogcritics.org/exclusive-interview-eleanor-mccain-on-i-can-see-hope-from-here-a-celebration-of-canadian-music/">Exclusive Interview: Eleanor McCain on &#8216;I Can See Hope from Here&#8217; &#8211; a Celebration of Canadian Music</a>
									</li>
											<li>
					<a href="https://blogcritics.org/graphic-novel-review-night-bus-by-zuo-ma-from-drawnquarterly/">Graphic Novel Review: &#8216;Night Bus&#8217; by Zuo Ma from Drawn+Quarterly</a>
									</li>
											<li>
					<a href="https://blogcritics.org/party-game-review-anchorman-improper-teleprompter-barry-jason/">Party Game Review: &#8216;Anchorman: Improper Teleprompter&#8217; from Barry &amp; Jason</a>
									</li>
					</ul>

		</div></div><!-- .widget /--><div id="categort-posts-widget-2" class="widget categort-posts"><div class="widget-top"><h4>Film Picks		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/blu-ray-review-the-water-man/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2021/08/Water-Man-BD-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/blu-ray-review-the-water-man/">Blu-ray Review: &#8216;The Water Man&#8217;</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>1 week ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/anthem-film-review-emotion-from-pain-to-laughter/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2021/08/FeaturedLP-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Anthem" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/anthem-film-review-emotion-from-pain-to-laughter/">Anthem Film Review: Emotion from Pain to Laughter</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>3 weeks ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/anthem-film-festival-review-mighty-ira-free-speech-champion/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2021/08/MIfeatured-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Mighty Ira" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/anthem-film-festival-review-mighty-ira-free-speech-champion/">Anthem Film Festival Review: ‘Mighty Ira’ – Free Speech Champion</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>3 weeks ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/anthem-film-review-films-and-the-zeitgeist-mix-it-up/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2021/08/Capture4-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="This Is Me" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/anthem-film-review-films-and-the-zeitgeist-mix-it-up/">Anthem Film Review: Films and the Zeitgeist Mix it Up</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>3 weeks ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/anthem-film-festival-review-rush-to-judgment-goes-deep/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2021/08/nick-nathan3better_orig-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="Anthem" loading="lazy" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/anthem-film-festival-review-rush-to-judgment-goes-deep/">Anthem Film Festival Review: ‘Rush to Judgment’ Goes Deep</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>August 8, 2021</span>		</li>
						</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /--><div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-top"><h4>Recent Comments</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11925">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://toliveandwriteinla.com/' rel='external nofollow ugc' class='url'>Leo Sopicki</a></span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11924">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11923">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/greta-thunberg-started-out-all-alone-but-shes-not-alone-anymore/#comment-11917">Greta the Great – Greta Thunberg Leads the Way on Climate Change</a></li><li class="recentcomments"><span class="comment-author-link">Dr Joseph S Maresca</span> on <a href="https://blogcritics.org/greta-thunberg-started-out-all-alone-but-shes-not-alone-anymore/#comment-11916">Greta the Great – Greta Thunberg Leads the Way on Climate Change</a></li></ul></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-2c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="facebook-widget-2" class="footer-widget facebook-widget"><div class="footer-widget-top"><h4>Find us on Facebook		</h4></div>
						<div class="footer-widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/pg/Blogcritics-132856246726018&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="latest_tweets_widget-2" class="footer-widget twitter-widget"><div class="footer-widget-top"><h4>			<a href="https://twitter.com/@Blogcritics">Follow Us</a>
		</h4></div>
						<div class="footer-widget-container">
<div class="twitter-widget-content" >
<ul class="twitter_update_list">
<li class="twitter-item">
	<i class="fa fa-twitter"></i>EXCLUSIVE INTERVIEW: Eleanor McCain on ‘I Can See Hope from Here’ – a Celebration of Canadian Music… <a href="https://t.co/ZQA5j9fS7O" class="twitter-link">https://t.co/ZQA5j9fS7O</a><small class="twitter-timestamp"><abbr title="2021/09/02 14:50:17">2021/09/02</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Music Reviews: ‘The Jimmie Vaughan Story’ box set, plus Suzie Ungerleider, Connie Smith, Karen Jonas, Matt Jaffe, a… <a href="https://t.co/PqK8Y5P1WH" class="twitter-link">https://t.co/PqK8Y5P1WH</a><small class="twitter-timestamp"><abbr title="2021/09/01 14:45:03">2021/09/01</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Party Game Review: ‘Anchorman: Improper Teleprompter’ from Barry &amp; Jason - Read our review!
<a href="https://t.co/P7Z8i6F6UU" class="twitter-link">https://t.co/P7Z8i6F6UU</a>… <a href="https://t.co/3hRZ0ifcIx" class="twitter-link">https://t.co/3hRZ0ifcIx</a><small class="twitter-timestamp"><abbr title="2021/09/01 14:40:57">2021/09/01</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Exclusive Interview: Jeanefer Jean-Charles, Choreographer and Artistic Director of ‘Black Victorians’ at the Greenw… <a href="https://t.co/pXmRWI5WF5" class="twitter-link">https://t.co/pXmRWI5WF5</a><small class="twitter-timestamp"><abbr title="2021/08/31 14:33:59">2021/08/31</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Book Review: ‘Reign Falls Down’ by Steven B. Harris <a href="https://t.co/lkVVnNSQF0" class="twitter-link">https://t.co/lkVVnNSQF0</a> <a href="https://twitter.com/#search?q=books" class="twitter-link">#books</a> <a href="https://t.co/FY0tfsX7aG" class="twitter-link">https://t.co/FY0tfsX7aG</a><small class="twitter-timestamp"><abbr title="2021/08/25 01:01:00">2021/08/25</abbr></small></li>
</ul> </div>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="https://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>  | Web Admin <a href="/cdn-cgi/l/email-protection#97fafef4fff6f2fbb9f4f6e5e5f6e4e6e2fefbfbf8d7f5fbf8f0f4e5fee3fef4e4b9f8e5f0">Michael Carrasquillo</a>		</div>
				
		<div class="alignleft">
			© Copyright 2021, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div id="reading-position-indicator"></div>        <meta http-equiv="imagetoolbar" content="no"><!-- disable image toolbar (if any) -->
        <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
            /*<![CDATA[*/
            document.oncontextmenu = function() {
                return false;
            };
            document.onselectstart = function() {
                if (event.srcElement.type != "text" && event.srcElement.type != "textarea" && event.srcElement.type != "password") {
                    return false;
                }
                else {
                    return true;
                }
            };
            if (window.sidebar) {
                document.onmousedown = function(e) {
                    var obj = e.target;
                    if (obj.tagName.toUpperCase() == 'SELECT'
                            || obj.tagName.toUpperCase() == "INPUT"
                            || obj.tagName.toUpperCase() == "TEXTAREA"
                            || obj.tagName.toUpperCase() == "PASSWORD") {
                        return true;
                    }
                    else {
                        return false;
                    }
                };
            }
            document.ondragstart = function() {
                return false;
            };
            /*]]>*/
        </script>
        <script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"blogcritics"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"5505789 https:\/\/blogcritics.org\/?p=5505789","disqusShortname":"blogcritics","disqusTitle":"Music Review: \u2018Feminine Care\u2019 Lexagon","disqusUrl":"https:\/\/blogcritics.org\/music-review-feminine-care-lexagon\/","postId":"5505789"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js' id='disqus_embed-js'></script>
<script type='text/javascript' id='tptn_tracker-js-extra'>
/* <![CDATA[ */
var ajax_tptn_tracker = {"ajax_url":"https:\/\/blogcritics.org\/","top_ten_id":"5505789","top_ten_blog_id":"1","activate_counter":"11","top_ten_debug":"0","tptn_rnd":"1153110790"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/top-10/includes/js/top-10-tracker.min.js' id='tptn_tracker-js'></script>
<script type='text/javascript' id='tie-scripts-js-extra'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"","lightbox_gallery":"","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/tie-scripts.js' id='tie-scripts-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/ilightbox.packed.js' id='tie-ilightbox-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/search.js' id='tie-search-js'></script>

        <script type="text/javascript">(function(){window['__CF$cv$params']={r:'68b6ab8c1ba4cf64',m:'ShxC8LBoLAbzKdmG209QmJRuTxsetrFAkwqzQGQei8k-1631088309-0-ASrgZ5vRJDlZIM5RofNWSkarAhXlVnmPqL7USIFyzdWa9feG+xaO0xtACTC7ucYab68CaFPSSuVv4xhb5L560qN/p1deoEJGPzv0vQeBZEH8H3lIzhciwDGE0smh5s9qSkIp+as86ZQgUzswnmf5l9JljUyX4mMF7EMhIwkl17Mu',s:[0xa922f0b78f,0x8b2fee247a],u:'/cdn-cgi/challenge-platform/h/g'}})();</script></body>
</html>
<!-- Cached by WP-Optimize (gzip) - https://getwpo.com - Last modified: Wed, 08 Sep 2021 00:36:31 GMT -->
