<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blogcritics.org/xmlrpc.php" />
<title>PAX East 2020 – Day 2 Experience | Blogcritics</title>
<meta property="og:title" content="PAX East 2020 – Day 2 Experience - Blogcritics"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="The second day of PAX East is where the feeling of the show really comes together. The first day is"/>
<meta property="og:url" content="https://blogcritics.org/pax-east-2020-day-2-experience/"/>
<meta property="og:site_name" content="Blogcritics"/>
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault-660x330.jpg" />

<!-- This site is optimized with the Yoast SEO plugin v13.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Pathfinder Wrath of the Righteous, Ghostrunner, and Othercide were three games that looked very promising at PAX East 2020."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://blogcritics.org/pax-east-2020-day-2-experience/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="PAX East 2020 – Day 2 Experience | Blogcritics" />
<meta property="og:description" content="Pathfinder Wrath of the Righteous, Ghostrunner, and Othercide were three games that looked very promising at PAX East 2020." />
<meta property="og:url" content="https://blogcritics.org/pax-east-2020-day-2-experience/" />
<meta property="og:site_name" content="Blogcritics" />
<meta property="article:publisher" content="https://www.facebook.com/blogcritics/" />
<meta property="article:tag" content="cRPG" />
<meta property="article:tag" content="ghostrunner" />
<meta property="article:tag" content="othercide" />
<meta property="article:tag" content="pathfinder wrath of the righteous" />
<meta property="article:tag" content="PAX East" />
<meta property="article:tag" content="pax east 2020" />
<meta property="article:tag" content="penny arcade expo" />
<meta property="article:tag" content="pinny arcade" />
<meta property="article:tag" content="strategy games" />
<meta property="article:tag" content="video game" />
<meta property="article:tag" content="videogames" />
<meta property="article:section" content="Gaming" />
<meta property="article:published_time" content="2020-03-08T22:45:32+00:00" />
<meta property="article:modified_time" content="2020-03-08T22:45:34+00:00" />
<meta property="og:updated_time" content="2020-03-08T22:45:34+00:00" />
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault.jpg" />
<meta property="og:image:secure_url" content="https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Pathfinder Wrath of the Righteous, Ghostrunner, and Othercide were three games that looked very promising at PAX East 2020." />
<meta name="twitter:title" content="PAX East 2020 – Day 2 Experience | Blogcritics" />
<meta name="twitter:site" content="@blogcritics" />
<meta name="twitter:image" content="https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault.jpg" />
<meta name="twitter:creator" content="@blogcritics" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://blogcritics.org/#organization","name":"Blogcritics","url":"https://blogcritics.org/","sameAs":["https://www.facebook.com/blogcritics/","https://www.linkedin.com/company/227939/","https://twitter.com/blogcritics"],"logo":{"@type":"ImageObject","@id":"https://blogcritics.org/#logo","inLanguage":"en-US","url":"https://blogcritics.org/wp-content/uploads/2017/09/blogcritics-logo-wplogin320_65.png","width":320,"height":65,"caption":"Blogcritics"},"image":{"@id":"https://blogcritics.org/#logo"}},{"@type":"WebSite","@id":"https://blogcritics.org/#website","url":"https://blogcritics.org/","name":"Blogcritics","inLanguage":"en-US","description":"The critical lens on today&#039;s culture &amp; entertainment","publisher":{"@id":"https://blogcritics.org/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://blogcritics.org/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#primaryimage","inLanguage":"en-US","url":"https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault.jpg","width":1280,"height":720},{"@type":"WebPage","@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#webpage","url":"https://blogcritics.org/pax-east-2020-day-2-experience/","name":"PAX East 2020 \u2013 Day 2 Experience | Blogcritics","isPartOf":{"@id":"https://blogcritics.org/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#primaryimage"},"datePublished":"2020-03-08T22:45:32+00:00","dateModified":"2020-03-08T22:45:34+00:00","description":"Pathfinder Wrath of the Righteous, Ghostrunner, and Othercide were three games that looked very promising at PAX East 2020."},{"@type":"Article","@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#article","isPartOf":{"@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#webpage"},"author":{"@id":"https://blogcritics.org/#/schema/person/e2c6e21dd2ab5180ce0ebe70a24888ff"},"headline":"PAX East 2020 \u2013 Day 2 Experience","datePublished":"2020-03-08T22:45:32+00:00","dateModified":"2020-03-08T22:45:34+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#webpage"},"publisher":{"@id":"https://blogcritics.org/#organization"},"image":{"@id":"https://blogcritics.org/pax-east-2020-day-2-experience/#primaryimage"},"keywords":"cRPG,ghostrunner,othercide,pathfinder wrath of the righteous,PAX East,pax east 2020,penny arcade expo,pinny arcade,strategy games,video game,videogames","articleSection":"Conferences,Editor Pick: Gaming,Gaming,Gaming Interviews,Gaming News,PC/Mac,Playstation,Previews,Top Stories,Xbox","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://blogcritics.org/#/schema/person/e2c6e21dd2ab5180ce0ebe70a24888ff","name":"Michael Prince","image":{"@type":"ImageObject","@id":"https://blogcritics.org/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=96&d=mm&r=g","caption":"Michael Prince"},"description":"A longtime video game fan starting from simple games on the Atari 2600 to newer titles on a bleeding edge PC I play everything I can get my hands on.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel="amphtml" href="https://blogcritics.org/pax-east-2020-day-2-experience/?amp" /><meta name="generator" content="AMP for WP 1.0.32"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Feed" href="https://blogcritics.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Comments Feed" href="https://blogcritics.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; PAX East 2020 – Day 2 Experience Comments Feed" href="https://blogcritics.org/pax-east-2020-day-2-experience/feed/" />
<!-- This site uses the Google Analytics by ExactMetrics plugin v6.0.2 - Using Analytics tracking - https://www.exactmetrics.com/ -->
<script type="text/javascript" data-cfasync="false">
	var em_version         = '6.0.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-1811558-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-1811558-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}
</script>
<!-- / Google Analytics by ExactMetrics -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blogcritics.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://blogcritics.org/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blogcritics.org/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://blogcritics.org/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://blogcritics.org/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/blogcritics.org","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/google-analytics-dashboard-for-wp/assets/js/frontend.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tieViewsCacheL10n = {"admin_ajax_url":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","post_id":"5499372"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/postviews-cache.js'></script>
<link rel='https://api.w.org/' href='https://blogcritics.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogcritics.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blogcritics.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://blogcritics.org/?p=5499372' />
<link rel="alternate" type="application/json+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fpax-east-2020-day-2-experience%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fpax-east-2020-day-2-experience%2F&#038;format=xml" />
<link rel="shortcut icon" href="https://blogcritics.org/wp-content/uploads/2017/09/favicon.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://blogcritics.org/wp-content/uploads/2017/09/apple-touch-icon.png" />



<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #7f0000;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#7f0000;
}

::-webkit-scrollbar-thumb{
	background-color:#7f0000 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #7f0000;
}

.search-block:after {
	border-right-color:#7f0000;
}

body.rtl .search-block:after {
	border-left-color:#7f0000;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #7f0000;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #7f0000;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #7f0000;
	border-color: #7f0000;
}

#order_review,
#order_review_heading {
	border-color: #7f0000;
}


a {
	color: #7f0000;
}
		
a:hover {
	color: #806060;
}
		
.top-nav ul li a:hover, .top-nav ul li:hover > a, .top-nav ul :hover > a , .top-nav ul li.current-menu-item a {
	color: #7f0000;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/blogcritics.org\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		</head>
<body id="top" class="post-template-default single single-post postid-5499372 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://blogcritics.org/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Sunday , March 8 2020</span>
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-5264769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264769"><a href="/contact/">Contact Us</a></li>
<li id="menu-item-5264771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264771"><a href="/write-for-blogcritics/">Writer Sign Up</a></li>
<li id="menu-item-5264773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264773"><a href="/about/">About</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://blogcritics.org/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="https://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="Blogcritics" href="https://blogcritics.org/">
					<img src="https://blogcritics.org/wp-content/uploads/2017/10/blogcritics-logo190px.jpg" alt="Blogcritics" /><strong>Blogcritics The critical lens on today&#039;s culture &amp; entertainment</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan e3lan-top">			<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Logo Header Banner -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="3121633733"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-5264473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264473"><a href="/">Home</a></li>
<li id="menu-item-5367196" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-5367196"><a href="https://blogcritics.org/editor-picks/">Editor Picks</a></li>
<li id="menu-item-5264475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264475"><a href="https://blogcritics.org/tv/">TV</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5265485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265485"><a href="https://blogcritics.org/tv/tv-reviews-recaps/">Reviews &#038; Recaps</a></li>
	<li id="menu-item-5265515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265515"><a href="https://blogcritics.org/tv/interviews-tv/">Interviews</a></li>
	<li id="menu-item-5274805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5274805"><a href="https://blogcritics.org/film/columns-film/">Weekly TV Coverage</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5267599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267599"><a href="https://blogcritics.org/tv/tv-columns/gleekonomics/">Gleekonomics</a></li>
		<li id="menu-item-5267603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267603"><a href="https://blogcritics.org/tv/tv-columns/jeroming-the-tv-landscape/">Jeroming the TV Landscape</a></li>
		<li id="menu-item-5340221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5340221"><a href="https://blogcritics.org/tv/tv-columns/the-gallifreyian-groupie/">The Gallifreyan Groupie</a></li>
		<li id="menu-item-5267607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267607"><a href="https://blogcritics.org/tv/tv-columns/once-upon-a-time/">Once Upon a Time&#8230;There Was a Place Called Storybrooke</a></li>
		<li id="menu-item-5295573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5295573"><a href="https://blogcritics.org/tv/tv-columns/lets-talk-tv-with-barbara-barnett/">Let&#8217;s Talk TV with Barbara Barnett</a></li>
		<li id="menu-item-5267597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267597"><a href="https://blogcritics.org/tv/tv-columns/supernatural/">Supernatural Musings</a></li>
		<li id="menu-item-5267601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267601"><a href="https://blogcritics.org/tv/tv-columns/idol-wired/">Idol Wired</a></li>
		<li id="menu-item-5267609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267609"><a href="https://blogcritics.org/tv/tv-columns/sci-fi-primetime/">Sci-Fi Primetime</a></li>
		<li id="menu-item-5267605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267605"><a href="https://blogcritics.org/tv/tv-columns/mad-men-confidential/">Mad Men Confidential</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-5264553" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264553"><a href="https://blogcritics.org/music/">Music</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264585"><a href="https://blogcritics.org/music/reviews-music/">Reviews music</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5277445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277445"><a href="https://blogcritics.org/music/reviews-music/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-5264589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264589"><a href="https://blogcritics.org/music/reviews-music/concert-reviews/">Concert Reviews</a></li>
		<li id="menu-item-5277447" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277447"><a href="https://blogcritics.org/music/reviews-music/music-dvd-blu-ray-reviews/">Music DVD &#038; Blu-ray Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-5264577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264577"><a href="https://blogcritics.org/music/interviews-music/">Interviews music</a></li>
</ul>
</li>
<li id="menu-item-5264599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264599"><a href="https://blogcritics.org/books/">Books</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264625"><a href="https://blogcritics.org/books/reviews-books/">Book Reviews</a></li>
	<li id="menu-item-5265519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265519"><a href="https://blogcritics.org/books/book-interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-5264731" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264731"><a href="https://blogcritics.org/gaming/">Gaming</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264745"><a href="https://blogcritics.org/gaming/gaming-reviews/">Gaming Reviews</a></li>
	<li id="menu-item-5264743" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5264743"><a href="https://blogcritics.org/gaming/previews/">Previews</a></li>
	<li id="menu-item-5264741" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5264741"><a href="https://blogcritics.org/gaming/conferences/">Conferences</a></li>
</ul>
</li>
<li id="menu-item-5264641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264641"><a href="https://blogcritics.org/culture/">Culture and Society</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264647"><a href="https://blogcritics.org/culture/arts/">Arts</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5275059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275059"><a href="https://blogcritics.org/culture/arts/cabaret/">Cabaret</a></li>
		<li id="menu-item-5275061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275061"><a href="https://blogcritics.org/culture/arts/dance/">Dance</a></li>
		<li id="menu-item-5275063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275063"><a href="https://blogcritics.org/culture/arts/opera-arts/">Opera</a></li>
		<li id="menu-item-5275067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275067"><a href="https://blogcritics.org/culture/arts/theater/">Theater</a></li>
	</ul>
</li>
	<li id="menu-item-5292699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5292699"><a href="https://blogcritics.org/culture/culture-columns/">Culture Columns</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5292701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292701"><a href="https://blogcritics.org/culture/culture-columns/ending-world-hunger/">Ending World Hunger</a></li>
		<li id="menu-item-5443149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5443149"><a href="https://blogcritics.org/culture/culture-columns/language-matters/">Language Matters</a></li>
		<li id="menu-item-5292703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292703"><a href="https://blogcritics.org/culture/culture-columns/hometown-heroes-culture-columns/">Hometown Heroes</a></li>
	</ul>
</li>
	<li id="menu-item-5264643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264643"><a href="https://blogcritics.org/culture/politics/">Politics</a></li>
	<li id="menu-item-5264659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264659"><a href="https://blogcritics.org/culture/travel/">Travel</a></li>
	<li id="menu-item-5264661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264661"><a href="https://blogcritics.org/culture/scitech/">Science and Technology</a></li>
	<li id="menu-item-5264645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264645"><a href="https://blogcritics.org/culture/sports/">Sports</a></li>
	<li id="menu-item-5264663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264663"><a href="https://blogcritics.org/culture/spirituality/">Spirituality</a></li>
	<li id="menu-item-5264657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264657"><a href="https://blogcritics.org/culture/tips-and-advice/">Tips and Advice</a></li>
	<li id="menu-item-5439149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5439149"><a href="https://blogcritics.org/culture/personalfinance/">Personal Finance</a></li>
	<li id="menu-item-5264655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264655"><a href="https://blogcritics.org/culture/health-and-fitness/">Health and Fitness</a></li>
	<li id="menu-item-5264653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264653"><a href="https://blogcritics.org/culture/food-and-drink/">Food and Drink</a></li>
</ul>
</li>
<li id="menu-item-5264679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264679"><a href="https://blogcritics.org/film/">Film</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264711"><a href="https://blogcritics.org/film/reviews-film/">Reviews film</a></li>
	<li id="menu-item-5264685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264685"><a href="https://blogcritics.org/film/interviews-film/">Interviews film</a></li>
</ul>
</li>
<li id="menu-item-5406273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5406273"><a href="https://blogcritics.org/flash-fiction-2/">Flash Fiction</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<nav id="crumbs"><a href="https://blogcritics.org/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><span class="delimiter">/</span><a href="https://blogcritics.org/gaming/">Gaming</a><span class="delimiter">/</span><a href="https://blogcritics.org/gaming/conferences/">Conferences</a><span class="delimiter">/</span><span class="current">PAX East 2020 – Day 2 Experience</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/blogcritics.org\/"}},{"@type":"ListItem","position":2,"item":{"name":"Gaming","@id":"https:\/\/blogcritics.org\/gaming\/"}},{"@type":"ListItem","position":3,"item":{"name":"Conferences","@id":"https:\/\/blogcritics.org\/gaming\/conferences\/"}}]}</script>
		

		<div class="e3lan e3lan-post">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=582133&width=320&height=50"></script> 				</div>
		<article class="post-listing post-5499372 post type-post status-publish format-standard has-post-thumbnail  category-conferences category-gaming-picks category-gaming category-gaming-interviews category-gaming-news category-pc-mac category-playstation category-previews category-top-stories category-xbox tag-crpg tag-ghostrunner tag-othercide tag-pathfinder-wrath-of-the-righteous tag-pax-east tag-pax-east-2020 tag-penny-arcade-expo tag-pinny-arcade tag-strategy-games tag-video-game tag-videogames" id="the-post">
			
			<div class="single-post-thumb">
			<img width="660" height="330" src="https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault-660x330.jpg" class="attachment-slider size-slider wp-post-image" alt="" srcset="https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault-660x330.jpg 660w, https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault-1050x525.jpg 1050w" sizes="(max-width: 660px) 100vw, 660px" />		</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">PAX East 2020 – Day 2 Experience</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://blogcritics.org/author/michael-prince/" title="">Michael Prince </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>19 mins ago</span>	
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://blogcritics.org/pax-east-2020-day-2-experience/#respond"><span class="dsq-postid" data-dsqidentifier="5499372 https://blogcritics.org/?p=5499372">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>4 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					<div class="share-post">
	<span class="share-text">Share</span>

		<ul class="flat-social">
			<li><a href="https://www.facebook.com/sharer.php?u=https://blogcritics.org/pax-east-2020-day-2-experience/" class="social-facebook" rel="external" target="_blank"><i class="fa fa-facebook"></i> <span>Facebook</span></a></li>
				<li><a href="https://twitter.com/intent/tweet?text=PAX+East+2020+%E2%80%93+Day+2+Experience&url=https://blogcritics.org/pax-east-2020-day-2-experience/" class="social-twitter" rel="external" target="_blank"><i class="fa fa-twitter"></i> <span>Twitter</span></a></li>
					<li><a href="https://www.linkedin.com/shareArticle?mini=true&url=https://blogcritics.org/pax-east-2020-day-2-experience/&title=PAX+East+2020+%E2%80%93+Day+2+Experience" class="social-linkedin" rel="external" target="_blank"><i class="fa fa-linkedin"></i> <span>LinkedIn</span></a></li>
				<li><a href="https://pinterest.com/pin/create/button/?url=https://blogcritics.org/pax-east-2020-day-2-experience/&amp;description=PAX+East+2020+%E2%80%93+Day+2+Experience&amp;media=https://blogcritics.org/wp-content/uploads/2020/03/maxresdefault-660x330.jpg" class="social-pinterest" rel="external" target="_blank"><i class="fa fa-pinterest"></i> <span>Pinterest</span></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->

					
					
<p>The second day of <a rel="noreferrer noopener" aria-label="PAX East (opens in a new tab)" href="https://east.paxsite.com/" target="_blank">PAX East</a> is where the feeling of the show really comes together. The first day is always a little less crowded, the developers are just starting to get into their groove. On Day Two people are more in synch with the vibe of the show.</p>



<p>I had just finished a full day and night as PAX started, and was feeling the impact of a late night doing the annual charity <a rel="noreferrer noopener" aria-label="Pokecrawl  (opens in a new tab)" href="https://twitter.com/paxpokecrawl?lang=en" target="_blank">Pokecrawl </a>– a pub crawl with 300 fellow Pokemon fans spread across six teams. We head to bars, challenge each other with themed drink-offs, and donate plenty of money to <a rel="noreferrer noopener" aria-label="Childs Play (opens in a new tab)" href="http://childsplaycharity.org/" target="_blank">Child&#8217;s Play</a>. This year we raise over $7,200 for that amazing charity, which shows how big-hearted all the participants are.</p>



<p>Heading into the show floor my goal was to wander the length of the con and earmark a bunch of games and vendors to check out before the show ended. I also wanted to pick up some souvenirs for my kids so I hit a bunch of the shirt and dice vendors to get them some swag.</p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/20200301_214359-1024x640.jpg" alt="" class="wp-image-5499375" srcset="https://blogcritics.org/wp-content/uploads/2020/03/20200301_214359-1024x640.jpg 1024w, https://blogcritics.org/wp-content/uploads/2020/03/20200301_214359-330x206.jpg 330w, https://blogcritics.org/wp-content/uploads/2020/03/20200301_214359-768x480.jpg 768w, https://blogcritics.org/wp-content/uploads/2020/03/20200301_214359-1536x960.jpg 1536w, https://blogcritics.org/wp-content/uploads/2020/03/20200301_214359-2048x1280.jpg 2048w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>I was also determined to stock up on a bunch of Pinny Arcade Pins. My goal was to collect Pins that would look good on the lapels of my suit jackets.  So they had to not be overly cartoony or too blatantly gamified. I ended up getting a nice haul from various booths and vendors.  I like to show my geek cred but not veer too far into unprofessional territory.</p>



<p>There were plenty of amazing games I had a chance to check
out as well.&nbsp; Some were smaller
experiences, but all were actually quite fun and promising.</p>



<p><strong><em><a href="https://wrath.owlcatgames.com/" target="_blank" rel="noreferrer noopener" aria-label="Pathfinder Wrath of the Righteous (opens in a new tab)">Pathfinder Wrath of the Righteous</a></em></strong></p>



<p>I had the great pleasure of checking out this title at PAX East. This is the second title in the <em>Pathfinder </em>CRPG universe and based on what I saw it will be an incredible role playing experience. <a rel="noreferrer noopener" aria-label="Currently in the middle of its Kickstarter campaign (opens in a new tab)" href="https://www.kickstarter.com/projects/owlcatgames/pathfinder-wrath-of-the-righteous" target="_blank">Currently in the middle of its Kickstarter campaign</a> and having raised over $1.5 million, the developer in making this is a rare Kickstarter success story for games in recent years.</p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_MinotaurAttack_1920x1080-1024x576.jpg" alt="" class="wp-image-5499379" srcset="https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_MinotaurAttack_1920x1080-1024x576.jpg 1024w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_MinotaurAttack_1920x1080-330x186.jpg 330w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_MinotaurAttack_1920x1080-768x432.jpg 768w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_MinotaurAttack_1920x1080-1536x864.jpg 1536w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_MinotaurAttack_1920x1080.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>The focus of this game is the world of Sarkoris 100 years before the first game, with the land overrun by demonic forces. Many crusades have been waged against the demons, and the story picks up as the player-controlled commander of the 5<sup>th</sup> crusade starts to gather forces to push back the demonic forces.</p>



<p>With many different races and classes to choose from, I was shown incredibly deep options to customize my main party as well as the lead character. Various characters join in the crusade – a diabolical devil (ancient foes of demons) and a dwarven demon assassin to name just a couple.</p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_KnockedOutGates_1920x1080-1024x576.jpg" alt="" class="wp-image-5499376" srcset="https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_KnockedOutGates_1920x1080-1024x576.jpg 1024w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_KnockedOutGates_1920x1080-330x186.jpg 330w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_KnockedOutGates_1920x1080-768x432.jpg 768w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_KnockedOutGates_1920x1080-1536x864.jpg 1536w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_KnockedOutGates_1920x1080.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>On top of the main characters in the party, in many instances crusaders or other forces take part in battles, helping to bolster my party’s forces as we battle the demons. Commanding battles and they way they unfold is also a huge part of the game.</p>



<p>Each member of the party has numerous skills and attacks, but the new Mythic path system was the coolest thing I saw in the game. At a certain point we will be able to choose a Mythic path allowing the main character to channel extraordinary abilities as a mythic entity. Each path will follow a specific theme, has a profound impact on the main story of the adventure, grants powerful unique abilities, and affects the character’s appearance.</p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_TavernDefend_1920x1080-1024x576.jpg" alt="" class="wp-image-5499377" srcset="https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_TavernDefend_1920x1080-1024x576.jpg 1024w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_TavernDefend_1920x1080-330x186.jpg 330w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_TavernDefend_1920x1080-768x432.jpg 768w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_TavernDefend_1920x1080-1536x864.jpg 1536w, https://blogcritics.org/wp-content/uploads/2020/03/PFWOTR_TavernDefend_1920x1080.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>I was able to see the Lich in action as one of the options, and the special abilities were very impressive. The system promises a great deal of extra depth for the game once it releases. Other paths give a mythic identity of an Angel, Aeon, Trickster, Demon, Azata, and Legend.</p>



<p>While the game is still in an early form, the amount of variety in skills, characters, and systems, along with the Mythic progression system, made it incredibly appealing to me. The renaissance of CRPGs like this has been amazing and <em>Pathfinder Wrath of the Righteous</em> looks to be another great example in this genre.</p>



<p>Check out its <a rel="noreferrer noopener" aria-label="Kickstarter campaign (opens in a new tab)" href="https://www.kickstarter.com/projects/owlcatgames/pathfinder-wrath-of-the-righteous" target="_blank">Kickstarter campaign</a> to see the stretch goals and release information as this will be a game well worth exploring once it releases.</p>



<p><strong><em><a href="https://ghostrunnergame.com/" target="_blank" rel="noreferrer noopener" aria-label="Ghostrunner (opens in a new tab)">Ghostrunner</a></em></strong></p>



<p>This game was visually one of the best I saw at the conference, set in a dystopian future where violence lives and breeds in humanity’s last remaining tower-city. Playing as a cyber-warrior I was able to dash, slide, wall jump, slow down time, and kill with one strike. Unfortunately the enemies could take me out in one hit as well, making this a deadly speedy dance as I rushed through the world.</p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-1024x549.png" alt="" class="wp-image-5499380" srcset="https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-1024x549.png 1024w, https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-330x177.png 330w, https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-768x412.png 768w, https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-1536x823.png 1536w, https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-2048x1098.png 2048w, https://blogcritics.org/wp-content/uploads/2020/03/Ghostrunner_screenshot_01-310x165.png 310w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>This was an incredibly challenging game, but the developer added instant respawning (really!) that makes re-trying the section over and over again easy and very fun. There is magical timing required to jump, wall run, slow down time, and strike the enemies without taking a hit. I was warned I would die, a lot, and I did but it was continually fun.</p>



<p>The dev team <a href="http://www.onemorelevel.com/" target="_blank" rel="noreferrer noopener" aria-label="One More Level (opens in a new tab)">One More Level</a> was so engaged and positive about their game when I chatted with them and with good reason. <em>Ghostrunner </em>was such a fast, frantic, and beautiful experience and left me wanting more.  The game is more of a core action experience with less focus on story but if they deliver on the promise of what I saw at PAX East it will be a really fun experience.</p>



<p><strong><em><a href="https://www.othercidegame.com/" target="_blank" rel="noreferrer noopener" aria-label="Othercide (opens in a new tab)">Othercide</a></em></strong></p>



<p>This incredibly atmospheric game from French studio <a rel="noreferrer noopener" aria-label="LightBulb Crew (opens in a new tab)" href="https://lightbulbcrew.fr/" target="_blank">LightBulb Crew</a> is a turn-based strategy game that follows the Xcom formula simply from the fact that characters act in sequence depending on their action priority. Aside from that the game is as different as can be from the classic alien invasion game. </p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/othercide-1024x576.jpg" alt="" class="wp-image-5499373" srcset="https://blogcritics.org/wp-content/uploads/2020/03/othercide-1024x576.jpg 1024w, https://blogcritics.org/wp-content/uploads/2020/03/othercide-330x186.jpg 330w, https://blogcritics.org/wp-content/uploads/2020/03/othercide-768x432.jpg 768w, https://blogcritics.org/wp-content/uploads/2020/03/othercide-1536x864.jpg 1536w, https://blogcritics.org/wp-content/uploads/2020/03/othercide.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>The focus is on a group of clones patterned after an immortal and powerful warrior called Mother. These daughters are created to battle against the diabolic forces haunting the world. Created as warriors, all the daughters start relatively the same, but quickly diverge as skills and weapons are chosen.</p>



<p>The action in <em>Othercide </em>utilizes a dynamic timeline system where it is clearly shown when everyone will perform their actions. Unlike Xcom there is NO cover so actions need to be carefully considered to be successful and avoid counterattacks.</p>



<figure class="wp-block-image size-large"><img src="https://blogcritics.org/wp-content/uploads/2020/03/Othercide_Screenshot-04_Logo-1024x576.jpg" alt="" class="wp-image-5499382" srcset="https://blogcritics.org/wp-content/uploads/2020/03/Othercide_Screenshot-04_Logo-1024x576.jpg 1024w, https://blogcritics.org/wp-content/uploads/2020/03/Othercide_Screenshot-04_Logo-330x186.jpg 330w, https://blogcritics.org/wp-content/uploads/2020/03/Othercide_Screenshot-04_Logo-768x432.jpg 768w, https://blogcritics.org/wp-content/uploads/2020/03/Othercide_Screenshot-04_Logo-1536x864.jpg 1536w, https://blogcritics.org/wp-content/uploads/2020/03/Othercide_Screenshot-04_Logo.jpg 1920w" sizes="(max-width: 1024px) 100vw, 1024px" /></figure>



<p>The system has roguelike elements and some of the daughters will die, but those that survive will grow in power and skill to become as powerful as Mother eventually. Some daughters can be sacrificed to heal others, adding a very sticky moral layer as you keep key daughters alive to fight again.</p>



<p>The game features a black and white art style with flashes of color. The visuals blew me away. The gameplay was also quite fun and very strategic, causing me to carefully examine every action before I committed. The dynamic timeline was crucial to pay attention to in order to succeed.</p>



<p><em>Othercide </em>will be released on Steam this year and the developer told me there will be numerous Betas up until release to continue refining the game. Based on what I saw this will be a very cool, challenging, and stylish strategy game with a lot of surprises.</p>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://blogcritics.org/tag/crpg/" rel="tag">cRPG</a> <a href="https://blogcritics.org/tag/ghostrunner/" rel="tag">ghostrunner</a> <a href="https://blogcritics.org/tag/othercide/" rel="tag">othercide</a> <a href="https://blogcritics.org/tag/pathfinder-wrath-of-the-righteous/" rel="tag">pathfinder wrath of the righteous</a> <a href="https://blogcritics.org/tag/pax-east/" rel="tag">PAX East</a> <a href="https://blogcritics.org/tag/pax-east-2020/" rel="tag">pax east 2020</a> <a href="https://blogcritics.org/tag/penny-arcade-expo/" rel="tag">penny arcade expo</a> <a href="https://blogcritics.org/tag/pinny-arcade/" rel="tag">pinny arcade</a> <a href="https://blogcritics.org/tag/strategy-games/" rel="tag">strategy games</a> <a href="https://blogcritics.org/tag/video-game/" rel="tag">video game</a> <a href="https://blogcritics.org/tag/videogames/" rel="tag">videogames</a></p>

		<div class="e3lan e3lan-post">			<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Above Article Banner -->
<ins class="adsbygoogle"
     style="display:inline-block;width:468px;height:60px"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="4623660935"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>				</div>
				<section id="author-box">
			<div class="block-head">
				<h3>About Michael Prince </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/4d18dd69dcf585a5aa6a75de62336b7a?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' />	</div><!-- #author-avatar -->
			<div class="author-description">
						A longtime video game fan starting from simple games on the Atari 2600 to newer titles on a bleeding edge PC I play everything I can get my hands on.		</div><!-- #author-description -->
			<div class="author-social flat-social">
						<a class="social-site" target="_blank" href="http://www.seriousgamer.ca/"><i class="fa fa-home"></i></a>
																													</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

		
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/pax-east-2020-baldurs-gate-3-gameplay-reveal/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2020/03/baldurs_gate_3-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/pax-east-2020-baldurs-gate-3-gameplay-reveal/" rel="bookmark">PAX East 2020 – Baldur’s Gate 3 Gameplay Reveal</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>1 day ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/dance-theater-review-nyc-seven-sins-company-xiv/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2020/03/Company-XIV-Seven-Sins-Mark-Shelby-Perry-3844-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Company XIV Seven Sins Mark Shelby Perry" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/dance-theater-review-nyc-seven-sins-company-xiv/" rel="bookmark">Dance-Theater Review (NYC): &#8216;Seven Sins&#8217; from Company XIV</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>2 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/pax-east-2020-day-1-experience/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2020/03/PAX-East-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/pax-east-2020-day-1-experience/" rel="bookmark">PAX East 2020 – Day 1 Experience</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>4 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<div class="post-thumbnail">
				<a href="https://blogcritics.org/videogame-review-corruption-2029/">
					<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2020/02/Corruption-Win64-Shipping-2020-02-17-20-50-33-086-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />					<span class="fa overlay-icon"></span>
				</a>
			</div><!-- post-thumbnail /-->
						
			<h2 class="post-title"><a href="https://blogcritics.org/videogame-review-corruption-2029/" rel="bookmark">Videogame Review: &#8216;Corruption 2029&#8217;</a></h2>
			<p>In this followup to Mutant Year Zero: Road to Eden, developer The Bearded Ladies delivers a solid action title with deep tactics but a shallow story.</p>
		</div>
			</section>
			
			
	
		
		
<div id="disqus_thread"></div>

	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="categort-posts-widget-2" class="widget categort-posts"><div class="widget-top"><h4>2019 Film Festivals		</h4><div class="stripe-line"></div></div>
						<div class="widget-container">				<ul>
							<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/lake-travis-film-festival-take-one/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2020/03/featured-110x75.png" class="attachment-tie-small size-tie-small wp-post-image" alt="featured" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/lake-travis-film-festival-take-one/">Lake Travis Film Festival: Take One</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>4 days ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/movie-music-reviews-bob-dylans-masked-and-anonymous/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2020/03/Masked-Anonymous-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/movie-music-reviews-bob-dylans-masked-and-anonymous/">Movie/Music Reviews: Bob Dylan&#8217;s &#8216;Masked and Anonymous&#8217; Arrives on Blu-ray, Plus Carla Olson</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>5 days ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/movie-review-a-quietly-affecting-carol-of-the-bells/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2020/02/CaroloftheBells_5.1-Mix_Official_90969-110x75.png" class="attachment-tie-small size-tie-small wp-post-image" alt="" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/movie-review-a-quietly-affecting-carol-of-the-bells/">Movie Review: A Quietly Affecting &#8216;Carol of the Bells&#8217;</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>1 week ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/call-of-the-wild/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2020/02/call3-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/call-of-the-wild/">Movie Review: ‘The Call of the Wild’ – Harrison Ford at His Best</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>2 weeks ago</span>		</li>
				<li >
							<div class="post-thumbnail">
					<a href="https://blogcritics.org/world-premieres-and-notable-speakers-highlight-sxsw-2020/" rel="bookmark"><img width="110" height="75" src="https://blogcritics.org/wp-content/uploads/2020/02/Witch_Hunt_ftr-110x75.jpg" class="attachment-tie-small size-tie-small wp-post-image" alt="" /><span class="fa overlay-icon"></span></a>
				</div><!-- post-thumbnail /-->
						<h3><a href="https://blogcritics.org/world-premieres-and-notable-speakers-highlight-sxsw-2020/">World Premieres and Notable Speakers Highlight SXSW 2020</a></h3>
			 <span class="tie-date"><i class="fa fa-clock-o"></i>3 weeks ago</span>		</li>
						</ul>
		<div class="clear"></div>
	</div></div><!-- .widget /-->		<div id="recent-posts-2" class="widget widget_recent_entries">		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<ul>
											<li>
					<a href="https://blogcritics.org/pax-east-2020-day-2-experience/" aria-current="page">PAX East 2020 – Day 2 Experience</a>
									</li>
											<li>
					<a href="https://blogcritics.org/pax-east-2020-baldurs-gate-3-gameplay-reveal/">PAX East 2020 – Baldur’s Gate 3 Gameplay Reveal</a>
									</li>
											<li>
					<a href="https://blogcritics.org/dance-theater-review-nyc-seven-sins-company-xiv/">Dance-Theater Review (NYC): &#8216;Seven Sins&#8217; from Company XIV</a>
									</li>
											<li>
					<a href="https://blogcritics.org/pax-east-2020-day-1-experience/">PAX East 2020 – Day 1 Experience</a>
									</li>
											<li>
					<a href="https://blogcritics.org/lake-travis-film-festival-take-one/">Lake Travis Film Festival: Take One</a>
									</li>
					</ul>
		</div></div><!-- .widget /--><div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-top"><h4>Recent Comments</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11925">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://toliveandwriteinla.com/' rel='external nofollow ugc' class='url'>Leo Sopicki</a></span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11924">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/film-review-linda-ronstadt-the-sound-of-my-voice-at-austin-film-society/#comment-11923">Film Review: ‘Linda Ronstadt: The Sound of My Voice’ at Austin Film Society</a></li><li class="recentcomments"><span class="comment-author-link">Victor Lana</span> on <a href="https://blogcritics.org/greta-thunberg-started-out-all-alone-but-shes-not-alone-anymore/#comment-11917">Greta the Great – Greta Thunberg Leads the Way on Climate Change</a></li><li class="recentcomments"><span class="comment-author-link">Dr Joseph S Maresca</span> on <a href="https://blogcritics.org/greta-thunberg-started-out-all-alone-but-shes-not-alone-anymore/#comment-11916">Greta the Great – Greta Thunberg Leads the Way on Climate Change</a></li></ul></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-2c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="facebook-widget-2" class="footer-widget facebook-widget"><div class="footer-widget-top"><h4>Find us on Facebook		</h4></div>
						<div class="footer-widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/pg/Blogcritics-132856246726018&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="latest_tweets_widget-2" class="footer-widget twitter-widget"><div class="footer-widget-top"><h4>			<a href="https://twitter.com/@Blogcritics">Follow Us</a>
		</h4></div>
						<div class="footer-widget-container">
<div class="twitter-widget-content" >
<ul class="twitter_update_list">
<li class="twitter-item">
	<i class="fa fa-twitter"></i>Concert Review: ASPECT Chamber Music Series – ‘French Impressions’ (Debussy, Chausson) with Gilles Vonsattel, Grace… <a href="https://t.co/vXElGD9CU0" class="twitter-link">https://t.co/vXElGD9CU0</a><small class="twitter-timestamp"><abbr title="2020/03/06 19:39:57">2020/03/06</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Movie/Music Reviews: Bob Dylan’s ‘Masked and Anonymous’ Arrives on Blu-ray, Plus Carla Olson
<a href="https://t.co/OKgr5TmIri" class="twitter-link">https://t.co/OKgr5TmIri</a> @bobdylan<small class="twitter-timestamp"><abbr title="2020/03/06 19:36:11">2020/03/06</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Jazz Reviews: Albare, ‘Albare Plays Jobim’ and John Di Martino, ‘Passion Flower: The Music of Billy Strayhorn’… <a href="https://t.co/m3OajCO0rH" class="twitter-link">https://t.co/m3OajCO0rH</a><small class="twitter-timestamp"><abbr title="2020/03/06 19:32:10">2020/03/06</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Dance-Theater Review (NYC): ‘Seven Sins’ from Company XIV: Another baroque burlesque extravaganza from @CompanyXIV… <a href="https://t.co/D28Vh0hoc8" class="twitter-link">https://t.co/D28Vh0hoc8</a><small class="twitter-timestamp"><abbr title="2020/03/06 19:27:17">2020/03/06</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Videogame Review: ‘Corruption 2029’  <a href="https://t.co/qJgrHztKXG" class="twitter-link">https://t.co/qJgrHztKXG</a> <a href="https://twitter.com/#search?q=Videogame" class="twitter-link">#Videogame</a> <a href="https://twitter.com/#search?q=videogames" class="twitter-link">#videogames</a> @TheBeardedLC<small class="twitter-timestamp"><abbr title="2020/02/27 03:29:00">2020/02/27</abbr></small></li>
</ul> </div>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="https://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>  | Web Admin <a href="/cdn-cgi/l/email-protection#92fffbf1faf3f7febcf1f3e0e0f3e1e3e7fbfefefdd2f0fefdf5f1e0fbe6fbf1e1bcfde0f5">Michael Carrasquillo</a>		</div>
				
		<div class="alignleft">
			© Copyright 2020, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div id="reading-position-indicator"></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blogcritics.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"blogcritics"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_count.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"5499372 https:\/\/blogcritics.org\/?p=5499372","disqusShortname":"blogcritics","disqusTitle":"PAX East 2020 \u2013 Day 2 Experience","disqusUrl":"https:\/\/blogcritics.org\/pax-east-2020-day-2-experience\/","postId":"5499372"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"","lightbox_gallery":"","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/search.js'></script>
</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Page Caching using disk: enhanced (Requested URI contains query) 

Served from: blogcritics.org @ 2020-03-08 19:04:37 by W3 Total Cache
-->