<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://blogcritics.org/xmlrpc.php" />
<title>Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’ | Blogcritics</title>
<meta property="og:title" content="Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’ - Blogcritics"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="In the spring of 2011, my wife and I were standing on a corner in New Orleans admiring some items in"/>
<meta property="og:url" content="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/"/>
<meta property="og:site_name" content="Blogcritics"/>
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg" />

<!-- This site is optimized with the Yoast SEO plugin v5.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In the spring of 2011,standing on a corner in New Orleans I heard a voice reminding me of Joni Mitchell. Christina Friis was supercharging the NOLA air."/>
<link rel="canonical" href="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’ | Blogcritics" />
<meta property="og:description" content="In the spring of 2011,standing on a corner in New Orleans I heard a voice reminding me of Joni Mitchell. Christina Friis was supercharging the NOLA air." />
<meta property="og:url" content="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/" />
<meta property="og:site_name" content="Blogcritics" />
<meta property="article:publisher" content="http://facebook.com/Blogcritics-132856246726018" />
<meta property="article:author" content="https://www.facebook.com/sopicki" />
<meta property="article:tag" content="Christina Friis" />
<meta property="article:tag" content="dirty dancing" />
<meta property="article:tag" content="joan baez" />
<meta property="article:tag" content="Joni Mitchell" />
<meta property="article:tag" content="Judy Collins" />
<meta property="article:tag" content="NOLA" />
<meta property="article:tag" content="Time of My Life" />
<meta property="article:section" content="Uncategorized" />
<meta property="article:published_time" content="2017-12-02T00:42:12-05:00" />
<meta property="fb:admins" content="132856246726018" />
<meta property="og:image" content="https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg" />
<meta property="og:image:secure_url" content="https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="270" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="In the spring of 2011,standing on a corner in New Orleans I heard a voice reminding me of Joni Mitchell. Christina Friis was supercharging the NOLA air." />
<meta name="twitter:title" content="Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’ | Blogcritics" />
<meta name="twitter:site" content="@blogcritics" />
<meta name="twitter:image" content="https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg" />
<meta name="twitter:creator" content="@LeoOfMars" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/blogcritics.org\/","name":"Blogcritics","potentialAction":{"@type":"SearchAction","target":"https:\/\/blogcritics.org\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/blogcritics.org\/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown\/","sameAs":["http:\/\/facebook.com\/Blogcritics-132856246726018","https:\/\/twitter.com\/blogcritics"],"@id":"#organization","name":"Blogcritics","logo":"http:\/\/blogcritics.org\/wp-content\/uploads\/2017\/09\/blogcritics-logo-wplogin320_65.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Feed" href="https://blogcritics.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Comments Feed" href="https://blogcritics.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’ Comments Feed" href="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blogcritics.org\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://blogcritics.org/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-slick-style-css'  href='https://blogcritics.org/wp-content/plugins/wp-trending-post-slider-and-widget/assets/css/slick.css' type='text/css' media='all' />
<link rel='stylesheet' id='wtpsw-public-style-css'  href='https://blogcritics.org/wp-content/plugins/wp-trending-post-slider-and-widget/assets/css/wtpsw-public.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='https://blogcritics.org/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://blogcritics.org/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tieViewsCacheL10n = {"admin_ajax_url":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","post_id":"5480365"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/postviews-cache.js'></script>
<link rel='https://api.w.org/' href='https://blogcritics.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blogcritics.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blogcritics.org/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://blogcritics.org/?p=5480365' />
<link rel="alternate" type="application/json+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fmusic-review-christina-friis-quiet-knowing-joni-mitchell-unknown%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blogcritics.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblogcritics.org%2Fmusic-review-christina-friis-quiet-knowing-joni-mitchell-unknown%2F&#038;format=xml" />
<meta name="framework" content="Alkivia Framework 0.8" />
<link rel="shortcut icon" href="http://blogcritics.org/wp-content/uploads/2017/09/favicon.ico" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://blogcritics.org/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://blogcritics.org/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="http://blogcritics.org/wp-content/uploads/2017/09/apple-touch-icon.png" />



<style type="text/css" media="screen">

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}

#main-nav,
.cat-box-content,
#sidebar .widget-container,
.post-listing,
#commentform {
	border-bottom-color: #7f0000;
}

.search-block .search-button,
#topcontrol,
#main-nav ul li.current-menu-item a,
#main-nav ul li.current-menu-item a:hover,
#main-nav ul li.current_page_parent a,
#main-nav ul li.current_page_parent a:hover,
#main-nav ul li.current-menu-parent a,
#main-nav ul li.current-menu-parent a:hover,
#main-nav ul li.current-page-ancestor a,
#main-nav ul li.current-page-ancestor a:hover,
.pagination span.current,
.share-post span.share-text,
.flex-control-paging li a.flex-active,
.ei-slider-thumbs li.ei-slider-element,
.review-percentage .review-item span span,
.review-final-score,
.button,
a.button,
a.more-link,
#main-content input[type="submit"],
.form-submit #submit,
#login-form .login-button,
.widget-feedburner .feedburner-subscribe,
input[type="submit"],
#buddypress button,
#buddypress a.button,
#buddypress input[type=submit],
#buddypress input[type=reset],
#buddypress ul.button-nav li a,
#buddypress div.generic-button a,
#buddypress .comment-reply-link,
#buddypress div.item-list-tabs ul li a span,
#buddypress div.item-list-tabs ul li.selected a,
#buddypress div.item-list-tabs ul li.current a,
#buddypress #members-directory-form div.item-list-tabs ul li.selected span,
#members-list-options a.selected,
#groups-list-options a.selected,
body.dark-skin #buddypress div.item-list-tabs ul li a span,
body.dark-skin #buddypress div.item-list-tabs ul li.selected a,
body.dark-skin #buddypress div.item-list-tabs ul li.current a,
body.dark-skin #members-list-options a.selected,
body.dark-skin #groups-list-options a.selected,
.search-block-large .search-button,
#featured-posts .flex-next:hover,
#featured-posts .flex-prev:hover,
a.tie-cart span.shooping-count,
.woocommerce span.onsale,
.woocommerce-page span.onsale ,
.woocommerce .widget_price_filter .ui-slider .ui-slider-handle,
.woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle,
#check-also-close,
a.post-slideshow-next,
a.post-slideshow-prev,
.widget_price_filter .ui-slider .ui-slider-handle,
.quantity .minus:hover,
.quantity .plus:hover,
.mejs-container .mejs-controls .mejs-time-rail .mejs-time-current,
#reading-position-indicator  {
	background-color:#7f0000;
}

::-webkit-scrollbar-thumb{
	background-color:#7f0000 !important;
}

#theme-footer,
#theme-header,
.top-nav ul li.current-menu-item:before,
#main-nav .menu-sub-content ,
#main-nav ul ul,
#check-also-box {
	border-top-color: #7f0000;
}

.search-block:after {
	border-right-color:#7f0000;
}

body.rtl .search-block:after {
	border-left-color:#7f0000;
}

#main-nav ul > li.menu-item-has-children:hover > a:after,
#main-nav ul > li.mega-menu:hover > a:after {
	border-color:transparent transparent #7f0000;
}

.widget.timeline-posts li a:hover,
.widget.timeline-posts li a:hover span.tie-date {
	color: #7f0000;
}

.widget.timeline-posts li a:hover span.tie-date:before {
	background: #7f0000;
	border-color: #7f0000;
}

#order_review,
#order_review_heading {
	border-color: #7f0000;
}


a {
	color: #7f0000;
}
		
a:hover {
	color: #806060;
}
		
.top-nav ul li a:hover, .top-nav ul li:hover > a, .top-nav ul :hover > a , .top-nav ul li.current-menu-item a {
	color: #7f0000;
}
		
</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/blogcritics.org\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/blogcritics.org\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
		<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><!-- BEGIN GADWP v5.1.2.2 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-1811558-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
</head>
<body id="top" class="post-template-default single single-post postid-5480365 single-format-standard lazy-enabled">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://blogcritics.org/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="boxed">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Saturday , December 2 2017</span>
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-5264769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264769"><a href="/contact/">Contact Us</a></li>
<li id="menu-item-5264771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264771"><a href="/write-for-blogcritics/">Writer Sign Up</a></li>
<li id="menu-item-5264773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264773"><a href="/about/">About</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://blogcritics.org/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="fa fa-twitter"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="Blogcritics" href="https://blogcritics.org/">
					<img src="http://blogcritics.org/wp-content/uploads/2017/10/blogcritics-logo190px.jpg" alt="Blogcritics"  /><strong>Blogcritics The critical lens on today&#039;s culture &amp; entertainment</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="e3lan e3lan-top">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=247310&width=728&height=90"></script> 				</div>			<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-5264473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264473"><a href="/">Home</a></li>
<li id="menu-item-5367196" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5367196"><a href="https://blogcritics.org/editor-picks/">Editor Picks</a></li>
<li id="menu-item-5264475" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264475"><a href="https://blogcritics.org/tv/">TV</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5265485" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265485"><a href="https://blogcritics.org/tv/tv-reviews-recaps/">Reviews &#038; Recaps</a></li>
	<li id="menu-item-5265515" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265515"><a href="https://blogcritics.org/tv/interviews-tv/">Interviews</a></li>
	<li id="menu-item-5274805" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5274805"><a href="https://blogcritics.org/film/columns-film/">Weekly TV Coverage</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5267599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267599"><a href="https://blogcritics.org/tv/tv-columns/gleekonomics/">Gleekonomics</a></li>
		<li id="menu-item-5267603" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267603"><a href="https://blogcritics.org/tv/tv-columns/jeroming-the-tv-landscape/">Jeroming the TV Landscape</a></li>
		<li id="menu-item-5340221" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5340221"><a href="https://blogcritics.org/tv/tv-columns/the-gallifreyian-groupie/">The Gallifreyan Groupie</a></li>
		<li id="menu-item-5267607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267607"><a href="https://blogcritics.org/tv/tv-columns/once-upon-a-time/">Once Upon a Time&#8230;There Was a Place Called Storybrooke</a></li>
		<li id="menu-item-5295573" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5295573"><a href="https://blogcritics.org/tv/tv-columns/lets-talk-tv-with-barbara-barnett/">Let&#8217;s Talk TV with Barbara Barnett</a></li>
		<li id="menu-item-5267597" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267597"><a href="https://blogcritics.org/tv/tv-columns/supernatural/">Supernatural Musings</a></li>
		<li id="menu-item-5267601" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267601"><a href="https://blogcritics.org/tv/tv-columns/idol-wired/">Idol Wired</a></li>
		<li id="menu-item-5267609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267609"><a href="https://blogcritics.org/tv/tv-columns/sci-fi-primetime/">Sci-Fi Primetime</a></li>
		<li id="menu-item-5267605" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5267605"><a href="https://blogcritics.org/tv/tv-columns/mad-men-confidential/">Mad Men Confidential</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-5264553" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264553"><a href="https://blogcritics.org/music/">Music</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264585" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-5264585"><a href="https://blogcritics.org/music/reviews-music/">Reviews music</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5277445" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5277445"><a href="https://blogcritics.org/music/reviews-music/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-5264589" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264589"><a href="https://blogcritics.org/music/reviews-music/concert-reviews/">Concert Reviews</a></li>
		<li id="menu-item-5277447" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-5277447"><a href="https://blogcritics.org/music/reviews-music/music-dvd-blu-ray-reviews/">Music DVD &#038; Blu-ray Reviews</a></li>
	</ul>
</li>
	<li id="menu-item-5264577" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264577"><a href="https://blogcritics.org/music/interviews-music/">Interviews music</a></li>
</ul>
</li>
<li id="menu-item-5264599" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264599"><a href="https://blogcritics.org/books/">Books</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264625" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264625"><a href="https://blogcritics.org/books/reviews-books/">Book Reviews</a></li>
	<li id="menu-item-5265519" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5265519"><a href="https://blogcritics.org/books/book-interviews/">Interviews</a></li>
</ul>
</li>
<li id="menu-item-5264731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264731"><a href="https://blogcritics.org/gaming/">Gaming</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264745"><a href="https://blogcritics.org/gaming/gaming-reviews/">Gaming Reviews</a></li>
	<li id="menu-item-5264743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264743"><a href="https://blogcritics.org/gaming/previews/">Previews</a></li>
	<li id="menu-item-5264741" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264741"><a href="https://blogcritics.org/gaming/conferences/">Conferences</a></li>
</ul>
</li>
<li id="menu-item-5264641" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264641"><a href="https://blogcritics.org/culture/">Culture and Society</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264647" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264647"><a href="https://blogcritics.org/culture/arts/">Arts</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5275059" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275059"><a href="https://blogcritics.org/culture/arts/cabaret/">Cabaret</a></li>
		<li id="menu-item-5275061" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275061"><a href="https://blogcritics.org/culture/arts/dance/">Dance</a></li>
		<li id="menu-item-5275063" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275063"><a href="https://blogcritics.org/culture/arts/opera-arts/">Opera</a></li>
		<li id="menu-item-5275067" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5275067"><a href="https://blogcritics.org/culture/arts/theater/">Theater</a></li>
	</ul>
</li>
	<li id="menu-item-5292699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5292699"><a href="https://blogcritics.org/culture/culture-columns/">Culture Columns</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-5292701" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292701"><a href="https://blogcritics.org/culture/culture-columns/ending-world-hunger/">Ending World Hunger</a></li>
		<li id="menu-item-5443149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5443149"><a href="https://blogcritics.org/culture/culture-columns/language-matters/">Language Matters</a></li>
		<li id="menu-item-5292703" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5292703"><a href="https://blogcritics.org/culture/culture-columns/hometown-heroes-culture-columns/">Hometown Heroes</a></li>
	</ul>
</li>
	<li id="menu-item-5264643" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264643"><a href="https://blogcritics.org/culture/politics/">Politics</a></li>
	<li id="menu-item-5264659" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264659"><a href="https://blogcritics.org/culture/travel/">Travel</a></li>
	<li id="menu-item-5264661" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264661"><a href="https://blogcritics.org/culture/scitech/">Science and Technology</a></li>
	<li id="menu-item-5264645" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264645"><a href="https://blogcritics.org/culture/sports/">Sports</a></li>
	<li id="menu-item-5264663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264663"><a href="https://blogcritics.org/culture/spirituality/">Spirituality</a></li>
	<li id="menu-item-5264657" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264657"><a href="https://blogcritics.org/culture/tips-and-advice/">Tips and Advice</a></li>
	<li id="menu-item-5439149" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5439149"><a href="https://blogcritics.org/culture/personalfinance/">Personal Finance</a></li>
	<li id="menu-item-5264655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264655"><a href="https://blogcritics.org/culture/health-and-fitness/">Health and Fitness</a></li>
	<li id="menu-item-5264653" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264653"><a href="https://blogcritics.org/culture/food-and-drink/">Food and Drink</a></li>
</ul>
</li>
<li id="menu-item-5264679" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5264679"><a href="https://blogcritics.org/film/">Film</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-5264711" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264711"><a href="https://blogcritics.org/film/reviews-film/">Reviews film</a></li>
	<li id="menu-item-5264685" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5264685"><a href="https://blogcritics.org/film/interviews-film/">Interviews film</a></li>
</ul>
</li>
<li id="menu-item-5406273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5406273"><a href="https://blogcritics.org/flash-fiction-2/">Flash Fiction</a></li>
</ul></div>					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container">

	
	
	
	
	
	<div class="content">

		
		<div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="https://blogcritics.org">Home</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://blogcritics.org/music/">Music</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://blogcritics.org/music/music-genres/">Music Genres</a></span> <span class="delimiter">/</span> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="https://blogcritics.org/music/music-genres/folk/">Folk</a></span> <span class="delimiter">/</span> <span class="current">Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’</span></div>
		

		
		<article class="post-listing post-5480365 post type-post status-publish format-standard has-post-thumbnail  category-folk category-music category-music-dvd-blu-ray-reviews category-music-genres category-reviews-music category-uncategorized tag-christina-friis tag-dirty-dancing tag-joan-baez tag-joni-mitchell tag-judy-collins tag-nola tag-time-of-my-life" id="the-post">
			
			<div class="single-post-thumb">
			<img width="600" height="270" src="https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg" class="attachment-slider size-slider wp-post-image" alt="Christina Friis" srcset="https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg 600w, https://blogcritics.org/wp-content/uploads/2017/12/Smile-300x135.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" />		</div>
	
		


			<div class="post-inner">

							<h1 class="name post-title entry-title"><span itemprop="name">Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’</span></h1>

						
<p class="post-meta">
		
	<span class="post-meta-author"><i class="fa fa-user"></i><a href="https://blogcritics.org/author/leoofmars/" title="">Leo Sopicki </a></span>
	
		
	<span class="tie-date"><i class="fa fa-clock-o"></i>7 hours ago</span>	
	
	<span class="post-comments"><i class="fa fa-comments"></i><a href="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/#respond"><span class="dsq-postid" data-dsqidentifier="5480365 https://blogcritics.org/?p=5480365">Leave a comment</span></a></span>
<span class="post-views"><i class="fa fa-eye"></i>17 Views</span> </p>
<div class="clear"></div>
			
				<div class="entry">
					<div class="share-post">
	<span class="share-text">Share</span>
	
		<script>
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 	'fbjssdk' );
		load('https://apis.google.com/js/plusone.js', 		'gplus1js');
		load('//platform.twitter.com/widgets.js', 			'tweetjs' );
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
	<ul class="normal-social">	
			<li>
			<div class="fb-like" data-href="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
		</li>
		
			<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/" data-text="Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’" data-via="" data-lang="en">tweet</a></li>
				<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/"></div></li>
				<li><su:badge layout="2" location="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/"></su:badge>
			<script type="text/javascript">
				(function() {
					var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true;
					li.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//platform.stumbleupon.com/1/widgets.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s);
				})();
			</script>
		</li>
				<li><script src="https://platform.linkedin.com/in.js" type="text/javascript"></script><script type="IN/Share" data-url="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/" data-counter="right"></script></li>
				<li style="width:80px;"><script type="text/javascript" src="https://assets.pinterest.com/js/pinit.js"></script><a href="http://pinterest.com/pin/create/button/?url=https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/&amp;media=https://blogcritics.org/wp-content/uploads/2017/12/Smile.jpg" class="pin-it-button" count-layout="horizontal"><img border="0" src="https://assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></li>
		</ul>
		<div class="clear"></div>
</div> <!-- .share-post -->
						<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/sacramentos-radio-94-7-electric-christmas-2017-concert-less-1-week-away/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2017/11/EC17_logo_995px-310x165.png" class="attachment-tie-medium size-tie-medium wp-post-image" alt="Electric Christmas 2017 poster" srcset="https://blogcritics.org/wp-content/uploads/2017/11/EC17_logo_995px-310x165.png 310w, https://blogcritics.org/wp-content/uploads/2017/11/EC17_logo_995px-995x525.png 995w" sizes="(max-width: 310px) 100vw, 310px" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/sacramentos-radio-94-7-electric-christmas-2017-concert-less-1-week-away/" rel="bookmark">Sacramento&#8217;s Radio 94.7 Electric Christmas 2017 Concert Less Than One Week Away</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>16 hours ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/music-review-grayson-capps-scarlett-roses/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2017/11/scarlett-roses-e1512045552865-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="scarlett roses" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/music-review-grayson-capps-scarlett-roses/" rel="bookmark">Music Review: Grayson Capps &#8211; &#8216;Scarlett Roses&#8217;</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>2 days ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="https://blogcritics.org/passage-russia-america-pianist-composer-transcriber-vyacheslav-gryaznov-delights-musical-storytelling/">
						<img width="310" height="165" src="https://blogcritics.org/wp-content/uploads/2017/11/Vyacheslav-Gryaznow-photo-Ilona-Oltuski-GetClassical.org_-310x165.jpg" class="attachment-tie-medium size-tie-medium wp-post-image" alt="" />						<span class="fa overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="https://blogcritics.org/passage-russia-america-pianist-composer-transcriber-vyacheslav-gryaznov-delights-musical-storytelling/" rel="bookmark">From Russia to America: Pianist, Composer, and Transcriber Vyacheslav Gryaznov Delights in Musical Storytelling</a></h3>
				<p class="post-meta"><span class="tie-date"><i class="fa fa-clock-o"></i>2 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
					<p>In the spring of 2011, my wife and I were standing on a corner in New Orleans admiring some items in a shop window. Then we heard a voice singing. Deep, rich sounds. Memories from my youth flashed through my brain – <a href="https://blogcritics.org/music-blu-ray-review-joni-mitchell-woman-of-heart-and-mind-painting-with-words-and-music/" target="_blank" rel="noopener">Joni Mitchell</a>, <a href="https://blogcritics.org/music-review-various-artists-woody-guthrie-at-100-live-at-the-kennedy-center-cddvd/" target="_blank" rel="noopener">Judy Collins</a>, <a href="https://blogcritics.org/joan-baez-honored-by-library-of-congress-and-amnesty-international/" target="_blank" rel="noopener">Joan Baez</a> – and I was sure this was a recording. Then we looked toward the source of the sound and saw Christina Friis strumming on her guitar and supercharging the New Orleans air. We forgot about what was in the window and headed over to hear her better.</p>
<figure id="attachment_5480371" style="max-width: 225px" class="wp-caption alignleft"><img class="size-medium wp-image-5480371" src="https://blogcritics.org/wp-content/uploads/2017/12/DSCN1855-e1512157679457-225x300.jpg" alt="Christina Friis" width="225" height="300" srcset="https://blogcritics.org/wp-content/uploads/2017/12/DSCN1855-e1512157679457-225x300.jpg 225w, https://blogcritics.org/wp-content/uploads/2017/12/DSCN1855-e1512157679457.jpg 300w" sizes="(max-width: 225px) 100vw, 225px" /><figcaption class="wp-caption-text">I first heard Christina in NOLA</figcaption></figure>
<p>A few weeks ago, an email showed up in my inbox from some singer. After a few email exchanges, we figured out that we had encountered each other on that New Orleans street corner six years ago, and, yes, I wanted to review her new album.</p>
<p>Danish-born Friis has been traveling back and forth between New Orleans and Denmark for the last few years, singing in churches and performing on street corners (known as busking). Now, back in recording mode, she released a new album in October and has a surprise for her fans coming later this year.</p>
<h4><strong>The New Album</strong></h4>
<p>Friis’ new album, <em>The Quiet of Knowing: Joni Mitchell Unknown</em>, a tribute album to the iconic folk-songstress of the 1960s, features unreleased songs written from 1965 to 1969. Dave Blackburn produced and arranged and plays guitar on all the songs. Barnaby Finch, who used to play for Lionel Richie, provides keyboard sounds.</p><div class='code-block code-block-1' style='margin: 8px 0; text-align: left; clear: both;'>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="8538825723"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

<p>When I put on the CD, I was taken back to that New Orleans street corner. Appropriate, I thought, because that’s how Mitchell got her start, busking in the streets of Toronto.</p>
<p>Friis grew up in a musical family and swears she could sing before she could talk. Experience as an exchange student introduced her to English, Spanish, and French. I wondered if she had always been a folk song fan or whether it was a more recent discovery.</p>
<p><img class="alignleft size-full wp-image-5480374" src="https://blogcritics.org/wp-content/uploads/2017/12/AlbumCover.jpg" alt="Christina Friis" width="400" height="400" srcset="https://blogcritics.org/wp-content/uploads/2017/12/AlbumCover.jpg 400w, https://blogcritics.org/wp-content/uploads/2017/12/AlbumCover-150x150.jpg 150w, https://blogcritics.org/wp-content/uploads/2017/12/AlbumCover-300x300.jpg 300w" sizes="(max-width: 400px) 100vw, 400px" />She explained, “I&#8217;ve always listened to and sung the songs of Joan Baez, my mom&#8217;s big idol. Folk music has always come naturally to me.”</p>
<p>I asked Friis about her favorite song on the album.</p>
<p>“My favorite track is ‘Hunter’,” she said. “I like the story of how the protagonist meets a stranger and wants to help, yet has reservations due to the ‘danger’ of not knowing where the stranger ‘has been’. The next day, there&#8217;s a feeling of remorse from not knowing whether the stranger was an angel or maybe a devil.</p>
<p>“I think the song speaks of a common dilemma, when approached by a homeless person or stranger. Too often we avoid even looking the person in the eye out of fear of the unknown and unfamiliar, yet we have no clue what kind of story the person actually carries with him or her. The song has food for thought.”</p>
<p>The final song on the album, “The Wizard of Is,” surprised me the most. Mitchell regularly performed it live, but I had never heard it. Almost instantly as it began, I recognized the sounds, the chords, and the tune as being adapted from Leonard Cohen’s “Suzanne.” A little digging revealed that Mitchell and Cohen had been lovers for a short time, and friends for life. The song is about him.</p>
<p>Whether you are a Joni Mitchell fan or not, I recommend that you check out the <a href="https://christinafriis.hearnow.com/" target="_blank" rel="noopener">album preview</a>. You may be a Friis fan and just not know it yet. You can also purchase the album through that site.</p>
<h4><strong>The Surprise</strong></h4>
<figure id="attachment_5480375" style="max-width: 400px" class="wp-caption alignright"><img class="size-full wp-image-5480375" src="https://blogcritics.org/wp-content/uploads/2017/12/Donny-and-me-e1491238337186.jpg" alt="Christina Friis" width="400" height="293" srcset="https://blogcritics.org/wp-content/uploads/2017/12/Donny-and-me-e1491238337186.jpg 400w, https://blogcritics.org/wp-content/uploads/2017/12/Donny-and-me-e1491238337186-300x220.jpg 300w" sizes="(max-width: 400px) 100vw, 400px" /><figcaption class="wp-caption-text">Christina Friis with Donny Markowitz</figcaption></figure>
<p>Soon, Friis plans on releasing an extended play with four original songs and her first music video. She has been working on this with Grammy award-winning producer Donny Markowitz, writer of the <em>Dirty Dancing</em> anthem “Time of My Life.”</p>
<p>Friis met Markowitz at songwriting sessions in New Orleans in the past, then contacted him a few months before her return to New Orleans last March to see if he would produce the record. She credits him with not only producing but with helping her improve the tunes and arrangements.</p>
<p>To stay up to date on Christina Friis’ new project, you can sign up for emails at her <a href="http://christinafriis.com/" target="_blank" rel="noopener">website</a> and <a href="https://twitter.com/FriisMusic" target="_blank" rel="noopener">follow her on Twitter</a>. The video linked below shows her busking “Hunter” in the French Quarter of New Orleans. The recorded music features Dave Blackburn on guitar and Barnaby Finch on keyboards.</p>
<p><iframe width="618" height="464" src="https://www.youtube.com/embed/nnKdxZ06wEM?feature=oembed" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe></p>
<p>&nbsp;</p>
					
									</div><!-- .entry /-->


								<div class="clear"></div>
			</div><!-- .post-inner -->

			<script type="application/ld+json">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</script>
		</article><!-- .post-listing -->
		<p class="post-tag">Tags <a href="https://blogcritics.org/tag/christina-friis/" rel="tag">Christina Friis</a> <a href="https://blogcritics.org/tag/dirty-dancing/" rel="tag">dirty dancing</a> <a href="https://blogcritics.org/tag/joan-baez/" rel="tag">joan baez</a> <a href="https://blogcritics.org/tag/joni-mitchell/" rel="tag">Joni Mitchell</a> <a href="https://blogcritics.org/tag/judy-collins/" rel="tag">Judy Collins</a> <a href="https://blogcritics.org/tag/nola/" rel="tag">NOLA</a> <a href="https://blogcritics.org/tag/time-of-my-life/" rel="tag">Time of My Life</a></p>

		<div class="e3lan e3lan-post">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=247310&width=728&height=90"></script> 				</div>
				<section id="author-box">
			<div class="block-head">
				<h3>About Leo Sopicki </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
				<div class="author-bio">
	<div class="author-avatar">
		<img alt='' src='https://secure.gravatar.com/avatar/2d81910522fd5ea8b4d9e9b4ed3697b3?s=90&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/2d81910522fd5ea8b4d9e9b4ed3697b3?s=180&#038;d=mm&#038;r=g 2x' class='avatar avatar-90 photo' height='90' width='90' />	</div><!-- #author-avatar -->
			<div class="author-description">
						<p>Writer, photographer, graphic artist and technologist.  I  focus my creative efforts on celebrating the American virtues of self-reliance, individual initiative, volunteerism, tolerance and a healthy suspicion of power and authority.</p>
		</div><!-- #author-description -->
			<div class="author-social flat-social">
						<a class="social-site" target="_blank" href="http://www.leosopicki.com"><i class="fa fa-home"></i></a>
									<a class="social-facebook" target="_blank" href="https://www.facebook.com/sopicki"><i class="fa fa-facebook"></i></a>
									<a class="social-twitter" target="_blank" href="http://twitter.com/@LeoOfMars"><i class="fa fa-twitter"></i><span> @@LeoOfMars</span></a>
									<a class="social-google-plus" target="_blank" href="https://plus.google.com/+LeoSopicki/posts"><i class="fa fa-google-plus"></i></a>
									<a class="social-linkedin" target="_blank" href="https://www.linkedin.com/in/sopicki"><i class="fa fa-linkedin"></i></a>
												<a class="social-youtube" target="_blank" href="https://www.youtube.com/channel/UCeRYdvmiAnjSjff0xbJV4Kw"><i class="fa fa-youtube"></i></a>
									<a class="social-pinterest" target="_blank" href="https://www.pinterest.com/leosopicki/"><i class="fa fa-pinterest"></i></a>
									<a class="social-behance" target="_blank" href="https://www.behance.net/LeoSopicki"><i class="fa fa-behance"></i></a>
								</div>
		<div class="clear"></div>
</div>
				</div>
		</section><!-- #author-box -->
		

		
		
			
	<section id="check-also-box" class="post-listing check-also-right">
		<a href="#" id="check-also-close"><i class="fa fa-close"></i></a>

		<div class="block-head">
			<h3>Check Also</h3>
		</div>

				<div class="check-also-post">
						
			<h2 class="post-title"><a href="https://blogcritics.org/music-review-sherri-roberts-anybodys-spring/" rel="bookmark">Music Review: Sherri Roberts &#8211; &#8216;Anybody&#8217;s Spring&#8217;</a></h2>
			<p>Traces of cabaret and swing music can be found in the smooth texture of her register and the enchanting way she sings a lyric, emphasizing the underlying emotions and creating an intimate atmosphere. </p>
		</div>
			</section>
			
			
	
		
		
<div id="disqus_thread">
    </div>


	</div><!-- .content -->
<aside id="sidebar">
	<div class="theiaStickySidebar">
<div id="ads300_250-widget-2" class="widget e3lan e3lan300_250-widget"><div class="widget-top"><h4> Advertisement</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div  class="e3lan-widget-content e3lan300-250">
								<div class="e3lan-cell">
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Sidebar Widget Top -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-3219627867632523"
     data-ad-slot="9541788348"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
			</div>
				</div>
	</div></div><!-- .widget /--><div id="wtpsw-post-list-widget-2" class="widget wtpsw_post_list_widget"><h3 class="widget-title">Trending</h3>

<div class="wtpsw-post-items">
    <ul>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/aboard-holiday-train-show-new-york-botanical-garden/" title="All Aboard for the Holiday Train Show at the New York Botanical Garden">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2017/11/IMG_0782-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="NYBG, Holiday Train Show" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/aboard-holiday-train-show-new-york-botanical-garden/" title="All Aboard for the Holiday Train Show at the New York Botanical Garden">All Aboard for the Holiday Train Show at the New York Botanical Garden</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        This year at the NYBG's annual spectacular show, the entire presentation reflects the notions of...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/universal-studios-home-entertainment-holiday-gift-guide-2017/" title="Universal Studios Home Entertainment Holiday Gift Guide, 2017">
                                        </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/universal-studios-home-entertainment-holiday-gift-guide-2017/" title="Universal Studios Home Entertainment Holiday Gift Guide, 2017">Universal Studios Home Entertainment Holiday Gift Guide, 2017</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        From Dr. Seuss to Alfred Hitchcock, Universal is determined to make sure this is one...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/fiction-watch-2018/" title="Fiction To Watch For In 2018">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2017/11/paperpeople4-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/fiction-watch-2018/" title="Fiction To Watch For In 2018">Fiction To Watch For In 2018</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        Is there any good fiction coming out in 2018, you ask? Here's ten books likely...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/theater-review-nyc-deal-zhu-yi-urban-stages/" title="Theater Review (NYC): &#8216;A Deal&#8217; by Zhu Yi at Urban Stages">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2017/11/IMG_0920-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="Helen Coxe, Seth Moore, Wei-Yi Lin, Urban Stages, Zhu Yi, A Deal, John Giampietro" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/theater-review-nyc-deal-zhu-yi-urban-stages/" title="Theater Review (NYC): &#8216;A Deal&#8217; by Zhu Yi at Urban Stages">Theater Review (NYC): &#8216;A Deal&#8217; by Zhu Yi at Urban Stages</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        The social and cultural divide inherent between Chinese values and politics and American values and...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
            <li class="wtpsw-post-li">

                                <div class="wtpsw-post-thumb-left">
                    <a href="https://blogcritics.org/book-review-tips-living-murder-mystery-renee-shafransky/" title="Book Review: &#8216;Tips for Living,&#8217; A Murder Mystery by Renee Shafransky">
                    <img width="100" height="100" src="https://blogcritics.org/wp-content/uploads/2017/11/35433671-150x150.jpg" class="attachment-100x100 size-100x100 wp-post-image" alt="" />                    </a>
                </div><!-- end .wtpsw-post-thumb-left -->
                
                <div class="wtpsw-post-thumb-right">
                   <h6> <a class="wtpsw-post-title" href="https://blogcritics.org/book-review-tips-living-murder-mystery-renee-shafransky/" title="Book Review: &#8216;Tips for Living,&#8217; A Murder Mystery by Renee Shafransky">Book Review: &#8216;Tips for Living,&#8217; A Murder Mystery by Renee Shafransky</a></h6>
                    
                    
                    <div class="wtpsw-post-stats">

                        
                        
                        
                    </div><!-- end .wtpsw-post-stats -->

                                        <div class="wtpsw-post-cnt">
                        In 'Tips for Living,' by Renee Shafransky, Nora's life again begins to swirl downward in...                    </div>
                                    </div><!-- end .wtpsw-post-thumb-right -->
                
            </li>

        
    </ul>
</div><!-- end .wtpsw-post-items --></div></div><!-- .widget /--><div id="text-2" class="widget widget_text"><div class="widget-top"><h4>Stock Market Overview</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><p><script>
   if (typeof(stockdio_events) == "undefined") {
      stockdio_events = true;
      var stockdio_eventMethod = window.addEventListener ? "addEventListener" : "attachEvent";
      var stockdio_eventer = window[stockdio_eventMethod];
      var stockdio_messageEvent = stockdio_eventMethod == "attachEvent" ? "onmessage" : "message";
      stockdio_eventer(stockdio_messageEvent, function (e) {
         if (typeof(e.data) != "undefined" && typeof(e.data.method) != "undefined") {
            eval(e.data.method);
         }
      },false);
   }
</script><br />
<iframe id='st_9803fe1c7c3546e68a48aac271cfa985' frameBorder='0' scrolling='no' width='400' height='100%' src='https://api.stockdio.com/visualization/financial/charts/v1/MarketOverviewChart?app-key=7DD47C26FAAB4B808DD70D7C7861102A&#038;includeEquities=false&#038;includeCurrencies=false&#038;palette=Financial-Light&#038;title=Market%20Overview&#038;onload=st_9803fe1c7c3546e68a48aac271cfa985'></iframe></p>
</div>
		</div></div><!-- .widget /-->		<div id="recent-posts-2" class="widget widget_recent_entries">		<div class="widget-top"><h4>Recent Posts</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<ul>
											<li>
					<a href="https://blogcritics.org/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown/">Music Review: Christina Friis – ‘The Quiet of Knowing: Joni Mitchell Unknown’</a>
									</li>
											<li>
					<a href="https://blogcritics.org/sacramentos-radio-94-7-electric-christmas-2017-concert-less-1-week-away/">Sacramento&#8217;s Radio 94.7 Electric Christmas 2017 Concert Less Than One Week Away</a>
									</li>
											<li>
					<a href="https://blogcritics.org/top-ten-book-covers-2017/">Top Ten Book Covers of 2017</a>
									</li>
											<li>
					<a href="https://blogcritics.org/music-review-grayson-capps-scarlett-roses/">Music Review: Grayson Capps &#8211; &#8216;Scarlett Roses&#8217;</a>
									</li>
											<li>
					<a href="https://blogcritics.org/prison-time-barrier-employment-success-despite-prison-education-programs/">Prison Time a Barrier to College Education and Employment Despite Prison Education Programs</a>
									</li>
					</ul>
		</div></div><!-- .widget /--><div id="tie_weatherwidget-2" class="widget widget_tie_weatherwidget"><div class="widget-top"><h4>Weather</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><!-- TIE WEATHER ERROR: city not found --></div></div><!-- .widget /--><div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-top"><h4>Recent Comments</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://autisticagainstantivaxxers.wordpress.com/2017/04/07/submissions/' rel='external nofollow' class='url'>Containing =/= Is.</a></span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11815">Los Angelos Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://disqus.com/home/discussion/channel-sci/lets_debate_everything_science/' rel='external nofollow' class='url'>Kianna Prodzinski</a></span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11814">Los Angelos Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://autisticagainstantivaxxers.wordpress.com/2017/04/07/submissions/' rel='external nofollow' class='url'>Containing =/= Is.</a></span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11813">Los Angelos Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link">Stacey</span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11812">Los Angelos Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li><li class="recentcomments"><span class="comment-author-link">Brian</span> on <a href="https://blogcritics.org/los-angelos-film-festival-review-pathological-optimist-miranda-bailey/#comment-11811">Los Angelos Film Festival Review: &#8216;The Pathological Optimist&#8217; by Miranda Bailey</a></li></ul></div></div><!-- .widget /-->	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->
<div class="e3lan e3lan-bottom">			<script src="//ap.lijit.com/www/delivery/fpi.js?z=323844&width=728&height=90"></script> 				</div>
<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-2c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="facebook-widget-2" class="footer-widget facebook-widget"><div class="footer-widget-top"><h4>Find us on Facebook		</h4></div>
						<div class="footer-widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/pg/Blogcritics-132856246726018&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="latest_tweets_widget-2" class="footer-widget twitter-widget"><div class="footer-widget-top"><h4>			<a href="http://twitter.com/@Blogcritics">Follow Us</a>
		</h4></div>
						<div class="footer-widget-container">
<div class="twitter-widget-content" >
<ul class="twitter_update_list">
<li class="twitter-item">
	<i class="fa fa-twitter"></i>The latest Blogcritics Highlights Daily! <a href="https://t.co/D6zozEVeKd" class="twitter-link">https://t.co/D6zozEVeKd</a> <a href="http://twitter.com/#search?q=theater" class="twitter-link">#theater</a> #prison<small class="twitter-timestamp"><abbr title="2017/12/01 05:15:46">2017/12/01</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Theater Review (NYC): ‘Washed Up on the Potomac’ by Lynn Rosen <a href="https://t.co/oPyoOJEyhs" class="twitter-link">https://t.co/oPyoOJEyhs</a> <a href="http://twitter.com/Pool_Plays" class="twitter-user">@Pool_Plays</a> This smart, hila… <a href="https://t.co/ViydIPk4rk" class="twitter-link">https://t.co/ViydIPk4rk</a><small class="twitter-timestamp"><abbr title="2017/11/30 17:26:12">2017/11/30</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Theatre Review (Singapore): ‘Forever Young’ by Sing’Theatre <a href="https://t.co/EuE47VSLO0" class="twitter-link">https://t.co/EuE47VSLO0</a> <a href="http://twitter.com/singtheatre" class="twitter-user">@singtheatre</a> <a href="http://twitter.com/#search?q=theatre" class="twitter-link">#theatre</a> <a href="http://twitter.com/#search?q=Singapore" class="twitter-link">#Singapore</a> <a href="https://t.co/t6YfVUq6IN" class="twitter-link">https://t.co/t6YfVUq6IN</a><small class="twitter-timestamp"><abbr title="2017/11/30 17:23:30">2017/11/30</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Music Review: Bill Toms &amp; Hard Rain – ‘Good for My Soul’ rattles and glides like the great horn-driven soul music o… <a href="https://t.co/ixa0KxkwOc" class="twitter-link">https://t.co/ixa0KxkwOc</a><small class="twitter-timestamp"><abbr title="2017/11/30 17:20:55">2017/11/30</abbr></small></li>

<li class="twitter-item">
	<i class="fa fa-twitter"></i>Holiday Live Theater Offerings in San Antonio <a href="https://t.co/QNGnXK6IT4" class="twitter-link">https://t.co/QNGnXK6IT4</a> <a href="http://twitter.com/TheMagikTheatre" class="twitter-user">@TheMagikTheatre</a> <a href="http://twitter.com/PlayhouseSA" class="twitter-user">@PlayhouseSA</a> @roxietheatre… <a href="https://t.co/IsTO1e22wI" class="twitter-link">https://t.co/IsTO1e22wI</a><small class="twitter-timestamp"><abbr title="2017/11/30 17:15:30">2017/11/30</abbr></small></li>
</ul> </div>
		</div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://wordpress.org">WordPress</a> | Designed by <a href="http://tielabs.com/">TieLabs</a>  | Web Admin <a href="mailto:michael@michaelcarrasquillo.com">Michael Carrasquillo</a>		</div>
				
		<div class="alignleft">
			© Copyright 2017, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
<div id="reading-position-indicator"></div><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blogcritics.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"true","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"","is_singular":"1","SmothScroll":"true","reading_indicator":"true","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/themes/sahifa/js/search.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.9.1","language":""},"disqusIdentifier":"5480365 https:\/\/blogcritics.org\/?p=5480365","disqusShortname":"blogcritics","disqusTitle":"Music Review: Christina Friis \u2013 \u2018The Quiet of Knowing: Joni Mitchell Unknown\u2019","disqusUrl":"https:\/\/blogcritics.org\/music-review-christina-friis-quiet-knowing-joni-mitchell-unknown\/","options":{"manualSync":"1"},"postId":"5480365"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/media/js/disqus.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"blogcritics"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blogcritics.org/wp-content/plugins/disqus-comment-system/media/js/count.js'></script>
</body>
</html>