<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head >
<meta charset="UTF-8" />
<title>Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016) | Blogcritics</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://blogcritics.org/xmlrpc.php" />
<meta property="og:title" content="Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)"/>
<meta property="og:type" content="article"/>
<meta property="og:description" content="Next week, SnowGlobe Music Festival is once again there to host your pre-New Year's Eve celebrations..."/>
<meta property="og:url" content="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/"/>
<meta property="og:site_name" content="Blogcritics"/>
<meta property="og:image" content="http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?resize=624%2C330" />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//ws.sharethis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Feed" href="http://blogcritics.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Comments Feed" href="http://blogcritics.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blogcritics &raquo; Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016) Comments Feed" href="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/blogcritics.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.6.1"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='http://blogcritics.org/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='ssbaFont-css'  href='//fonts.googleapis.com/css?family=Indie+Flower&#038;ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='tie-style-css'  href='http://blogcritics.org/wp-content/themes/sahifa/style.css?ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='http://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700&#038;ver=4.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='amazon-link-style-css'  href='http://blogcritics.org/wp-content/plugins/amazon-link/Amazon.css?ver=3.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://blogcritics.org/wp-content/plugins/jetpack/css/jetpack.css?ver=4.3.2' type='text/css' media='all' />
<!-- This site uses the Google Analytics by MonsterInsights plugin v5.5.4 - Universal enabled - https://www.monsterinsights.com/ -->
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

	__gaTracker('create', 'UA-1811558-1', 'auto');
	__gaTracker('set', 'forceSSL', true);
	__gaTracker('require', 'displayfeatures');
	__gaTracker('send','pageview');

</script>
<!-- / Google Analytics by MonsterInsights -->
<script type='text/javascript' src='http://blogcritics.org/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://ws.sharethis.com/button/st_insights.js?publisher=4d48b7c5-0ae3-43d4-bfbe-3ff8c17a8ae6&#038;product=simpleshare' id='st_insights_js'></script id='st_insights_js'>
<link rel='https://api.w.org/' href='http://blogcritics.org/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://blogcritics.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://blogcritics.org/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Staying Informed in Trump-Traumatized America&#8211;A Guide for 2017' href='http://blogcritics.org/staying-informed-in-trump-traumatized-america-a-guide-for-2017/' />
<meta name="generator" content="WordPress 4.6.1" />
<link rel="canonical" href="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" />
<link rel='shortlink' href='http://wp.me/p3YzbJ-mWcL' />
<link rel="alternate" type="application/json+oembed" href="http://blogcritics.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogcritics.org%2Fpreview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://blogcritics.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fblogcritics.org%2Fpreview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016%2F&#038;format=xml" />
<meta name="framework" content="Alkivia Framework 0.8" />
<script>(function(d, s, id){
                 var js, fjs = d.getElementsByTagName(s)[0];
                 if (d.getElementById(id)) {return;}
                 js = d.createElement(s); js.id = id;
                 js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
                 fjs.parentNode.insertBefore(js, fjs);
               }(document, 'script', 'facebook-jssdk'));</script><style type="text/css">	.ssba {
									
									
									
									-moz-border-radius: 10px; -webkit-border-radius: 10px; -khtml-border-radius: 10px;  border-radius: 10px; -o-border-radius: 10px;
								}
								.ssba img
								{
									width: 35px !important;
									padding: 6px;
									border:  0;
									box-shadow: none !important;
									display: inline !important;
									vertical-align: middle;
								}
								.ssba, .ssba a
								{
									text-decoration:none;
									border:0;
									background: none;
									font-family: Indie Flower;
									font-size: 	20px;
									
									
								}
								.ssba_sharecount:after, .ssba_sharecount:before {
									right: 100%;
									border: solid transparent;
									content: " ";
									height: 0;
									width: 0;
									position: absolute;
									pointer-events: none;
								}
								.ssba_sharecount:after {
									border-color: rgba(224, 221, 221, 0);
									border-right-color: #f5f5f5;
									border-width: 5px;
									top: 50%;
									margin-top: -5px;
								}
								.ssba_sharecount:before {
									border-color: rgba(85, 94, 88, 0);
									border-right-color: #e0dddd;
									border-width: 6px;
									top: 50%;
									margin-top: -6px;
								}
								.ssba_sharecount {
									font: 11px Arial, Helvetica, sans-serif;

									padding: 5px;
									-khtml-border-radius: 6px;
									-o-border-radius: 6px;
									-webkit-border-radius: 6px;
									-moz-border-radius: 6px;
									border-radius: 6px;
									position: relative;
									border: 1px solid #e0dddd;color: #555e58;
										background: #f5f5f5;
									}
									.ssba_sharecount:after {
										border-right-color: #f5f5f5;
									}</style>
<!-- Twitter Cards Meta By WPDeveloper.net -->
<meta name="twitter:card" content="summary" />
<meta name="twitter:site" content="@Blogcritics" />
<meta name="twitter:creator" content="@Blogcritics" />
<meta name="twitter:url" content="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" />
<meta name="twitter:title" content="Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)" />
<meta name="twitter:description" content="On December 29-31, 2016, The Chainsmokers, Flume, Major Lazer, and Odesza headline SnowGlobe Music Festival in South Lake Tahoe." />
<meta name="twitter:image" content="http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?fit=624%2C960" />
<!-- Twitter Cards Meta By WPDeveloper.net -->


<link rel='dns-prefetch' href='//widgets.wp.com'>
<link rel='dns-prefetch' href='//s0.wp.com'>
<link rel='dns-prefetch' href='//0.gravatar.com'>
<link rel='dns-prefetch' href='//1.gravatar.com'>
<link rel='dns-prefetch' href='//2.gravatar.com'>
<link rel='dns-prefetch' href='//i0.wp.com'>
<link rel='dns-prefetch' href='//i1.wp.com'>
<link rel='dns-prefetch' href='//i2.wp.com'>
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="http://blogcritics.org/wp-content/uploads/bcimages/2016/03/favicon.ico" title="Favicon" />	
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->	
<!--[if lt IE 9]>
<script src="http://blogcritics.org/wp-content/themes/sahifa/js/html5.js"></script>
<script src="http://blogcritics.org/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="http://blogcritics.org/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="http://blogcritics.org/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="http://blogcritics.org/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->
<script type='text/javascript'>
	/* <![CDATA[ */
	var tievar = {'go_to' : 'Go to...'};
	var tie = {"ajaxurl":"http://blogcritics.org/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};
	/* ]]> */
</script>
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no" />

<style type="text/css" media="screen"> 
::-webkit-scrollbar {width: 8px; height:8px; }
	#main-nav,.cat-box-content,#sidebar .widget-container,.post-listing {border-bottom-color: #ef3636;}
	.search-block .search-button,
	#topcontrol,
	#main-nav ul li.current-menu-item a,
	#main-nav ul li.current-menu-item a:hover,
	#main-nav ul li.current-menu-parent a,
	#main-nav ul li.current-menu-parent a:hover,
	#main-nav ul li.current-page-ancestor a,
	#main-nav ul li.current-page-ancestor a:hover,
	.pagination span.current,
	.share-post span.share-text,
	.flex-control-paging li a.flex-active,
	.ei-slider-thumbs li.ei-slider-element,
	.review-percentage .review-item span span,.review-final-score ,
	.woocommerce span.onsale, .woocommerce-page span.onsale ,
	.woocommerce .widget_price_filter .ui-slider .ui-slider-handle, .woocommerce-page .widget_price_filter .ui-slider .ui-slider-handle  {
		background-color:#ef3636 !important;
	}
	::-webkit-scrollbar-thumb{background-color:#ef3636 !important;}
	footer#theme-footer, .top-nav, .top-nav ul li.current-menu-item:after,#main-nav ul li.mega-menu .mega-menu-block, #main-nav ul ul {border-top-color: #ef3636;}
	.search-block:after {border-right-color:#ef3636;}
	#main-nav ul > li.parent-list:hover > a:after{border-color:transparent transparent #ef3636;}

body {
 background-image : url(http://blogcritics.org/wp-content/themes/sahifa/images/patterns/body-bg3.png);background-position: top center;
}
	a {
	color: #3642ad;	text-decoration: underline;}

</style> 

</head>
<body id="top" class="single single-post postid-5466959 single-format-standard">
	<div class="background-cover"></div>
			<header id="theme-header" class="theme-header">
						<div class="top-nav">
								
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-5264769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264769"><a href="/contact/">Contact Us</a></li>
<li id="menu-item-5264771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264771"><a href="/write-for-blogcritics/">Writer Sign Up</a></li>
<li id="menu-item-5264773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5264773"><a href="/about/">About</a></li>
</ul></div>
			<div class="social-icons icon_16">
		<a class="tooldown" title="Rss" href="http://blogcritics.org/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="tooldown" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/?ref=hl" target="_blank"><i class="tieicon-facebook"></i></a><a class="tooldown" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="tieicon-twitter"></i></a>	</div>

		
	
			</div><!-- .top-menu /-->
			
		<div class="header-content">
			<div class="logo" style="margin-top:15px">
			<h2>								<a title="Blogcritics" href="http://blogcritics.org/">
					<img src="http://blogcritics.org/wp-content/uploads/bcimages/2016/02/bc-banner-1-1024x147.jpg" alt="Blogcritics" /><strong>Blogcritics The critical lens on today&#039;s culture &amp; entertainment</strong>
				</a>
			</h2>			</div><!-- .logo /-->
			<div class="ads-top">					<script type="text/javascript" src="http://ap.lijit.com/www/delivery/fpi.js?z=342583&u=Blogcritics&width=970&height=90"></script>				</div>			<div class="clear"></div>
		</div>	
													<nav id="main-nav">
				<div class="container">
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-5264473" class="menu-item  menu-item-type-custom  menu-item-object-custom"><a href="/">Home</a></li>
<li id="menu-item-5264475" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/tv/">TV</a>
<ul class="sub-menu">
	<li id="menu-item-5265485" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-reviews-recaps/">Reviews &#038; Recaps</a></li>
	<li id="menu-item-5265515" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/interviews-tv/">Interviews</a></li>
	<li id="menu-item-5274805" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/film/columns-film/">Weekly TV Coverage</a>
	<ul class="sub-menu">
		<li id="menu-item-5267599" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/gleekonomics/">Gleekonomics</a></li>
		<li id="menu-item-5267603" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/jeroming-the-tv-landscape/">Jeroming the TV Landscape</a></li>
		<li id="menu-item-5340221" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/the-gallifreyian-groupie/">The Gallifreyan Groupie</a></li>
		<li id="menu-item-5267607" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/once-upon-a-time/">Once Upon a Time&#8230;There Was a Place Called Storybrooke</a></li>
		<li id="menu-item-5295573" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/lets-talk-tv-with-barbara-barnett/">Let&#8217;s Talk TV with Barbara Barnett</a></li>
		<li id="menu-item-5267597" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/supernatural/">Supernatural Musings</a></li>
		<li id="menu-item-5267601" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/idol-wired/">Idol Wired</a></li>
		<li id="menu-item-5267609" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/sci-fi-primetime/">Sci-Fi Primetime</a></li>
		<li id="menu-item-5267605" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/tv/tv-columns/mad-men-confidential/">Mad Men Confidential</a></li>
	</ul> <!--End Sub Menu-->
</li>
</ul> <!--End Sub Menu-->
</li>
<li id="menu-item-5264553" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  current-post-ancestor  current-menu-parent  current-post-parent  menu-item-has-children"><a href="http://blogcritics.org/category/music/">Music</a>
<ul class="sub-menu">
	<li id="menu-item-5264585" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/music/reviews-music/">Reviews music</a>
	<ul class="sub-menu">
		<li id="menu-item-5277445" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/music/reviews-music/album-reviews/">Album Reviews</a></li>
		<li id="menu-item-5264589" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/music/reviews-music/concert-reviews/">Concert Reviews</a></li>
		<li id="menu-item-5277447" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/music/reviews-music/music-dvd-blu-ray-reviews/">Music DVD &#038; Blu-ray Reviews</a></li>
	</ul> <!--End Sub Menu-->
</li>
	<li id="menu-item-5264577" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/music/interviews-music/">Interviews music</a></li>
</ul> <!--End Sub Menu-->
</li>
<li id="menu-item-5264599" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/books/">Books</a>
<ul class="sub-menu">
	<li id="menu-item-5264625" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/books/reviews-books/">Book Reviews</a></li>
	<li id="menu-item-5265519" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/books/book-interviews/">Interviews</a></li>
</ul> <!--End Sub Menu-->
</li>
<li id="menu-item-5264731" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/gaming/">Gaming</a>
<ul class="sub-menu">
	<li id="menu-item-5264745" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/gaming/gaming-reviews/">Gaming Reviews</a></li>
	<li id="menu-item-5264743" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/gaming/previews/">Previews</a></li>
	<li id="menu-item-5264741" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/gaming/conferences/">Conferences</a></li>
</ul> <!--End Sub Menu-->
</li>
<li id="menu-item-5264641" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/culture/">Culture and Society</a>
<ul class="sub-menu">
	<li id="menu-item-5264647" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/culture/arts/">Arts</a>
	<ul class="sub-menu">
		<li id="menu-item-5275059" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/arts/cabaret/">Cabaret</a></li>
		<li id="menu-item-5275061" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/arts/dance/">Dance</a></li>
		<li id="menu-item-5275063" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/arts/opera-arts/">Opera</a></li>
		<li id="menu-item-5275067" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/arts/theater/">Theater</a></li>
	</ul> <!--End Sub Menu-->
</li>
	<li id="menu-item-5292699" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/culture/culture-columns/">Culture Columns</a>
	<ul class="sub-menu">
		<li id="menu-item-5292701" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/culture-columns/ending-world-hunger/">Ending World Hunger</a></li>
		<li id="menu-item-5443149" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/culture-columns/language-matters/">Language Matters</a></li>
		<li id="menu-item-5292703" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/culture-columns/hometown-heroes-culture-columns/">Hometown Heroes</a></li>
	</ul> <!--End Sub Menu-->
</li>
	<li id="menu-item-5264643" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/politics/">Politics</a></li>
	<li id="menu-item-5264659" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/travel/">Travel</a></li>
	<li id="menu-item-5264661" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/scitech/">Science and Technology</a></li>
	<li id="menu-item-5264645" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/sports/">Sports</a></li>
	<li id="menu-item-5264663" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/spirituality/">Spirituality</a></li>
	<li id="menu-item-5264657" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/tips-and-advice/">Tips and Advice</a></li>
	<li id="menu-item-5439149" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/personalfinance/">Personal Finance</a></li>
	<li id="menu-item-5264655" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/health-and-fitness/">Health and Fitness</a></li>
	<li id="menu-item-5264653" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/culture/food-and-drink/">Food and Drink</a></li>
</ul> <!--End Sub Menu-->
</li>
<li id="menu-item-5264679" class="menu-item  menu-item-type-taxonomy  menu-item-object-category  menu-item-has-children"><a href="http://blogcritics.org/category/film/">Film</a>
<ul class="sub-menu">
	<li id="menu-item-5264711" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/film/reviews-film/">Reviews film</a></li>
	<li id="menu-item-5264685" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/film/interviews-film/">Interviews film</a></li>
</ul> <!--End Sub Menu-->
</li>
<li id="menu-item-5367196" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/editor-picks/">Editor Picks</a></li>
<li id="menu-item-5406273" class="menu-item  menu-item-type-taxonomy  menu-item-object-category"><a href="http://blogcritics.org/category/flash-fiction-2/">Flash Fiction</a></li>
</ul></div>										<a href="http://blogcritics.org/?tierand=1" class="random-article tieicon-shuffle ttip" title="Random Article"></a>
									</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->
	
		
	<div id="main-content" class="container">
	<div class="content">
		<div xmlns:v="http://rdf.data-vocabulary.org/#"  id="crumbs"><span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" class="crumbs-home" href="http://blogcritics.org">Home</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://blogcritics.org/category/music/">Music</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://blogcritics.org/category/music/music-genres/">Music Genres</a></span> / <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://blogcritics.org/category/music/music-genres/dance-music/">Dance Music</a></span> / <span class="current">Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)</span></div>		
	
		
				
				
						
		<article class="post-listing post-5466959 post type-post status-publish format-standard has-post-thumbnail hentry category-dance-music category-music category-music-genres category-news-music tag-105995 tag-big-gigantic tag-chet-porter tag-classixx tag-concert tag-flume tag-major-lazer tag-marian-hill tag-music-festival tag-odesza tag-rl-grime tag-rufus-du-sol tag-snails tag-snowglobe tag-snowglobe-music-festival tag-sofi-tukker tag-the-chainsmokers tag-the-knocks">
			
			<div class="post-inner">
				<h1 class="name post-title entry-title" itemprop="itemReviewed" itemscope itemtype="http://schema.org/Thing"><span itemprop="name">Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)</span></h1>

						
<p class="post-meta">
		
	<span>Posted by: <a href="http://blogcritics.org/author/itrek4ever02/" title="">Tan The Man </a></span>
	
		
	<span>1 hour ago</span>	
	<span>in <a href="http://blogcritics.org/category/music/music-genres/dance-music/" rel="category tag">Dance Music</a>, <a href="http://blogcritics.org/category/music/" rel="category tag">Music</a>, <a href="http://blogcritics.org/category/music/music-genres/" rel="category tag">Music Genres</a>, <a href="http://blogcritics.org/category/music/news-music/" rel="category tag">Music News</a></span>
	
	<span><a href="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/#respond"><span class="dsq-postid" data-dsqidentifier="5466959 http://blogcritics.org/?p=5466959">Leave a comment</span></a></span>
</p>
<div class="clear"></div>

				<div class="entry">
										
					<!-- Google Ads Injected by Adsense Explosion 1.1.5 --><div class="adsxpls" id="adsxpls1" style="padding:7px; float: left; padding-left: 0px; margin: 0px;"><!-- AdSense Plugin Explosion num: 1 --><script type="text/javascript"><!--

google_ad_client = "pub-3219627867632523"; google_alternate_color = "FFFFFF";
google_ad_width = 468; google_ad_height = 60; google_ad_format = "468x60_as";
google_ad_type = "text_image";
google_ad_channel =""; google_color_border = "336699";
google_color_link = "0000FF"; google_color_bg = "FFFFFF";
google_color_text = "000000"; google_color_url = "008000";
google_ui_features = "rc:0"; //--></script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div><!-- google_ad_section_start --><!-- Simple Share Buttons Adder (6.3.2) simplesharebuttons.com --><div class="ssba ssba-wrap"><div style="text-align:left">Please Share...<a data-site="print" class="ssba_print ssba_share_link" href="#" onclick="window.print()"><img src="http://i0.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/print.png?w=618" title="Print" class="ssba ssba-img" alt="Print this page" data-recalc-dims="1" /></a><a href="http://twitter.com/share?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;text=Preview%3A+SnowGlobe+Music+Festival+2016+in+South+Lake+Tahoe%2C+California+%28Dec.+29-31%2C+2016%29+" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://twitter.com/share?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;text=Preview%3A+SnowGlobe+Music+Festival+2016+in+South+Lake+Tahoe%2C+California+%28Dec.+29-31%2C+2016%29+', '');" data-site="" class="ssba_twitter_share"   target="_blank"><img src="http://i2.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/twitter.png?w=618" title="Twitter" class="ssba ssba-img" alt="Tweet about this on Twitter" data-recalc-dims="1" /></a><a href="http://www.facebook.com/sharer.php?u=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.facebook.com/sharer.php?u=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/', '');" data-site="" class="ssba_facebook_share"   target="_blank"><img src="http://i0.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/facebook.png?w=618" title="Facebook" class="ssba ssba-img" alt="Share on Facebook" data-recalc-dims="1" /></a><span class="ssba_sharecount">0</span><a href="https://plus.google.com/share?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://plus.google.com/share?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/', '');" data-site="" class="ssba_google_share"   target="_blank"><img src="http://i1.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/google.png?w=618" title="Google+" class="ssba ssba-img" alt="Share on Google+" data-recalc-dims="1" /></a><span class="ssba_sharecount">0</span><a href="http://pinterest.com/pin/create/bookmarklet/?is_video=false&url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&media=http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?fit=624%2C960&description=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://pinterest.com/pin/create/bookmarklet/?is_video=false&amp;url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;media=http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?fit=624%2C960&amp;description=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)', '');" data-site="pinterest-featured"  class="ssba_pinterest_share ssba_share_link"  target="_blank"><img src="http://i0.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/pinterest.png?w=618" title="Pinterest" class="ssba ssba-img" alt="Pin on Pinterest" data-recalc-dims="1" /></a><span class="ssba_sharecount">0</span><a href="http://www.tumblr.com/share/link?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.tumblr.com/share/link?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/', '');" data-site="tumblr" class="ssba_tumblr_share"   target="_blank"><img src="http://i1.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/tumblr.png?w=618" title="tumblr" class="ssba ssba-img" alt="Share on Tumblr" data-recalc-dims="1" /></a><span class="ssba_sharecount">0</span><a href="http://www.stumbleupon.com/submit?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;title=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.stumbleupon.com/submit?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;title=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)', '');" data-site="stumbleupon" class="ssba_stumbleupon_share ssba_share_link"   target="_blank"><img src="http://i0.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/stumbleupon.png?w=618" title="StumbleUpon" class="ssba ssba-img" alt="Share on StumbleUpon" data-recalc-dims="1" /></a><span class="ssba_sharecount">0</span><a href="http://reddit.com/submit?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;title=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://reddit.com/submit?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;title=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)', '');" data-site="reddit" class="ssba_reddit_share"   target="_blank"><img src="http://i2.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/reddit.png?w=618" title="Reddit" class="ssba ssba-img" alt="Share on Reddit" data-recalc-dims="1" /></a><span class="ssba_sharecount">0</span><a data-site="email" class="ssba_email_share" href="mailto:?subject=Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)&amp;body=%20http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/"><img src="http://i0.wp.com/blogcritics.org/wp-content/plugins/simple-share-buttons-adder/buttons/pagepeel/email.png?w=618" title="Email" class="ssba ssba-img" alt="Email this to someone" data-recalc-dims="1" /></a></div></div><p><img class="alignright wp-image-5466960" src="http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?resize=250%2C385" alt="SnowGlobe Music Festival 2016 Poster" srcset="http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?resize=195%2C300 195w, http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?resize=624%2C960 624w" sizes="(max-width: 250px) 100vw, 250px" data-recalc-dims="1" />Next week, <a href="http://snowglobemusicfestival.com" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://snowglobemusicfestival.com', 'SnowGlobe Music Festival');">SnowGlobe Music Festival</a> is once again there to host your pre-New Year&#8217;s Eve celebrations with live electronic dance music. This event takes place on December 29-31, 2016 in snowy South Lake Tahoe, California. In other words, it is the seasonal opposite of Coachella.</p>
<p>This year, SnowGlobe takes over a larger portion of the <a href="http://www.ltcc.edu/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://www.ltcc.edu/', 'Lake Tahoe Community College');">Lake Tahoe Community College</a> campus that is twice the size of the main field that hosted the festival in previous years. The result should allow for bigger tents with more room to dance both inside and out.</p>
<p>Last year&#8217;s sold-out SnowGlobe featured Kaskade, Dillon Francis, Chet Faker, and Run the Jewels. This year&#8217;s event builds upon that awesome line-up with headliners <a href="http://thechainsmokers.com/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://thechainsmokers.com/', 'The Chainsmokers');">The Chainsmokers</a>, <a href="http://flumemusic.com/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://flumemusic.com/', 'Flume');">Flume</a>, <a href="http://majorlazer.com/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://majorlazer.com/', 'Major Lazer');">Major Lazer</a>, and <a href="http://odesza.com/" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://odesza.com/', 'Odesza');">Odesza</a>.</p><!-- Google Ads Injected by Adsense Explosion 1.1.5 --><div class="adsxpls" id="adsxpls2" style="padding:7px; float: left; padding-left: 0px; margin: 0px;"><!-- AdSense Plugin Explosion num: 2 --><script type="text/javascript"><!--

google_ad_client = "pub-3219627867632523"; google_alternate_color = "FFFFFF";
google_ad_width = 250; google_ad_height = 250; google_ad_format = "250x250_as";
google_ad_type = "text_image";
google_ad_channel =""; google_color_border = "E3FA11";
google_color_link = "FFFFFF"; google_color_bg = "A2AB2B";
google_color_text = "000000"; google_color_url = "FFFFFF";
google_ui_features = "rc:0"; //--></script>
<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script></div>
<p>Each act has infectious hit songs still dominating the radio airwaves such as Major Lazer&#8217;s <a href="https://www.youtube.com/watch?v=a59gmGkq_pw" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.youtube.com/watch?v=a59gmGkq_pw', '&#8220;Cold Water&#8221;');">&#8220;Cold Water&#8221;</a> and The Chainsmokers&#8217; <a href="https://www.youtube.com/watch?v=Io0fBr1XBUA" onclick="__gaTracker('send', 'event', 'outbound-article', 'https://www.youtube.com/watch?v=Io0fBr1XBUA', '&#8220;Don&#8217;t Let Me Down&#8221;');">&#8220;Don&#8217;t Let Me Down&#8221;</a> that are currently charting on Billboard&#8217;s Top 100.</p>
<p>Other notable acts include:</p>
<ul>
<li>Classixx</li>
<li>The Knocks</li>
<li>Marian Hill</li>
<li>RL Grime</li>
<li>RÜFÜS DU SOL</li>
<li>Snails</li>
<li>Sofi Tukker</li>
</ul>
<p>SnowGlobe is an all-ages event; however, the anticipated crowd will be overwhelmingly youthful given the scheduled music acts. As with similar festivals, expect art, food, and lots of selfies.</p>
<p>All three-day passes are sold out. As of this writing, only a few day passes remain for Friday night (12/30) in order to catch Major Lazer, Big Gigantic, and Chet Porter.</p>
<div id="sidelines_discussion"></div>
<noscript>Please enable JavaScript to view the <a href="http://sidelinesapp.com/?ref_noscript" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://sidelinesapp.com/?ref_noscript', 'discussion by Sidelines.');">discussion by Sidelines.</a></noscript>
<a href="http://sidelinesapp.com" onclick="__gaTracker('send', 'event', 'outbound-article', 'http://sidelinesapp.com', 'Powered by Sidelines');" class="sidelines-widget-link">Powered by <span class="sidelines-logo">Sidelines</span></a>
<div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-58763955-5466959-585cc22ea48bd' data-src='//widgets.wp.com/likes/#blog_id=58763955&amp;post_id=5466959&amp;origin=blogcritics.org&amp;obj_id=58763955-5466959-585cc22ea48bd' data-name='like-post-frame-58763955-5466959-585cc22ea48bd'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div><div class='code-block code-block-1' style='margin: 8px 0px;'><script type="text/javascript">
amzn_assoc_placement = "adunit0";
amzn_assoc_enable_interest_ads = "true";
amzn_assoc_tracking_id = "blogcrmagazi-20";
amzn_assoc_ad_mode = "auto";
amzn_assoc_ad_type = "smart";
amzn_assoc_marketplace = "amazon";
amzn_assoc_region = "US";
amzn_assoc_textlinks = "";
amzn_assoc_linkid = "552fd2a0092cd0f418bf679ebb6cfe09";
amzn_assoc_emphasize_categories = "16261631,1000,13900861,2335752011,13900871,130,172282,5088769011,979455011,195209011,51575011,229534,468642";
amzn_assoc_fallback_mode = {"type":"search","value":"books"};
amzn_assoc_default_category = "All";
</script>
<script src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US"></script>
</div><!-- google_ad_section_end -->										
					
									</div><!-- .entry /-->
				<span style="display:none"><a href="http://blogcritics.org/tag/2016/" rel="tag">2016</a> <a href="http://blogcritics.org/tag/big-gigantic/" rel="tag">Big Gigantic</a> <a href="http://blogcritics.org/tag/chet-porter/" rel="tag">Chet Porter</a> <a href="http://blogcritics.org/tag/classixx/" rel="tag">Classixx</a> <a href="http://blogcritics.org/tag/concert/" rel="tag">concert</a> <a href="http://blogcritics.org/tag/flume/" rel="tag">Flume</a> <a href="http://blogcritics.org/tag/major-lazer/" rel="tag">Major Lazer</a> <a href="http://blogcritics.org/tag/marian-hill/" rel="tag">Marian Hill</a> <a href="http://blogcritics.org/tag/music-festival/" rel="tag">music festival</a> <a href="http://blogcritics.org/tag/odesza/" rel="tag">Odesza</a> <a href="http://blogcritics.org/tag/rl-grime/" rel="tag">RL Grime</a> <a href="http://blogcritics.org/tag/rufus-du-sol/" rel="tag">Rufus Du Sol</a> <a href="http://blogcritics.org/tag/snails/" rel="tag">Snails</a> <a href="http://blogcritics.org/tag/snowglobe/" rel="tag">SnowGlobe</a> <a href="http://blogcritics.org/tag/snowglobe-music-festival/" rel="tag">SnowGlobe Music Festival</a> <a href="http://blogcritics.org/tag/sofi-tukker/" rel="tag">Sofi Tukker</a> <a href="http://blogcritics.org/tag/the-chainsmokers/" rel="tag">The Chainsmokers</a> <a href="http://blogcritics.org/tag/the-knocks/" rel="tag">The Knocks</a></span>				<span style="display:none" class="updated">2016-12-22</span>
								<div style="display:none" class="vcard author" itemprop="author" itemscope itemtype="http://schema.org/Person"><strong class="fn" itemprop="name"><a href="http://blogcritics.org/author/itrek4ever02/" title="Posts by Tan The Man" rel="author">Tan The Man</a></strong></div>
								
				<div class="share-post">
	<span class="share-text">Share !</span>
	<script>
	window.___gcfg = {lang: 'en-US'};
	(function(w, d, s) {
	  function go(){
		var js, fjs = d.getElementsByTagName(s)[0], load = function(url, id) {
		  if (d.getElementById(id)) {return;}
		  js = d.createElement(s); js.src = url; js.id = id;
		  fjs.parentNode.insertBefore(js, fjs);
		};
		load('//connect.facebook.net/en/all.js#xfbml=1', 'fbjssdk');
		load('https://apis.google.com/js/plusone.js', 'gplus1js');
		load('//platform.twitter.com/widgets.js', 'tweetjs');
	  }
	  if (w.addEventListener) { w.addEventListener("load", go, false); }
	  else if (w.attachEvent) { w.attachEvent("onload",go); }
	}(window, document, 'script'));
	</script>
	<ul>			
			<li><a href="https://twitter.com/share" class="twitter-share-button" data-url="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" data-text="Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)" data-via="@blogcritics" data-lang="en">tweet</a></li>
				<li>
			<div id="fb-root"></div>
			<div class="fb-like" data-href="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
		</li>
				<li style="width:80px;"><div class="g-plusone" data-size="medium" data-href="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/"></div>
		</li>
				<li><su:badge layout="2" location="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/"></su:badge>
			<script type="text/javascript">
				(function() {
					var li = document.createElement('script'); li.type = 'text/javascript'; li.async = true;
					li.src = ('https:' == document.location.protocol ? 'https:' : 'http:') + '//platform.stumbleupon.com/1/widgets.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(li, s);
				})();
			</script>
		</li>
				<li><script src="http://platform.linkedin.com/in.js" type="text/javascript"></script><script type="IN/Share" data-url="http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/" data-counter="right"></script></li>
				<li style="width:80px;"><script type="text/javascript" src="http://assets.pinterest.com/js/pinit.js"></script><a href="http://pinterest.com/pin/create/button/?url=http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/&amp;media=http://i0.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/SMF2016-624x960.jpg?resize=624%2C330" class="pin-it-button" count-layout="horizontal"><img border="0" src="http://assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></li>
		</ul>
	<div class="clear"></div>
</div> <!-- .share-post -->
			</div><!-- .post-inner -->


<!-- START GOOGLE ADSENSE FOR WRITERS -->
<div align="center">
				

        	<div class="article-adsense">
                <script type="text/javascript"><!--
					google_ad_client = "pub-1312223205865376";
					google_ad_type = "text";
					google_ad_width = 468;
					google_ad_height = 60;
					google_ad_format = "468x60_as";
					google_color_border = "FFFFFF";
					google_color_bg = "FFFFFF";
					google_color_link = "555555";
					google_color_url = "555555";
					google_color_text = "555555";
					google_alternate_color = "FFFFFF";
				//--></script>
				<script type="text/javascript" src="http://pagead2.googlesyndication.com/pagead/show_ads.js"></script>            
			</div>
</div>
<!-- END GOOGLE ADSENSE FOR WRITERS -->

		</article><!-- .post-listing -->
		<p class="post-tag">Tagged with: <a href="http://blogcritics.org/tag/2016/" rel="tag">2016</a> <a href="http://blogcritics.org/tag/big-gigantic/" rel="tag">Big Gigantic</a> <a href="http://blogcritics.org/tag/chet-porter/" rel="tag">Chet Porter</a> <a href="http://blogcritics.org/tag/classixx/" rel="tag">Classixx</a> <a href="http://blogcritics.org/tag/concert/" rel="tag">concert</a> <a href="http://blogcritics.org/tag/flume/" rel="tag">Flume</a> <a href="http://blogcritics.org/tag/major-lazer/" rel="tag">Major Lazer</a> <a href="http://blogcritics.org/tag/marian-hill/" rel="tag">Marian Hill</a> <a href="http://blogcritics.org/tag/music-festival/" rel="tag">music festival</a> <a href="http://blogcritics.org/tag/odesza/" rel="tag">Odesza</a> <a href="http://blogcritics.org/tag/rl-grime/" rel="tag">RL Grime</a> <a href="http://blogcritics.org/tag/rufus-du-sol/" rel="tag">Rufus Du Sol</a> <a href="http://blogcritics.org/tag/snails/" rel="tag">Snails</a> <a href="http://blogcritics.org/tag/snowglobe/" rel="tag">SnowGlobe</a> <a href="http://blogcritics.org/tag/snowglobe-music-festival/" rel="tag">SnowGlobe Music Festival</a> <a href="http://blogcritics.org/tag/sofi-tukker/" rel="tag">Sofi Tukker</a> <a href="http://blogcritics.org/tag/the-chainsmokers/" rel="tag">The Chainsmokers</a> <a href="http://blogcritics.org/tag/the-knocks/" rel="tag">The Knocks</a></p>
		
				
				
		<section id="author-box">
			<div class="block-head">
				<h3>About Tan The Man </h3><div class="stripe-line"></div>
			</div>
			<div class="post-listing">
					<div class="author-avatar">
		<img alt='' src='http://2.gravatar.com/avatar/ed876c5849a6db2799bbb7bfb10a2d4f?s=60&#038;d=mm&#038;r=g' srcset='http://2.gravatar.com/avatar/ed876c5849a6db2799bbb7bfb10a2d4f?s=120&amp;d=mm&amp;r=g 2x' class='avatar avatar-60 photo' height='60' width='60' />	</div><!-- #author-avatar -->
			<div class="author-description">
			Tan The Man writes mostly about film and music. He has previously covered events like Noise Pop, Outside Lands Music and Arts Festival, South By Southwest, TBD Festival, Wizard World Comic Con and WonderCon.		</div><!-- #author-description -->
		
		<div class="author-social">
						<a class="ttip" href="http://www.dorksandlosers.com" title="Tan The Man 's site"><img src="http://blogcritics.org/wp-content/themes/sahifa/images/author_site.png" width="18" height="18" alt="" /></a>
				
						<a class="ttip" href="http://twitter.com/dorksandlosers" title="Tan The Man  on Twitter"><img src="http://blogcritics.org/wp-content/themes/sahifa/images/author_twitter.png" width="18" height="18" alt="" /></a>
				
							
							
						<a class="ttip" href="https://www.flickr.com/photos/dorksandlosers" title="Tan The Man  on Flickr"><img src="http://blogcritics.org/wp-content/themes/sahifa/images/author_flickr.png" width="18" height="18" alt="" /></a>
				
						<a class="ttip" href="https://www.youtube.com/c/dorksandlosersdnl" title="Tan The Man  on YouTube"><img src="http://blogcritics.org/wp-content/themes/sahifa/images/author_youtube.png" width="18" height="18" alt="" /></a>
															<a class="ttip" href="https://www.instagram.com/realtantheman" title="Tan The Man  on Instagram"><img src="http://blogcritics.org/wp-content/themes/sahifa/images/author_instagram.png" width="18" height="18" alt="" /></a>
				
		</div>
		<div class="clear"></div>
				</div>
		</section><!-- #author-box -->
				
		
						
		<div class="post-navigation">
			<div class="post-previous"><a href="http://blogcritics.org/staying-informed-in-trump-traumatized-america-a-guide-for-2017/" rel="prev"><span>Previous:</span> Staying Informed in Trump-Traumatized America&#8211;A Guide for 2017</a></div>
			<div class="post-next"></div>
		</div><!-- .post-navigation -->
			
			<section id="related_posts">
		<div class="block-head">
			<h3>Related Articles</h3><div class="stripe-line"></div>
		</div>
		<div class="post-listing">
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://blogcritics.org/music-review-dropkick-murphys-11-short-stories-of-pain-glory/" title="Permalink to Music Review: Dropkick Murphys – &#8217;11 Short Stories of Pain &#038; Glory&#8217;" rel="bookmark">
						<img width="272" height="125" src="http://i2.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/dropkick-murphys-album.jpg?resize=272%2C125" class="attachment-tie-medium size-tie-medium" alt="Music Review: Dropkick Murphys – &#8217;11 Short Stories of Pain &#038; Glory&#8217;" title="Music Review: Dropkick Murphys – &#8217;11 Short Stories of Pain &#038; Glory&#8217;" srcset="http://i2.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/dropkick-murphys-album.jpg?resize=272%2C125 272w, http://i2.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/dropkick-murphys-album.jpg?zoom=2&amp;resize=272%2C125 544w" sizes="(max-width: 272px) 100vw, 272px" />						<span class="overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://blogcritics.org/music-review-dropkick-murphys-11-short-stories-of-pain-glory/" title="Permalink to Music Review: Dropkick Murphys – &#8217;11 Short Stories of Pain &#038; Glory&#8217;" rel="bookmark">Music Review: Dropkick Murphys – &#8217;11 Short Stories of Pain &#038; Glory&#8217;</a></h3>
				<p class="post-meta"><span>13 hours ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://blogcritics.org/music-review-jethro-tull-stand-up-the-elevated-edition/" title="Permalink to Music Review: Jethro Tull – &#8216;Stand Up: The Elevated Edition&#8217;" rel="bookmark">
						<img width="272" height="125" src="http://i1.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/jethro-tull-stand-up.jpg?resize=272%2C125" class="attachment-tie-medium size-tie-medium" alt="Music Review: Jethro Tull – &#8216;Stand Up: The Elevated Edition&#8217;" title="Music Review: Jethro Tull – &#8216;Stand Up: The Elevated Edition&#8217;" srcset="http://i1.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/jethro-tull-stand-up.jpg?resize=272%2C125 272w, http://i1.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/jethro-tull-stand-up.jpg?zoom=2&amp;resize=272%2C125 544w" sizes="(max-width: 272px) 100vw, 272px" />						<span class="overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://blogcritics.org/music-review-jethro-tull-stand-up-the-elevated-edition/" title="Permalink to Music Review: Jethro Tull – &#8216;Stand Up: The Elevated Edition&#8217;" rel="bookmark">Music Review: Jethro Tull – &#8216;Stand Up: The Elevated Edition&#8217;</a></h3>
				<p class="post-meta"><span>1 day ago</span></p>
			</div>
						<div class="related-item">
							
				<div class="post-thumbnail">
					<a href="http://blogcritics.org/music-blu-ray-review-heart-live-at-the-royal-albert-hall-with-the-royal-philharmonic-orchestra/" title="Permalink to Music Blu-ray Review: Heart &#8211; &#8216;Live at the Royal Albert Hall with The Royal Philharmonic Orchestra&#8217;" rel="bookmark">
						<img width="272" height="125" src="http://i1.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/heart1.jpg?resize=272%2C125" class="attachment-tie-medium size-tie-medium" alt="Music Blu-ray Review: Heart &#8211; &#8216;Live at the Royal Albert Hall with The Royal Philharmonic Orchestra&#8217;" title="Music Blu-ray Review: Heart &#8211; &#8216;Live at the Royal Albert Hall with The Royal Philharmonic Orchestra&#8217;" srcset="http://i1.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/heart1.jpg?resize=272%2C125 272w, http://i1.wp.com/blogcritics.org/wp-content/uploads/bcimages/2016/12/heart1.jpg?zoom=2&amp;resize=272%2C125 544w" sizes="(max-width: 272px) 100vw, 272px" />						<span class="overlay-icon"></span>
					</a>
				</div><!-- post-thumbnail /-->
							
				<h3><a href="http://blogcritics.org/music-blu-ray-review-heart-live-at-the-royal-albert-hall-with-the-royal-philharmonic-orchestra/" title="Permalink to Music Blu-ray Review: Heart &#8211; &#8216;Live at the Royal Albert Hall with The Royal Philharmonic Orchestra&#8217;" rel="bookmark">Music Blu-ray Review: Heart &#8211; &#8216;Live at the Royal Albert Hall with The Royal Philharmonic Orchestra&#8217;</a></h3>
				<p class="post-meta"><span>2 days ago</span></p>
			</div>
						<div class="clear"></div>
		</div>
	</section>
	
		
		
<div id="disqus_thread">
    </div>

<script type="text/javascript">
var disqus_url = 'http://blogcritics.org/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016/';
var disqus_identifier = '5466959 http://blogcritics.org/?p=5466959';
var disqus_container_id = 'disqus_thread';
var disqus_shortname = 'blogcritics';
var disqus_title = "Preview: SnowGlobe Music Festival 2016 in South Lake Tahoe, California (Dec. 29-31, 2016)";
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    
    
    this.language = '';
        this.callbacks.onReady.push(function () {

        // sync comments in the background so we don't block the page
        var script = document.createElement('script');
        script.async = true;
        script.src = '?cf_action=sync_comments&post_id=5466959';

        var firstScript = document.getElementsByTagName('script')[0];
        firstScript.parentNode.insertBefore(script, firstScript);
    });
    
    if (disqus_config_custom) {
        disqus_config_custom.call(this);
    }
};

(function() {
    var dsq = document.createElement('script'); dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = '//' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();
</script>

	
	</div><!-- .content -->
<aside id="sidebar">
			<div id="text-html-widget-13" class="text-html-box" >
			<script type="text/javascript" src="http://ap.lijit.com/www/delivery/fpi.js?z=323842&u=Blogcritics&width=300&height=250"></script>			</div>
					<div id="text-html-widget-3" class="text-html-box" style="text-align:center;">
			<script type="text/javascript" src="http://ap.lijit.com/www/delivery/fpi.js?z=247311&u=Blogcritics&width=300&height=250"></script>			</div>
					<div id="text-html-widget-6" class="text-html-box" >
			<div id="text-12" class="widget widget_text"><div class="widget-top"><h4>Search</h4><div class="stripe-line"></div></div>			</div>
			<div class="search-widget">
		<form method="get" id="searchform" action="http://blogcritics.org/">
			<input type="text" id="s" name="s" value="to search type and hit enter" onfocus="if (this.value == 'to search type and hit enter') {this.value = '';}" onblur="if (this.value == '') {this.value = 'to search type and hit enter';}"  />
		</form>
	</div><!-- .search-widget /-->		
<div id="social-2" class="widget social-icons-widget"><div class="widget-top"><h4>Social</h4><div class="stripe-line"></div></div>
						<div class="widget-container">		<div class="social-icons icon_24">
		<a class="ttip" title="Rss" href="http://blogcritics.org/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/?ref=hl" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="tieicon-twitter"></i></a>	</div>

</div></div><!-- .widget /-->			<div id="text-html-widget-4" class="text-html-box" style="text-align:center;">
			<script type="text/javascript" src="http://ap.lijit.com/www/delivery/fpi.js?z=323841&u=Blogcritics&width=300&height=250"></script>			</div>
		<div id="text-html-widget-9" class="widget text-html"><div class="widget-top"><h4>Mailing List</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><div ><a href="http://blogcritics.org/sign-our-mailing-list/" target="_blank">Sign up for our newsletter</a>
				</div><div class="clear"></div></div></div><!-- .widget /-->			<div id="text-html-widget-7" class="text-html-box" >
			<?php get_sse(); ?>			</div>
					<div id="text-html-widget-11" class="text-html-box" style="text-align:center;">
			<iframe src="//z-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetAdHtml&ID=OneJS&OneJS=1&banner_type=setandforget&campaigns=holsetforget2016&placement=assoc_banner_placement_default&region=US&marketplace=amazon&ad_type=banner&height=250&width=300&f=ifr&linkID=0e57dfdeef578c381179113c5ee9ee24&t=blogcrmagazi-20&tracking_id=blogcrmagazi-20" width="300" height="250" scrolling="no" border="0" marginwidth="0" style="border:none;" frameborder="0"></iframe>			</div>
					<div id="text-html-widget-12" class="text-html-box" >
			<div class="alignleft">
     <script type="text/javascript">
       	amzn_assoc_ad_type = "banner";
	amzn_assoc_marketplace = "amazon";
	amzn_assoc_region = "US";
	amzn_assoc_placement = "assoc_banner_placement_default";
	amzn_assoc_campaigns = "books";
	amzn_assoc_banner_type = "category";
	amzn_assoc_isresponsive = "true";
	amzn_assoc_banner_id = "1WV938XZP3V21MG4E2R2";
	amzn_assoc_tracking_id = "blogcrmagazi-20";
	amzn_assoc_linkid = "1734cf4716b343ed76ff56e93f223f4e";
     </script>
     <script src="//z-na.amazon-adsystem.com/widgets/q?ServiceVersion=20070822&Operation=GetScript&ID=OneJS&WS=1"></script>
    </div>			</div>
		<div id="text-12" class="widget widget_text"><div class="widget-top"><h4>Follow us on social</h4><div class="stripe-line"></div></div>
						<div class="widget-container">			<div class="textwidget"><a href="https://twitter.com/Blogcritics" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://twitter.com/Blogcritics', 'Tweets by @Blogcritics');" class="twitter-timeline"  data-widget-id="331833586783240193">Tweets by @Blogcritics</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
</div>
		</div></div><!-- .widget /-->			<div id="text-html-widget-5" class="text-html-box" style="text-align:center;">
			<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fpages%2FBlogcritics%2F132856246726018&amp;width&amp;height=290&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=428051813997156" scrolling="no" frameborder="0" style="border:none; overflow:hidden; height:290px;" allowTransparency="true"></iframe>			</div>
		<div id="recent-comments-2" class="widget widget_recent_comments"><div class="widget-top"><h4>Most Recent Comments</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Daniel Ramos</span> on <a href="http://blogcritics.org/anatomy-of-a-smear-heidi-cruz/#comment-7968999">Anatomy of a Smear: Heidi Cruz and the &#8220;North American Union&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Daniel Ramos</span> on <a href="http://blogcritics.org/anatomy-of-a-smear-heidi-cruz/#comment-7968998">Anatomy of a Smear: Heidi Cruz and the &#8220;North American Union&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Sam Fox</span> on <a href="http://blogcritics.org/anatomy-of-a-smear-heidi-cruz/#comment-7968997">Anatomy of a Smear: Heidi Cruz and the &#8220;North American Union&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Daniel Ramos</span> on <a href="http://blogcritics.org/anatomy-of-a-smear-heidi-cruz/#comment-7968995">Anatomy of a Smear: Heidi Cruz and the &#8220;North American Union&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Dr Joseph S Maresca</span> on <a href="http://blogcritics.org/book-review-should-we-fear-russia-by-dmitri-trenin/#comment-7968993">Book Review: ‘Should We Fear Russia?’ by Dmitri Trenin</a></li></ul></div></div><!-- .widget /--><div id="most-comments" class="widget widget_most_comments"><div class="widget-top"><h4>Hot Topics</h4><div class="stripe-line"></div></div>
						<div class="widget-container"><ul>
<li><a href="http://blogcritics.org/i-voted-for-donald-trump-white-nationalism-on-the-rise/"  title="'I Voted for Donald Trump' – White Nationalism on the Rise">'I Voted for Donald Trump' – White Nationalism on the Rise</a>- 3 comments</li><li><a href="http://blogcritics.org/music-review-donna-summer-the-ultimate-collection-3-cd-deluxe-edition/"  title="Music Review: Donna Summer - 'The Ultimate Collection' [3-CD Deluxe Edition]">Music Review: Donna Summer - 'The Ultimate Collection' [3-CD Deluxe Edition]</a>- 2 comments</li><li><a href="http://blogcritics.org/are-you-listening-2016-in-music-sophie-ellis-bextor-bright-light-bright-light-david-bowie-melanie-c-hikaru-utada-beyonce-and-more/"  title="Are You Listening? 2016 in Music: Sophie Ellis-Bextor, Bright Light Bright Light, David Bowie, Melanie C, Hikaru Utada, Beyoncé and more">Are You Listening? 2016 in Music: Sophie Ellis-Bextor, Bright Light Bright Light, David Bowie, Melanie C, Hikaru Utada, Beyoncé and more</a>- 1 comments</li><li><a href="http://blogcritics.org/interview-eimear-mcbride-author-of-the-lesser-bohemians/"  title="Interview: Eimear McBride, Author of 'The Lesser Bohemians'">Interview: Eimear McBride, Author of 'The Lesser Bohemians'</a>- 1 comments</li><li><a href="http://blogcritics.org/book-review-should-we-fear-russia-by-dmitri-trenin/"  title="Book Review: ‘Should We Fear Russia?’ by Dmitri Trenin">Book Review: ‘Should We Fear Russia?’ by Dmitri Trenin</a>- 1 comments</li></ul>
</div></div><!-- .widget /--></aside>	<div class="clear"></div>
</div><!-- .container /-->
<div class="ads-bottom">					<script type="text/javascript" src="http://ap.lijit.com/www/delivery/fpi.js?z=323844&u=Blogcritics&width=728&height=90"></script>				</div>
<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-3c">

			<div id="footer-first" class="footer-widgets-box">
			<div id="text-17" class="footer-widget widget_text"><div class="footer-widget-top"><h4> </h4></div>
						<div class="footer-widget-container">			<div class="textwidget"><table style="text-align: left; width: 100%;" border="0" cellpadding="0" cellspacing="0">
  <tbody>
    <tr>
      <td>



<table
 style="text-align: left; color: rgb(204, 204, 204); width: 600px;"
 border="0" cellpadding="0" cellspacing="5">
  <tbody>
    <tr>
      <td colspan="3" rowspan="1">
<big style="color: rgb(153, 153, 153);"><big><big><big><span style="font-weight: bold; font-style: italic;">Blogcritics Magazine</span></big></big></big></big><br style="font-weight: bold;">
      <span style="font-weight: bold; color: white;">BARBARA BARNETT, Executive Editor</span>
      <br style="font-weight: bold; color: white;">
      <span style="font-weight: bold; color: white;">JON SOBEL, Executive Editor</span><br>
      <hr width="650" />
      </td>
    </tr>
    <tr>
      <td style="vertical-align: top;"><span style="font-weight: bold; color: rgb(153, 153, 153);">TV Editor</span><br>
      <span style="color: white;">Barbara Barnett</span><br style="color: white;">
      <br>
      <span style="font-weight: bold; color: rgb(153, 153, 153);">Music Editors</span><br>
      <span style="color: white;">Charlie Doherty</span><br style="color: white;">
      <span style="color: white;">Chaz Lipp</span></td>
      <td style="vertical-align: top;"><span style="font-weight: bold; color: rgb(153, 153, 153);">Film Editor</span><br>
      <span style="color: white;">Barbara Barnett</span><br style="color: white;">
      <br>
      <span style="font-weight: bold; color: rgb(153, 153, 153);">Books Editor</span><br>
      <span style="color: white;"></span><span style="color: white;">Bill Sherman</span><br style="color: white;">
      </td>
      <td style="vertical-align: top;">
      <span  style="font-weight: bold; color: rgb(153, 153, 153);">Culture and Society Editors</span><br>
      <span style="color: white;">Jon Sobel</span><br style="color: white;">
      <span style="color: white;">Victor Lana</span><br style="color: white;">
      <span style="color: white;">Charlie Doherty (Sports)</span><br>
      <br>
      <span style="font-weight: bold; color: rgb(153, 153, 153);">Gaming Editor</span><br>
      <span style="color: white;">Josh Lasser</span></td>
    </tr>
    <tr>
      <td colspan="3" rowspan="1"><hr width="650" /></td>
    </tr>
    <tr>
      <td colspan="1" rowspan="1">
      <span style="font-weight: bold; color: rgb(153, 153, 153);">Comments Editors</span><br>
      <span style="color: white;">Christopher Rose</span><br style="color: white;">
      <span style="color: white;">Rob Knaggs</span><br>
      <br>
      <span style="font-weight: bold; color: rgb(153, 153, 153);"><br>
      
</td>
<td>
<aside id="text-4" class="widget widget_text"><h3 class="widget-title"><span>Write for Blogcritics</span></h3>
<div class="textwidget">
Are you a writer? Would you like to increase your visibility, hone your skills, and reach a very large and growing audience? Then Blogcritics may be for you.<br /><br />
If you would like to apply to be one of our writers, <a href="/?page_id=5000815">then click here!</a></div>
</aside>
<br /><br />

<aside id="text-4" class="widget widget_text"><h3 class="widget-title"><span>Legal</span></h3>
<div class="textwidget"><a href="/tos/">Terms of Service</a><br />
<a href="/privacy-policy/">Privacy Policy</a><br />
<a href="/dmca/">DMCA</a></div>
</aside>

</td>
</tr>
</tbody>
</table>
</div>
		</div></div><!-- .widget /-->		</div>
	
	

	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			Powered by <a href="http://www.wordpress.com">WordPress</a> | Designed by <a href="http://www.tielabs.com">Tielabs</a>		</div>
				<div class="social-icons icon_16">
		<a class="ttip" title="Rss" href="http://blogcritics.org/feed/" target="_blank"><i class="tieicon-rss"></i></a><a class="ttip" title="Facebook" href="https://www.facebook.com/Blogcritics-132856246726018/?ref=hl" target="_blank"><i class="tieicon-facebook"></i></a><a class="ttip" title="Twitter" href="http://twitter.com/blogcritics" target="_blank"><i class="tieicon-twitter"></i></a>	</div>

		
		<div class="alignleft">
			© Copyright 2016, All Rights Reserved		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->
	<div id="topcontrol" class="tieicon-up-open" title="Scroll To Top"></div>
        <script type="text/javascript">
        // <![CDATA[
        var disqus_shortname = 'blogcritics';
        (function () {
            var nodes = document.getElementsByTagName('span');
            for (var i = 0, url; i < nodes.length; i++) {
                if (nodes[i].className.indexOf('dsq-postid') != -1 && nodes[i].parentNode.tagName == 'A') {
                    nodes[i].parentNode.setAttribute('data-disqus-identifier', nodes[i].getAttribute('data-dsqidentifier'));
                    url = nodes[i].parentNode.href.split('#', 1);
                    if (url.length == 1) { url = url[0]; }
                    else { url = url[1]; }
                    nodes[i].parentNode.href = url + '#disqus_thread';
                }
            }
            var s = document.createElement('script');
            s.async = true;
            s.type = 'text/javascript';
            s.src = '//' + disqus_shortname + '.disqus.com/count.js';
            (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
        }());
        // ]]>
        </script>
        <script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/blogcritics.org\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.5.1'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201651'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/sidelines-widget/js/lightningjs-embed.min.js?ver=0.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var SidelinesRestApi = {"createPostNonce":"aa950e25b9","pubCode":"462a123b9335fe539c3b","postID":"5466959","permalink":"http:\/\/blogcritics.org\/preview-snowglobe-music-festival-2016-in-south-lake-tahoe-california-dec-29-31-2016\/","remoteUrl":"sidelinesapp.com","version":"0.8"};
/* ]]> */
</script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/sidelines-widget/js/sidelines.js?ver=0.8'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/simple-share-buttons-adder/js/ssba.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/themes/sahifa/js/tie-scripts.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-includes/js/comment-reply.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-includes/js/wp-embed.min.js?ver=4.6.1'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/jetpack/_inc/postmessage.js?ver=4.3.2'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/jetpack/_inc/jquery.jetpack-resize.js?ver=4.3.2'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/jetpack/_inc/jquery.inview.js?ver=4.3.2'></script>
<script type='text/javascript' src='http://blogcritics.org/wp-content/plugins/jetpack/modules/likes/queuehandler.js?ver=4.3.2'></script>
		<iframe src='http://widgets.wp.com/likes/master.html?ver=20160429#ver=20160429' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script type='text/javascript' src='http://stats.wp.com/e-201651.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:4.3.2',blog:'58763955',post:'5466959',tz:'-6',srv:'blogcritics.org'} ]);
	_stq.push([ 'clickTrackerInit', '58763955', '5466959' ]);
</script>
<script type='text/javascript'>
(function(){
	spoutjs=document.createElement('script'),firstjs=document.getElementsByTagName('script')[0];
	spoutjs.async=1;
	spoutjs.src='//cdn.spoutable.com/bdbc1df3-0926-4aec-9cf8-63e886361baa/spoutable.js';
	firstjs.parentNode.insertBefore(spoutjs,firstjs)
})();
</script>
</body>
</html>
<!-- Dynamic page generated in 2.776 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2016-12-23 00:20:31 -->

<!-- Compression = gzip -->